cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1759
Views
0
Helpful
9
Replies

IR829 WAN failover to Cellular and viceversa

bas123
Level 1
Level 1

Hi,

Can someone help me how to configure a IR829 for WAN failover to cellular 0 and vice-versa depending on network presence or failure

Thanks

Bas

9 Replies 9

Hello,

 

the below should do it (important parts marked in bold):

 

version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IR800
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ethernet lmi ce
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 20
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
license udi pid IR829GW-LTE-GA-ZK9 sn FGL19472082
!
redundancy
!
controller Cellular 0
lte sim max-retry 0
lte failovertimer 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
interface GigabitEthernet0
no ip address
shutdown
!
track 1 ip sla 1 reachability
!
interface GigabitEthernet1
switchport
switchport mode access
switchport access vlan 10
desc To Switch Fa0/1
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
description Link to Primary ISP
ip address dhcp
duplex auto
speed auto
!
interface Cellular0
description Link to Backup ISP
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
no ip http server
no ip http secure-server
!
ip nat inside source route-map ISP_1 interface GigabitEthernet5 overload
ip nat inside source route-map BACKUP_ISP interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet5 dhcp track 1
ip route 0.0.0.0 0.0.0.0 Cellular0 20
!
route-map ISP_1 permit 10
match ip address 1
match interface GigabitEthernet5
!
route-map BACKUP_ISP permit 10
match ip address 1
match interface Cellular0
!
event manager applet CLEAR_NAT
event track 1 state any
action 1.0 cli command “enable”
action 2.0 cli command “clear ip nat translation *”
action 3.0 cli command "end"
!
dialer-list 1 protocol ip list 1
!
access-list 1 permit 192.168.10.0 0.0.0.255
!
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet5
frequency 3
!
ip sla 1 start-time now life forever
!
control-plane
!
line con 0
stopbits 1
line 1
stopbits 1
line 2
script dialer lte
stopbits 1
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 100000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 100000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
login
transport input none
!
no scheduler max-task-time
!
end

Hi @Georg Pauwen ,

Thank you for your reply.
I have followed almost same config as yours except WAN port. I am using Gi0 instead of Gi5, as I am connecting through SFP.
Issue: I couldn't get internet (ping 8.8.8.8) even when connected to WAN only without cellular0, what could be the issue here at WAN side?
hoping for your help again.
sh running-config below:

 

controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
vlan 10
name data10
!
track 1 ip sla 1 reachability

interface GigabitEthernet0
description Primary Link
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface GigabitEthernet1
description Connection to LAN side
switchport access vlan 10
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface Wlan-GigabitEthernet0
no ip address
!
interface Wpan2
no ip address
ieee154 txpower 25
no ieee154 fec-off
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0
description Secondary Link
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
!
interface Cellular1
no ip address
encapsulation slip
!
interface wlan-ap0
ip unnumbered Vlan1
!
interface Vlan1
description $ETH_LAN$
ip address 10.10.10.1 255.255.255.128
ip tcp adjust-mss 1452
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip dns server
ip nat inside source route-map Primary_Link interface GigabitEthernet0 overload
ip nat inside source route-map Secondary_Link interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1
ip route 0.0.0.0 0.0.0.0 Cellular0 20
!
ip sla 1
icmp-echo 8.8.8.8 source-interface GigabitEthernet0
frequency 30
ip sla schedule 1 life forever start-time now
dialer-list 1 protocol ip list 1
ipv6 ioam timestamp
!
route-map Secondary_Link permit 10
match ip address 1
match interface Cellular0
!
route-map Primary_Link permit 10
match ip address 1
match interface GigabitEthernet0
!
!
access-list 1 permit 192.168.10.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.127
!
control-plane

Hello Bas,

 

the configuration looks good actually. What is the LED status of interface GigabitEthernet0 ? Do you get an IP address on that interface at all ?

Hi,
Yes I get IP address at Gi0 and even LED is Green.
When I take WAN cable out of Gi0, it still keeping IP and status as UP. It's behaving weird.
How could I know what medium its using while I ping/access internet?
sh track - always showing Reachability is Down.

Hi @Georg Pauwen,

I see the problem is in this line

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 track 1

With this, "sh track" always shows DOWN as it don't help data pass pass through Gi0.

And this statement is in correct,

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0 dhcp track 1

Hope for your support

Thanks

Bas

Hello Bas,

 

by default, the ping is sourced from the outgoing interface, GigabitEthernet0 in your case. Either way, if you get a public IP address on GigabitEthernet0, the IP SLA, in theory, should work, and reachability should be up.

 

When you do a 'show ip route' what default route is displayed in your routing table ?

Hello Bas,

 

try and add the static route below:

 

ip route 8.8.8.8 255.255.255.255 GigabitEthernet0 dhcp

Hello


@bas123 wrote:

I couldn't get internet (ping 8.8.8.8) even when connected to WAN only without cellular0, what could be the issue here at WAN side?

nterface Vlan1
description $ETH_LAN$
ip address 10.10.10.1 255.255.255.128
ip tcp adjust-mss 1452

nterface GigabitEthernet1
description Connection to LAN side
switchport access vlan 10
no ip address


You sure your have suppose to static addressing here, if so make youve apllied the correct ip/subnet mask

Also check your interface status.

show ip interface brief

 

Regards you cellular connection,make sure the sim is actually in the correct slot, default is 0 ?
show cellular 0 profile
show interface cellular
show cellular alll

 

Lasty I dont see you allowing ip regards the defined dialer group
dialer-list 1 protocol ip permit

 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello

Can you elaborate on the actual topology- 

Are  you using single or multiple wan rtrs, Network translation any routing protocols ?


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card