cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2397
Views
0
Helpful
9
Replies

ISP BGP setup with redendency question

satish.txt1
Level 1
Level 1

I have following scenario where my ISP gave me two link primary and secondary (for redendency and ISP sending *Default Route* on eBGP) and i have terminated on my L3 switch where i am planning to run BGP but i have question related what i should run between "sw1" and "sw2"?   iBGP or OSFP ?

 

Note: by mistake i mentioned eBGP between sw1 and sw2 but its actually iBGP (it was typo)

 

Screen Shot 2018-03-01 at 12.40.21 PM.png

9 Replies 9

Rich Uline
Level 1
Level 1

Satish,

The SW1-to-SW2 link should only run iBGP. SW1 and SW2 will be redistributing eBGP routes into OSPF (not iBGP routes). If there is a failure on one ISP connection, the other edge device will learn all BGP routes from the other edge device. The edge device that lost the ISP connection will also stop redistributing all BGP routes as the only BGP learned routes will be internal. Because SW3 and SW4 are connected to both routers, they will learn all routes only from the OSPF connection to the edge device which still has an ISP connection.

You are suggesting to run iBGP between sw1 and sw2 point-to-point link and all other internal L3 interface should run OSFP right? 

That is correct.

Very strange issue, i did following but look like its not peeing iBGP.  in summary i am not seeing any peer even i reset my BGP session, I have setup loopback0 for neighbor 

 

 

 

sw2# sh ip bgp summary
BGP summary information for VRF default, address family IPv4 Unicast
BGP router identifier 192.168.1.19, local AS number 393218
BGP table version is 325, IPv4 Unicast config peers 1, capable peers 1
160 network entries and 160 paths using 35200 bytes of memory
BGP attribute entries [58/9048], BGP AS path entries [46/564]
BGP community entries [15/572], BGP clusterlist entries [0/0]

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
74.xx.xx.61   4 200     357     120      325    0    0 00:07:20 159

 

My config on sw2 ( i have same config on sw1 but ips are different) 

 

router bgp 100
  router-id 192.168.1.19
  log-neighbor-changes
  address-family ipv4 unicast
    network 74.xx.xx.0/24
  neighbor 74.xx.xx.61
    remote-as 200
    address-family ipv4 unicast
  neighbor 192.168.1.20
    remote-as 100
    update-source loopback0

 

Do the switches know how to reach each other's loopback IPs ? 

 

Jon

Yes i can ping each other loopback0 interface, i did set each other routes, (I have Nexus 9300 switches)

 

I am using 10.0.0.1/30 for point to point link 

 

ip route 192.168.1.20/32 10.0.0.1

 

interface loopback0
  description ROUTER-ID
  ip address 192.168.1.19/32

these two /32 's are different. one is .20 another is a .19.!?

 

can you debug bgp events and see if its just a straight connectivity problem wht the two cant peer or whether it is something else like an AS typo for instance.

Please remember to rate useful posts, by clicking on the stars below.

This is interesting and i have no clue why, as soon as i added following option it works! can someone explain me?

 

 

address-family ipv4 unicast
      next-hop-self
      soft-reconfiguration inbound

I can see them now

 

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
74.xx.xx.61   4 200    3897    2789     2252    0    0 15:00:27 157
192.168.1.19    4 100
                           1035    1048     2252    0    0 15:11:54 159

if u mean option next-hop-self so it's because EBGP change next hop only  when go btw different AS, so when 2 routers are in  iBGP (in the same AS)  we need to use this next-hop-self otherwise ibgp router doesn't not know how to send traffic to outside.

Review Cisco Networking for a $25 gift card