01-30-2017 01:26 PM - edited 03-05-2019 07:56 AM
I have an interface connected to an isp which is the DHCP server. I need to create two subinterfaces that receive two different IP addresses from the ISP. In one subinterface I will do NAT and the other will not.
What would be the best solution to receive IP addresses from the ISP?
interface G0
no ip address
interface g0/0.2
encapsulation dot1q 2
ip address dhcp ¿?
ip vrf forwarding OUTSIDE 1
interface g0/0.3
encapsulation dot1q 3 ip address dhcp ¿?
ip nat outside
ip vrf forwarding OUTSIDE 3
!
interface vlan 3
ip vrf forwarding OUTSIDE3
ip nat inside
ip address xxx
THANK IN ADVANCE
01-30-2017 02:35 PM
Hello,
I think you need the 'ip helper-address' command on the subinterfaces, with the IP address being the one of the DHCP server...
01-30-2017 02:57 PM
Hi,
Do you know if the provider is using your MAC addresses as identifier? If they are, you could configure the following command under your sub interfaces. Assuming the ISP has a local dhcp pool and the configuration is correct and the dhcp pools are different to avoid overlapping.
int g0/0.2
ip address dhcp
ip address dhcp client-id g0/0.2
int g0/0.3
ip address dhcp
ip address dhcp client-id g0/0.3
Could you please confirm the MAC addresses displayed on the sub-interfaces? I have not used it with subinterfaces before but you can try.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide