01-21-2021 12:12 AM
Hello,
I am a complete beginner in networking, started about a month ago. I was given a task to configure NAT Overload and DHCP on an ISR 1100 using a /31 subnet. Unfortunately I can't seem to find any guide on how to do this task as all instructions on pages are using multiple routers or ISP provided addresses while I have only one router and only the /31 address.
How am I supposed to configure this?
Sorry if this is a stupid question
Solved! Go to Solution.
01-21-2021 12:30 AM
Hello,
do you mean your router gets a /31 DHCP assigned IP address from your ISP ? If that is what you are asking, all you need to do is the below. The IP address you get from the ISP doesn't matter, as you are overloading the interface.
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8 8.8.4.4
!
interface GigabitEthernet0/0/0
description Link to ISP
ip address dhcp
ip nat outside
!
interface Vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
ip route 0,0.0.0 0.0.0.0 GigabitEthernet0/0/0 dhcp
!
ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
01-21-2021 03:54 AM
Hello,
not sure what you mean by 'intranet'...can you elaborate ?
For SSH access, you need to configure the below:
hostname ISR1100
!
username admin privilege 15 password 0 cisco
!
ip domain-name yourdomain.com
!
crypto key generate rsa 2048
!
ip ssh version 2
!
line vty 0 4
transport input ssh
login local
01-21-2021 12:30 AM
Hello,
do you mean your router gets a /31 DHCP assigned IP address from your ISP ? If that is what you are asking, all you need to do is the below. The IP address you get from the ISP doesn't matter, as you are overloading the interface.
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8 8.8.4.4
!
interface GigabitEthernet0/0/0
description Link to ISP
ip address dhcp
ip nat outside
!
interface Vlan 1
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
ip route 0,0.0.0 0.0.0.0 GigabitEthernet0/0/0 dhcp
!
ip nat inside source list 1 interface GigabitEthernet0/0/0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
01-21-2021 03:25 AM
Hello,
I was just given an address by my boss and told to configure NAT and DHCP using it. What I meant was that while searching for solutions I came across multiple websites using an address provided by the ISP and I wasn't sure how to apply those to my situation.
Another question is the config you provided me with above going to allow me to configure Intranet and remote access using SSH as well?
Thank you for your time
01-21-2021 03:54 AM
Hello,
not sure what you mean by 'intranet'...can you elaborate ?
For SSH access, you need to configure the below:
hostname ISR1100
!
username admin privilege 15 password 0 cisco
!
ip domain-name yourdomain.com
!
crypto key generate rsa 2048
!
ip ssh version 2
!
line vty 0 4
transport input ssh
login local
01-21-2021 04:03 AM
I assume I got something wrong on the intranet part, I'll have to ask it over but thank you on everything else! You really helped me a lot!
Sometimes all of those guides make it seem so complex but you made it look so easy.
Thank you!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide