05-06-2019 08:25 AM - edited 05-06-2019 08:26 AM
I have an ISR 4331 and I would like to configure a voice and data VLAN on it's layer 3 interface that connects to a layer 2 switch. Which option is correct?
Option 1:
vlan 100
name Data
!
vlan 111
name Voice
!
interface GigabitEthernet0/0/1
description Inside LAN Interface
switchport mode access
switchport access vlan 100,111
speed 1000
duplex full
!
interface vlan 100
description Inside LAN vlan
ip address 192.168.0.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
!
interface vlan 111
description Voice vlan
ip address 10.168.11.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
Option 2:
vlan 100
name Data
!
vlan 111
name Voice
!
interface GigabitEthernet0/0/1
description Inside LAN Interface
switchport native vlan 100
switchport mode trunk
switchport trunk allowed vlan 100,111
speed 1000
duplex full
!
interface vlan 100
description Inside LAN vlan
ip address 192.168.0.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
!
interface vlan 111
description Voice vlan
ip address 10.168.11.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
Thanks
GW
Solved! Go to Solution.
05-06-2019 12:29 PM
Trunking is my preference.
05-06-2019 09:45 AM
In ISR if you have 2 Interface, i prefer to use port-channel with Switch, so you have redundent link available in case one port go down due to some reason.
05-06-2019 09:52 AM
Agree.. but what is the preferred option as far as trunking data and voice on the port versus making it an access port with a data and voice vlan?
GW
05-06-2019 12:29 PM
Trunking is my preference.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide