cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
430
Views
5
Helpful
1
Replies

L2 Bridging over L3 WAN Link or L2 Encrypted -- SVI for Pseudowire on ISR 2911 G2 with DATA License

tom.neteng
Level 1
Level 1

I'm attempting to either extend a VLAN across an L3 link (VTI VTPN across E-Line) connected by two ISR G2 2911 routers utilizing a pseudowire or just switch to L2 encrypted.  Site one's router is connected by a routed link to the core and site two is a router on a stick.

 

However, I don't have an extra port or HWIC to dedicate entirely to a single SVI on either side for the designated VLAN, in order to separate that traffic from the primary routed interface.  Can I just use a subinterface on one side on top of the routed interface?  And the existing subinterface on the other side?

 

So something like:

 

R1

interface Loopback540

ip address 10.55.40.251 255.255.255.255

!

l2tp-class Class.To.Branch
digest secret supersecret hash sha

!

pseudowire-class PW.To.Branch
encapsulation l2tpv3

protocol l2tpv3 Class.To.Branch
ip local interface Loopback540

!

interface GigabitEthernet0/2
ip address 10.0.0.2 255.255.255.252
ip pim sparse-dense-mode
!

interface GigabitEthernet0/2.540
ip address 10.5.40.1 255.255.255.0
encapsulation dot1q 540

ip pim sparse-dense-mode

xconnect 10.55.40.2 540 pw-class PW.To.Branch

 

--

 

R2

interface Loopback540

ip address 10.55.40.252 255.255.255.255

!

l2tp-class Class.To.HQ
digest secret supersecret hash sha

!

pseudowire-class PW.To.HQ
encapsulation l2tpv3

protocol l2tpv3 Class.To.HQ

ip local interface Loopback540

!

interface GigabitEthernet0/2
ip address 10.0.0.2 255.255.255.252
ip pim sparse-dense-mode
!

interface GigabitEthernet0/0
no ip address

!
interface GigabitEthernet0/0.540
ip address 10.5.40.2 255.255.255.0
encapsulation dot1q 540

ip pim sparse-dense-mode
xconnect 10.55.40.1 540 pw-class PW.To.HQ

!

 

Tom

1 Reply 1

Philip D'Ath
VIP Alumni
VIP Alumni

You can do a sub-interface to a sub-interface.