11-17-2014 07:58 AM - edited 03-05-2019 12:11 AM
Dear All,
I need to built a scenario where i am using two ISP's for redundancy for my internal network and at the same time wants to load balance in such a way that my first packet going outside the network (using NAT) goes from first ISP's public ip address and second packet going outside the network (using NAT) goes from second ISP's public ip address.
Need your help
Thank You
11-17-2014 12:20 PM
Hello
I tried to lab this up - I managed to use a first hop protocol (hrsp) to a redundant HRSP & NAT configuration - however I have tried GLBP and at present not been successful in getting it to work-
Here is what I got with HRSP:
--- R2
r1 ----- internet host 100.100.100.100
---- R3
R2
-----
interface FastEthernet0/0
Description Link to LAN
ip address 10.1.123.252 255.255.255.0
ip nat inside
standby 123 ip 10.1.123.254
standby 123 priority 115
standby 123 preempt
standby 123 name HRSP1
standby 123 track FastEthernet0/1 50
interface FastEthernet0/1
Description Link to ISP1
ip address 1.1.1.2 255.255.255.0
ip nat outside
standby 234 ip 1.1.1.254
standby 234 priority 115
standby 234 preempt
standby 234 name HRSP2
standby 234 track FastEthernet0/0 50
ip route 100.100.100.100 255.255.255.255 FastEthernet0/1 1.1.1.4
ip nat inside source static 10.1.123.251 1.1.1.1 redundancy HRSP1
R3
-----
interface FastEthernet0/0
Description Link to LAN
ip address 10.1.123.253 255.255.255.0
ip nat inside
standby 123 ip 10.1.123.254
standby 123 preempt
standby 123 name HRSP1
standby 123 track FastEthernet0/0
interface FastEthernet0/1
Description Link to ISP2
ip address 1.1.1.3 255.255.255.0
ip nat outside
standby 234 ip 1.1.1.254
standby 234 preempt
standby 234 name HRSP2
standby 234 track FastEthernet0/1 50
ip route 100.100.100.100 255.255.255.255 FastEthernet0/1 1.1.1.4
ip nat inside source static 10.1.123.251 1.1.1.1 redundancy HRSP1
R2#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 1.1.1.1:7 10.1.123.251:7 100.100.100.100:7 100.100.100.100:7
icmp 1.1.1.1:12 10.1.123.251:12 100.100.100.100:12 100.100.100.100:12
--- 1.1.1.1 10.1.123.251 --- ---
R2#sh standby brief
Interface Grp Pri P State Active Standby Virtual IP
Fa0/0 123 115 P Active local 10.1.123.253 10.1.123.254
Fa0/1 234 115 P Active local 1.1.1.3 1.1.1.254
R3#sh stan brief
Interface Grp Pri P State Active Standby Virtual IP
Fa0/0 123 100 P Standby 10.1.123.252 local 10.1.123.254
Fa0/1 234 100 P Standby 1.1.1.2 local 1.1.1.254
R3#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 1.1.1.1 10.1.123.251 --- --
R2
int fa0/1
shut
R2#sh standby brief
Interface Grp Pri P State Active Standby Virtual IP
Fa0/0 123 65 P Standby 10.1.123.253 local 10.1.123.254
Fa0/1 234 115 P Init unknown unknown 1.1.1.254
R2#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 1.1.1.1 10.1.123.251 --- ---
3#sh stan brief
|
Interface Grp Pri P State Active Standby Virtual IP
Fa0/0 123 100 P Active local 10.1.123.252 10.1.123.254
Fa0/1 234 100 P Active local unknown 1.1.1.254
R3#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 1.1.1.1:7 10.1.123.251:7 100.100.100.100:7 100.100.100.100:7
icmp 1.1.1.1:12 10.1.123.251:12 100.100.100.100:12 100.100.100.100:12
--- 1.1.1.1 10.1.123.251 --- ---
res
Paul
11-18-2014 07:04 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
If I understand your question correctly, if you have equal cost routes, to same destination, via both ISP links, and if CEF is enabled, CEF packet-by-packet load balancing might do the trick. However, splitting packets from a single flow, is generally a very bad idea.
Better would be to round robin egress flows across both your ISPs. Best would be to use something like OER/PfR to dynamically load balance egress flows across both you ISPs.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide