08-24-2023 10:26 PM
Hello Dears,
In our environment, we have a Cisco 2911 Router (IOS). We are now planning to replace it with a Cisco C8200L Router (IOS-XE). In the old router, we have BVI implemented. Since this feature is called BDI in IOS-XE, I have migrated the configuration accordingly.
Cisco 2911 Router (IOS) configuration:
bridge irb
bridge 1 priority 0
bridge 1 protocol ieee
bridge 1 route ip
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
no cdp enable
bridge-group 1
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
no cdp enable
bridge-group 1
!
interface BVI1
ip address 192.168.50.1 255.255.255.0
!
Cisco C8200L Router (IOS-XE) configuration:
int g0/0/1
service instance 5 ethernet
encapsulation untagged
bridge-domain 5
int g0/0/2
service instance 5 ethernet
encapsulation untagged
bridge-domain 5
int BDI5
ip address 192.168.50.1 255.255.255.0
!
Router interfaces Gi0/0/1 and Gi0/0/2 are connected to two physical switches in a stack (appearing as one logical switch) through ports Gi1/0/1 and Gi2/0/1, and these ports are configured in access mode.
Switch configuration:
int gi1/0/1
switchport mode access
switchport access vlan 800
spanning-tree portfast
int gi2/0/1
switchport mode access
switchport access vlan 800
spanning-tree portfast
Previously, in the old router, everything worked correctly, but when I plugged in cables to the new router, connectivity was lost. In the logs, I see these errors:
08-25-2023 06:29 AM
The traffic flows when you shut an interface???
That aside, I'm wondering whether the 8200L has data plane hardware, and because of uses a lower capacity CPU. If so, if BDI traffic must be done on CPU, your volume of traffic is being limited.
If the forgoing is true, the only solution might be, don't use the 8200L in this manner. (A 4 gig port dumb L2 switch might be an inexpensive work around solution.)
Hopefully, someone else will provide a better issue explanation and solution.
08-28-2023 01:51 AM
Two interfaces combined into one Bridge domain interface. When only one interface is up, traffic flows; when both interfaces are up, the connection is lost.
08-28-2023 03:50 AM
Hello
Try rewrite/drop the tag as it comes into the BDI for the switch stack
Int xx
rewrite ingress tag pop 1 symmetric
08-28-2023 08:44 AM
Hello @Abdulla Ydyrys ,
the messages below:
>>
Aug 24 2023 17:52:14.516 ALM: %IOSXE-5-PLATFORM: R0/0: cpp_cp: QFP:0.0 Thread:000 TS:00000000297525326090 %PUNT_INJECT-5-DROP_PUNT_CAUSE: punt policer drops packets, cause: for-us-ctrl (0x37) from BDI5 src ip: 192.168.50.2
IOSXE_QFP-2-LOAD_EXCEED: Slot: 0, QFP:0, Load 85% exceeds the setting threshold 80%
Make me think that with two interfaces connected a bridging loop is formed.
When you shut one interface the bridging loop is removed and connectivity works again.
Hope to help
Giuseppe
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide