09-12-2018 09:19 AM
ip vrf intvlans
!
interface Port-channel18
ip address 1.1.1.1 255.255.255.252
!
interface Vlan15
ip address 11.22.33.44 255.255.255.0
!
interface Vlan105
ip vrf forwarding intvlans
ip address 192.168.105.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip vrf intvlans ! interface Port-channel1 ip address 1.1.1.2 255.255.255.252 ! interface Vlan15 ip address 11.22.33.45 255.255.255.0 ! interface Vlan105 ip vrf forwarding intvlans ip address 192.168.105.2 255.255.255.0
router ospf 2 vrf intvlans router-id 192.168.105.1 log-adjacency-changes capability vrf-lite network 192.168.105.0 0.0.0.255 area 0 ! router ospf 1 router-id 11.22.33.44 log-adjacency-changes network 11.22.33.0 0.0.0.255 area 0
router ospf 2 vrf intvlans router-id 192.168.105.2 log-adjacency-changes capability vrf-lite network 192.168.105.0 0.0.0.255 area 0 ! router ospf 1 router-id 11.22.33.45 log-adjacency-changes network 11.22.33.0 0.0.0.255 area 0
09-13-2018 11:36 AM
I do not quite understand how the global ospf can work, as I do not see the port-channel as part of you ospf configuration.
If you want the vrf lite configuration to work between the two routers, you would need to configure a subinterface off the port-channel that would belong to vrf intvlans.
Regards,
09-14-2018 03:19 AM
Thank you for your replay, Harold. The only problem is that RouterB is an old 4948 L3 switch, which does not support sub-interfaces, therefore I can't create them.
Is there any other option to accomplish this? I don't even want vrf lite, I just need to get that 192.168.105.0/24 working. Should I use other dynamic routing protocols like eigrp or bgp for that?
09-14-2018 05:51 AM
On the 4948 make the etherchannel a L2 trunk and use SVIs, that should work fine.
The point Harold made still stands though, it is unclear how the non VRF OSPF is working as you are not running OSPF on the port channel interfaces.
Jon
09-14-2018 06:03 AM
Can't be done with routed ports somehow? I would like to avoid L2 trunk ports, that is why I would like to use dynamic routing protocols. If the L2 network and trunk ports would be an option, I don't even need ospf or any dynamic routing protocols.
Anyway, I don't know how exactly my non-vrf ospf works, but it works for sure. An example from RouterB, only the prefixes has been modified:
sh ip route ospf 1
1.0.0.0/8 is variably subnetted, 17 subnets, 4 masks
O x.y.z.32/30 [110/2] via 11.22.33.44, 02:20:56, Port-channel1
O x.y.z.12/30 [110/2] via 11.22.33.44, 02:20:56, Port-channel1
O x.y.z.8/30 [110/2] via 11.22.33.44, 02:20:56, Port-channel1
O x.y.z.0/24 [110/2] via 11.22.33.44, 02:20:56, Port-channel1
...
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide