cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

918
Views
0
Helpful
4
Replies
Highlighted
Beginner

MLS QoS map command missing on 2801

I am trying to run the following commands on a 2801 router, but the commands are missing:

mls qos

mls qos map cos-dscp 0 8 16 40 32 46 48 56

The only QoS command i have in global config is (no MLS qos) :

REMOTE-ROUTER1(config)#qos ?

  restore-show-output  Restore old show output

  shape-timer          Set the HQF shape timer interval

The router is running IOS:

System image file is "flash:c2801-ipbasek9-mz.151-4.M5.bin"

can someone advise am i just running the incorrect IOS or am i missing somehting, i need to change the QoS Map for my Nortel VoIP.  The VoIP phones connect to a 3750 PoE which used to conenct to a 2651XM to route VoIP and data traffic over the same copper pairs (WAN link to hub site) hence the need for a Service policy but being Nortel phones, require changing the cos-dscp map.  the 2801 is going to replace the 2651XM using a new HWIC.

Thanks

Jeff

Everyone's tags (7)
4 REPLIES 4
Cisco Employee

MLS QoS map command missing on 2801

Hello Jeff,

MLS QoS stands for multilayer swicthing QoS. 2801 is strictly MQC. Nortel phones connect to 3750 right? Why not configure this on the 3750?

Regards,

Ryan

Beginner

MLS QoS map command missing on 2801

It is set on the 3750, i was under the impression i had to also set it on the router as well? 

Cisco Employee

MLS QoS map command missing on 2801

If the goal is to mark cos 5 to dscp 46 and you have configured mls qos trust cos on the Nortel phone ports then the 2801 will not change the marking unless configured to do so. Is there anything else you are trying to do besides marking cos 5 to dscp 46?

Beginner

MLS QoS map command missing on 2801

Ryan, what i am (maybe mistakenly) trying to do is copy the same config off the current router on to the new router.

all clients connect a 3750, which mas the cos-dscp map, which in turn is trunked to the router:

3750

mls qos

mls qos map cos-dscp 0 8 16 40 32 46 48 56

interface range fa 1/0/1 - 48

switchport access vlan 100

switchport voice vlan 200

priority-queue out

mls qos trust dscp

spanning-tree portfast

The current config on the 2651XM is as follows:

mls qos map cos-dscp 0 8 16 40 32 46 48 56

controller DSL 0/3/0

mode atm

line-term co

line-mode 2-wire line-zero

dsl-mode shdsl symmetric annex B

line-rate auto

class-map match-any Voice-Media

match ip dscp ef

class-map match-any Voice-Signalling

match ip dscp cs5

!

policy-map Torbay_VOIP

class Voice-Media

  priority percent 20

class Voice-Signalling

  bandwidth percent 5

class class-default

  fair-queue

  random-detect

interface ATM0/3/0

bandwidth 2312

no ip address

atm restart timer 300

no atm ilmi-keepalive

!

interface ATM0/3/0.1 point-to-point

bandwidth 2312

ip address 172.25.200.241 255.255.255.252

cdp enable

pvc 0/32

  vbr-nrt 2188 2188 1

  no broadcast

  encapsulation aal5snap

  service-policy output Torbay_VOIP

Hence, i was trying to put the mls qos command onto the 2801 the same as the 2651XM. 

Regards

jeff

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here