cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1230
Views
0
Helpful
4
Replies

MP-BGP Lab configuration not working

afgitdepartment
Level 1
Level 1

Hello,

I am trying to learn about MP-BGP and the example configurations I find on the net are not working in my dynamips lab. 

I have two routers (EAST and WEST) connected via their fa0/0 interfaces with 10.0.9.0/30 subnet between them.

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname EAST

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip vrf VRF1

rd 209:1

route-target export 209:1

route-target import 209:1

!

ip vrf VRF2

rd 209:2

route-target export 209:2

route-target import 209:2

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

!

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface Loopback100

ip vrf forwarding VRF1

ip address 100.103.196.1 255.255.255.252

!

interface Loopback200

ip vrf forwarding VRF2

ip address 200.103.196.1 255.255.255.252

!

interface FastEthernet0/0

ip address 10.0.9.2 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

router eigrp 1

passive-interface default

no passive-interface FastEthernet0/0

network 1.1.1.1 0.0.0.0

network 10.0.9.0 0.0.0.3

no auto-summary

!

router bgp 209

bgp log-neighbor-changes

neighbor 1.1.1.2 remote-as 209

neighbor 1.1.1.2 update-source Loopback0

!

address-family ipv4

  neighbor 1.1.1.2 activate

  neighbor 1.1.1.2 send-community extended

  no auto-summary

  no synchronization

exit-address-family

!

address-family ipv4 vrf VRF2

  redistribute connected

  no synchronization

exit-address-family

!

address-family ipv4 vrf VRF1

  redistribute connected

  no synchronization

exit-address-family

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname WEST

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

ip vrf VRF1

rd 209:1

route-target export 209:1

route-target import 209:1

!

ip vrf VRF2

rd 209:2

route-target export 209:2

route-target import 209:2

!

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

interface Loopback0

ip address 1.1.1.2 255.255.255.255

!

interface Loopback100

ip vrf forwarding VRF1

ip address 109.103.196.1 255.255.255.252

!

interface Loopback200

ip vrf forwarding VRF2

ip address 209.103.196.1 255.255.255.252

!

interface FastEthernet0/0

ip address 10.0.9.1 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

router eigrp 1

passive-interface default

no passive-interface FastEthernet0/0

network 1.1.1.2 0.0.0.0

network 10.0.9.0 0.0.0.3

no auto-summary

!

router bgp 209

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 209

neighbor 1.1.1.1 update-source Loopback0

!

address-family ipv4

  neighbor 1.1.1.1 activate

  neighbor 1.1.1.1 send-community extended

  no auto-summary

  no synchronization

exit-address-family

!

address-family ipv4 vrf VRF2

  redistribute connected

  no synchronization

exit-address-family

!

address-family ipv4 vrf VRF1

  redistribute connected

  no synchronization

exit-address-family

!

ip forward-protocol nd

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

end

WEST# SHOW IP Bgp SUmmary

BGP router identifier 1.1.1.2, local AS number 209

BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

1.1.1.1         4   209      10      10        1    0    0 00:07:13        0

EAST#SH IP BGp SUmmary

BGP router identifier 1.1.1.1, local AS number 209

BGP table version is 1, main routing table version 1

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

1.1.1.2         4   209      10      10        1    0    0 00:07:02        0

EAST#SHOW IP BGp VPNv4 ALL

BGP table version is 5, local router ID is 1.1.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 209:1 (default for vrf VRF1)

*> 100.103.196.0/30 0.0.0.0                  0         32768 ?

Route Distinguisher: 209:2 (default for vrf VRF2)

*> 200.103.196.0/30 0.0.0.0                  0         32768 ?

WEST#SHOW IP BGp VPNv4 ALL

BGP table version is 8, local router ID is 1.1.1.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale

Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path

Route Distinguisher: 209:1 (default for vrf VRF1)

*> 109.103.196.0/30 0.0.0.0                  0         32768 ?

Route Distinguisher: 209:2 (default for vrf VRF2)

*> 209.103.196.0/30 0.0.0.0                  0         32768 ?

I am expecting on both routers to see these prefixes in the VRFs that are tied to the loopbacks

What am I missing?

2 Accepted Solutions

Accepted Solutions

Raju Sekharan
Cisco Employee
Cisco Employee

Hi

You have not configured "address-family vpnv4" under bgp

Thanks

Raju

View solution in original post

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello,

the exchange of VPNv4 routes requires the configuration of address-family vpnv4 you have to replicate the configuration for address-family ipv4 under family vpnv4

the key commands are neigh activate and neigh send-community extended to be given under af

Hope to help

Giuseppe

View solution in original post

4 Replies 4

Raju Sekharan
Cisco Employee
Cisco Employee

Hi

You have not configured "address-family vpnv4" under bgp

Thanks

Raju

thanks. that did the trick.

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello,

the exchange of VPNv4 routes requires the configuration of address-family vpnv4 you have to replicate the configuration for address-family ipv4 under family vpnv4

the key commands are neigh activate and neigh send-community extended to be given under af

Hope to help

Giuseppe

thanks. that did the trick.

Review Cisco Networking products for a $25 gift card