Forgive me if this is a bit complex, but I am not sure how to proceed here.
I want to take the routing/subnet information from multiple VRFs (routing tables) that are currently in their own OSPF instances, and send them across a BGP/MPLS network.
I would have a Catalyst 3850 switch with the VRFs and OSPF instances defined on it, and this would route to the upstream ASR router that would perform BGP/MPLS.
switch---->router---MPLS----router---->switch
So let's say the switch has the following configured
ip vrf RED
rd 100:1
!
ip vrf BLUE
rd 200:1
interface Vlan71
ip vrf forwarding RED
ip address 10.251.21.10 255.255.255.240
interface Vlan23
ip vrf forwarding BLUE
ip address 172.27.12.254 255.255.255.0
router ospf 1 vrf RED
log-adjacency-changes
capability vrf-lite
network 10.251.21.0 0.0.0.15 area 2
router ospf 3 vrf BLUE
log-adjacency-changes
capability vrf-lite
network 172.27.12.0 0.0.0.255 area 2
Can the router take these VRF/OSPF instances and package them into BGP/MPLS to send across a WAN link using one subnet (peer-to-peer)? I want to cut down on all the subnets used for OSPF peering.