cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1059
Views
10
Helpful
18
Replies

MPLS vpnv4 l3 network I am not getting routes from CE Router

R Manjunatha
Beginner
Beginner

Hi,

I created the VRF in PE router R38 AS5610 and similarly in PE router R35 AS 6520 and I configured the MP-BGP between the routes.

PE -R38 to CE-R76----- PE-R35 to CE-R82----

configured static route and redistributed to BGP

I am not getting the BGP route (82.82.82.0) from PE-R38


R38#sh ip route vrf F-1

Routing Table: F-1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.76.0/24 is directly connected, Ethernet0/0
L 10.10.76.2/32 is directly connected, Ethernet0/0
76.0.0.0/24 is subnetted, 1 subnets
S 76.76.76.0 [1/0] via 10.10.76.1
R38

interface Loopback0
ip address 38.38.38.38 255.255.255.255
!
interface Ethernet0/0
vrf forwarding F-1
ip address 10.10.76.2 255.255.255.0
duplex auto
!
interface Ethernet0/1
ip address 10.10.38.1 255.255.255.0
duplex auto
mpls ip
!
interface Ethernet0/2
ip address 10.10.33.1 255.255.255.0
duplex auto
mpls ip
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
interface Ethernet1/0
no ip address
shutdown
duplex auto
!
interface Ethernet1/1
no ip address
shutdown
duplex auto
!
interface Ethernet1/2
no ip address
shutdown
duplex auto
!
interface Ethernet1/3
no ip address
shutdown
duplex auto
!
router ospf 1
router-id 37.37.37.37
network 10.10.33.0 0.0.0.255 area 0
network 10.10.38.0 0.0.0.255 area 0
network 37.37.37.0 0.0.0.0 area 0
network 38.38.38.38 0.0.0.0 area 0
!
router bgp 6510
bgp router-id 38.38.38.38
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 75.75.75.75 remote-as 6510
neighbor 75.75.75.75 update-source Loopback0
!
address-family vpnv4
neighbor 75.75.75.75 activate
neighbor 75.75.75.75 send-community extended
neighbor 75.75.75.75 next-hop-self
exit-address-family
!
address-family ipv4 vrf F-1
redistribute connected
redistribute static
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route vrf F-1 76.76.76.0 255.255.255.0 10.10.76.1
!
ipv6 ioam timestamp
!
!
mpls ldp router-id Loopback0




R75

interface Loopback0
ip address 75.75.75.75 255.255.255.255
!
interface Ethernet0/0
ip address 10.10.32.2 255.255.255.0
duplex auto
mpls ip
!
interface Ethernet0/1
ip address 10.10.75.1 255.255.255.0
duplex auto
mpls ip
!
interface Ethernet0/2
ip address 10.75.75.1 255.255.255.0
duplex auto
mpls bgp forwarding
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
router ospf 1
router-id 75.75.75.75
network 10.10.32.0 0.0.0.255 area 0
network 10.10.75.0 0.0.0.255 area 0
network 75.75.75.75 0.0.0.0 area 0
network 75.75.75.0 0.0.0.255 area 0
!
router bgp 6510
bgp router-id 75.75.75.75
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor 10.75.75.2 remote-as 6520
neighbor 38.38.38.38 remote-as 6510
neighbor 38.38.38.38 update-source Loopback0
!
address-family vpnv4
neighbor 10.75.75.2 activate
neighbor 10.75.75.2 send-community extended
neighbor 38.38.38.38 activate
neighbor 38.38.38.38 send-community extended
neighbor 38.38.38.38 next-hop-self
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 ioam timestamp
!
!
mpls ldp router-id Loopback0



R37

interface Loopback0
ip address 37.37.37.37 255.255.255.255
!
interface Ethernet0/0
ip address 10.10.37.1 255.255.255.0
duplex auto
mpls ip
!
interface Ethernet0/1
ip address 10.10.78.1 255.255.255.0
duplex auto
mpls ip
!
interface Ethernet0/2
ip address 10.75.75.2 255.255.255.0
duplex auto
mpls bgp forwarding
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
router ospf 1
router-id 37.37.37.37
network 10.10.37.0 0.0.0.255 area 0
network 10.10.78.0 0.0.0.255 area 0
network 37.37.37.37 0.0.0.0 area 0
!
router bgp 6520
bgp router-id 37.37.37.37
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor 10.75.75.1 remote-as 6510
neighbor 35.35.35.35 remote-as 6520
neighbor 35.35.35.35 update-source Loopback0
!
address-family vpnv4
neighbor 10.75.75.1 activate
neighbor 10.75.75.1 send-community extended
neighbor 35.35.35.35 activate
neighbor 35.35.35.35 send-community extended
neighbor 35.35.35.35 next-hop-self
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 ioam timestamp
!
!
mpls ldp router-id Loopback0





 

R35

interface Loopback0
ip address 35.35.35.35 255.255.255.255
!
interface Ethernet0/0
ip address 10.10.34.2 255.255.255.0
duplex auto
mpls ip
!
interface Ethernet0/1
ip address 10.10.35.1 255.255.255.0
duplex auto
mpls ip
!
interface Ethernet0/2
vrf forwarding F-2
ip address 10.10.82.1 255.255.255.0
duplex auto
!
interface Ethernet0/3
no ip address
shutdown
duplex auto
!
interface Ethernet1/0
no ip address
shutdown
duplex auto
!
interface Ethernet1/1
no ip address
shutdown
duplex auto
!
interface Ethernet1/2
no ip address
shutdown
duplex auto
!
interface Ethernet1/3
no ip address
shutdown
duplex auto
!
router ospf 1
router-id 35.35.35.35
network 10.10.34.0 0.0.0.255 area 0
network 10.10.35.0 0.0.0.255 area 0
network 35.35.35.35 0.0.0.0 area 0
!
router bgp 6520
bgp router-id 35.35.35.35
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 37.37.37.37 remote-as 6520
neighbor 37.37.37.37 update-source Loopback0
!
address-family vpnv4
neighbor 37.37.37.37 activate
neighbor 37.37.37.37 send-community extended
neighbor 37.37.37.37 next-hop-self
exit-address-family
!
address-family ipv4 vrf F-2
redistribute connected
redistribute static
exit-address-family
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route vrf F-2 82.82.82.0 255.255.255.0 10.10.82.2
!
ipv6 ioam timestamp
!
!
mpls ldp router-id Loopback0
!
control-plane

 

18 Replies 18

Gr8 ...I am able to see the BGP routes. what could be the issue 

 

R35#sh ip route vrf F-2

Routing Table: F-2
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B 10.10.76.0/24 [200/0] via 37.37.37.37, 00:01:54
C 10.10.82.0/24 is directly connected, Ethernet0/2
L 10.10.82.1/32 is directly connected, Ethernet0/2
76.0.0.0/24 is subnetted, 1 subnets
B 76.76.76.0 [200/0] via 37.37.37.37, 00:01:54
82.0.0.0/24 is subnetted, 1 subnets
S 82.82.82.0 [1/0] via 10.10.82.2

Your config was prefect,
only the router-id change 
and as @Harold Ritter mention you add some command in VRF 
NOW we need to force the BGP to accept the new change 
and 


clear ip bgp 
and no bgp default route-target filter 

do force the BGP to elect the best path and advertise it.

Hi @MHM Cisco World ,

Just applying the

address-family ipv4 vrf F-1

in the PE  was sufficient. There is no need to clear bgp in this case.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Hi @R Manjunatha ,

The issue was due to the missing

address-family vrf F-1

under BGP as per config you posted before.

R35(config-vrf)#do sh run vrf
Building configuration...

Current configuration : 284 bytes
vrf definition F-2
rd 100:1
route-target export 100:1
route-target import 100:1
!
address-family ipv4
exit-address-family
!
!
interface Ethernet0/2
vrf forwarding F-2
ip address 10.10.82.1 255.255.255.0
duplex auto
!
ip route vrf F-2 82.82.82.0 255.255.255.0 10.10.82.2
end

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers