09-01-2011 11:02 AM - edited 03-04-2019 01:28 PM
I learned using the modern "MQC" way to configuer Frame Realy traffic shaping. I have my configuration as follows:
!
class-map VOICE
match ip dscp ef
!
class-map DATA
match ip dscp cs1
!
! "Child" policy-map, used to implement CBWFQ
!
policy-map CBWFQ
class VOICE
priority 64
class DATA
bandwidth 128
class class-default
fair-queue
!
! "Parent" policy map, used for PVC shaping
!
policy-map SHAPE_384K
class class-default
shape average 384000
shape adaptive 192000
service-policy CBWFQ
interface Serial 0/0/0:0.1
ip address 177.0.112.1 255.255.255.0
service-policy output SHAPE_384K
frame-relay interface-dlci 112
I've seen several hybrid configurations and I am not sure which one is correct and recommended. By "hybrid", I mean mixure of legacy FRTS and MQC.
------ Hybrid Config 1 (let MQC shape, just use legacy FRTS map-class to apply) ------------
! Class-map and Policy-map definations stay the same...
!
map-class frame-relay FRTS
service-policy SHAPE_384K
interface Serial 0/0/0:0.1
ip address 177.0.112.1 255.255.255.0
frame-relay interface-dlci 112
class FRTS
------ Hybrid Config 2 (Let MQC do CBWFQ and let legacy FRTS shape and apply -----
map-class frame-relay SHAPE_384K
frame-relay cir 38400
frame-relay bc 3840
frame-relay be 0
service-policy CBWFQ
interface Serial 0/0/0:0.1
frame-relay traffic-shaping
ip address 177.0.112.1 255.255.255.0
frame-relay interface-dlci 112
class SHAPE_384K
Please advise the differences between them and which one is recommended.
09-05-2011 04:11 AM
Hi
they are both to some extent can do the same thing
but the hybrid one you call
which is FR class map class and under it you apply a service policy can let you have per-VC QoS Policy
so you will have per-VC CBWFQ here by calling this MQC in the FRTS map-class
one this to consider is the MQC applied under the map-class for per-VC QoS consider the available bandwidth based on the micir so you need to adjust this value to meet your need by default is it micir = CIR/2
as you can apply it under the interface DLCI command, which is useful when you have hub router with multipoint interface and several DLCIs for the Spokes with differnt bandwidth/QoS needs
however the new IOS version can also shape per DLCI using MQC only using class map and GTS shaping
you can match the DLCI using the bellow commands
class-map map1
match fr-dlci xx where xx is the dlci number and you can use it in the MQC policy
HTH
if helpful Rate
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide