cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4477
Views
0
Helpful
12
Replies

Multi-Hop Static Routing

turbocaminc
Level 1
Level 1

Im having issues routing traffic using static multi-hop routing over layer 3 switches. Due to political reasons I'm limited to static routing rather than a dynamic protocol. Each site has a 3560 layer 3 switch.

 

I currently have a topology of 3 seperate sites:

     Site 1  (10.1.0.0/16): IP Address 10.1.1.1/24

     Site 2 (10.2.0.0/16): IP Address 10.2.1.1/24

     Site 3: (10.3.0.0/16): IP Address 10.3.1.1/24

 

There is a 1Gbps fiber link from Site 1 (G0/1) to Site 2 (G0/1)

There is a 10Gbps fiber link from Site 2 (G0/2) to Site 3 (G0/1)

 

Site 1 can reach Site 2 but not Site 3.

Site 2 can reach both Site 1 and Site 3.

Site 3 can reach Site 2 but not Site 1.


Site 1 config:

ip routing
spanning-tree mode pvst
interface GigabitEthernet0/1
 switchport access vlan 1001
interface Vlan1
 ip address 10.5.1.1 255.255.255.0
interface Vlan1001
 ip address 10.0.0.5 255.255.255.252
ip classless
ip route 10.2.0.0 255.255.0.0 10.0.0.6
ip route 10.1.0.0 255.255.0.0 10.0.0.6


Site 2 config:

ip routing
spanning-tree mode pvst
interface GigabitEthernet0/1
 switchport access vlan 1000
 switchport trunk allowed vlan 2-1000,1005
interface GigabitEthernet0/2
 switchport access vlan 1001
interface Vlan1
 ip address 10.2.1.1 255.255.255.0
interface Vlan1000
 ip address 10.0.0.2 255.255.255.252
interface Vlan1001
 ip address 10.0.0.6 255.255.255.252
ip classless
ip route 10.1.0.0 255.255.0.0 10.0.0.1
ip route 10.5.0.0 255.255.0.0 10.0.0.5


Site 3 config:

ip routing
spanning-tree mode pvst
interface GigabitEthernet0/1
 switchport access vlan 1000
interface Vlan1
 ip address 10.1.1.1 255.255.255.0
interface Vlan1000
 ip address 10.0.0.1 255.255.255.252
ip classless
ip route 10.2.0.0 255.255.0.0 10.0.0.2
ip route 10.5.0.0 255.255.0.0 10.0.0.2

 

I created a scenario in packet tracer to test and I'm getting the same results. What am I doing wrong?

12 Replies 12

ghostinthenet
Level 7
Level 7

Are you testing your site-to-site connectivity by pinging from the switches?

Also, looking at your configuration, these seem to be backwards:

There is a 1Gbps fiber link from Site 1 (G0/1) to Site 2 (G0/1)
There is a 10Gbps fiber link from Site 2 (G0/2) to Site 3 (G0/1)

Site 1 (G0/1) appears to connect to Site 2 (G0/2)
Site 2 (G0/1) appears to connect to Site 3 (G0/1)

Can you verify?

I am testing with Ping you are correct. I can ping from site 1 to site 2. Site 2 can ping both site 1 and site 3. Site 3 can only reach site 2.

 

The connections are only 1Gbps, sorry for the typo.

 

Site 1 (G0/1) connects to Site 2 (G0/1)

Site 2 (G0/2) connects to Site 3 (G0/1)

Let's try adding the following:

Site 1

ip route 10.0.0.0 255.255.255.252 10.0.0.6

Site 3

ip route 10.0.0.4 255.255.255.252 10.0.0.2

Does that clear things up?

No same issue....

 

Is there something that needs to be configured on the Site 2 switch to allow traffic originating outside it's directly connected networks to be routed? I know if a dynamic protocol was used this wouldn't be an issue but maybe static routing doesn't allow access to internal routes or something like that?

No. Static routing, though inefficient, will allow the connectivity you're looking for. What does a traceroute from the site 1 switch to the site 3 switch show?

Pinging 10.1.1.1 from 10.5.1.1 it shows:

 

1. 10.0.0.6     1 msec     0 msec     0 msec

2.  *                *               *               *

3.  *                *               *               *

4.  *                *               *               *

5.  *                *               *               *
 

Etc.

I really can't see anything wrong at this point... so I'm going to suggest that we cheat a bit.

Take the static routes out of the configuration and turn on dynamic routing (only temporarily) using RIPv2 on all three switches.

router rip
version 2
network 10.0.0.0
no auto-summary
passive-interface default
no passive-interface g0/1
no passive-interface g0/2 # Only on the Site 2 switch

Let that run for a minute or so and then do a "show ip route rip" on each switch. Make a careful note of which routes were learned, including subnet mask and next hop.

When you're finished, remove the dynamic routing from each switch with "no router rip" in configuration mode. Then, add static routes to each switch based on what was learned via RIP.

Ultimately, you'll still be meeting the requirements of static routing, but you'll have used dynamic routing as a tool to get an accurate representation of what should be pointing where.

That actually doesn't work at all. I setup RIP like you suggested but was still limited with connectivity. RIP routes would show up on two of the switches but never the third. I tried multiple scenarios and even rebuilt everything from scratch in packet tracer.

Which switches received routes?

Okay... I just built your configuration in the lab and found the following:

You have the configurations for G0/1 and G0/2 on the site 2 switches backwards. If everything is connected as you indicate (S1 G0/1 to S2 G0/1 and S3 G0/1 to S2 G0/2) then nothing connects because the IPv4 addresses don't match up on the links. If the connections are S1 G0/1 to S2 G0/2 and S3 G0/1 to S2 G0/1, basic connectivity works.

Once this configuration is made and I enable RIPv2 on the connecting interfaces, the following routes appear:

S2

      10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
R        10.1.1.0/24 [120/1] via 10.0.0.1, 00:00:17, Vlan1000
R        10.5.1.0/24 [120/1] via 10.0.0.5, 00:00:16, Vlan1001

S1

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
R        10.0.0.0/30 [120/1] via 10.0.0.6, 00:00:26, Vlan1001
R        10.1.1.0/24 [120/2] via 10.0.0.6, 00:00:26, Vlan1001
R        10.2.1.0/24 [120/1] via 10.0.0.6, 00:00:26, Vlan1001

S3

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
R        10.0.0.4/30 [120/1] via 10.0.0.2, 00:00:09, Vlan1000
R        10.2.1.0/24 [120/1] via 10.0.0.2, 00:00:09, Vlan1000
R        10.5.1.0/24 [120/2] via 10.0.0.2, 00:00:09, Vlan1000

When I remove the RIPv2 configuration and enter the routes that appeared in the routing table as static routes, I get full end-to-end connectivity between the sites.

Hi,

You need to add these static routes on Site 1 and Site 3:

On Site 1:

ip route 10.0.0.4 255.255.255.252 10.0.0.2

On Site 3:

ip route 10.0.0.0 255.255.255.252 10.0.0.6

Regards,

Aref

Lntumba
Level 1
Level 1

The main thing's when you configure static route you need to begin by connecting all site and be able to ping all site on both sides by declaring the next hop which will help you to reach the remote site, just when you have finished this work you can after remove the IP route you don't want.

And test the direct connection to make sure you can ping. And only after you can work on the next hop. 

Review Cisco Networking for a $25 gift card