Showing results for 
Search instead for 
Did you mean: 

Multicast - Paging Server

Hello all, 


I have configured multicast and an Informacast paging server in my lab.

I'm using a 3560 switch as a core, a 2911 as a VPN hub, a 2911 as a remote site VPN spoke, and a 2960s as the switch for that remote site. Configured in a DMVPN multipoint config. 


I'm using pim sparse mode with auto rp.


Hub site core switch multicast configs:

ip multicast-routing

ip pim autorp listener

ip pim accept-rp auto-rp

ip pim send-rp-announce loopback0 scope 255

ip pim send-rp-discovery loopback0 scope 255

ip pim register-source loopback0


ip pim sparse-mode on every layer 3 interface. (router links, svi, loopbacks)


Hub and spoke routers multicast config

ip multicast-routing

ip pim autorp listener

ip pim register-source loopback255


ip pim sparse-mode on every layer 3 interface. (switch links, tunnels, sub-interfaces, loopbacks)


Multicast doesn't seem to route properly. 

No PIM RP mappings show up on the remote site router unless a configure the hub as a RP. 


Despite this, mtraces work across the network(hub site phone vlan to remote site hub vlan). 


If a phone behind the hub site core switch sends a multicast paging message to a phone in the remote site, the remote phone will display that its being requested for a page, but the RTP packets never make it.


If that same remote site phone sends a paging request to a phone behind the core switch, it works. 


I looked at packet captures and noticed that multicast traffic is being sent through to the remote site, it's just not being sent to the phone vlan interface on the remote site. 


The only way to get multicast working is if I force the interface of the receiving phone to join the multicast group. (ip igmp join-group on remote site router phone vlan sub interface).  


I've tried setting sparse-dense mode and that didn't work. 

I've tried setting every layer 3 device up as mapping agent and a RP, but that didn't work either. 

I feel like I'm close to figuring this out because I can get it working, just not with auto-rp alone. 


Any help is greatly appreciated.



Rising star

Re: Multicast - Paging Server


Hi Chris,


Could you share your configurations? We need to know what routing protocol you configured, and whether important multicast config is missing somewhere. When you add ip igmp join-group, you are informing that you are listening to that particular group. Is the phone also configured to listen to that particular multicast group?





Re: Multicast - Paging Server

Thank you for your response. I can certainly get you configs. It won’t be until Monday, though.

I’m using eigrp and the install document I followed to set up informacast didn’t have me change any settings on the phone regarding multicast. Just making sure that either http web service is enabled on the phones.

CUCM 10.5.2
Paging server 12.5

Re: Multicast - Paging Server

Hello Meheretab,


Thank you again for taking the time and responding.


I've sent you my sanitized configs in a private message because you're the only one who showed any interest.





Re: Multicast - Paging Server

When running a "show ip mroute" I see the route all the way on the far end. Incoming interface as Null, and outgoing interface as my phone vlan sub interface. On the core switch I see the incoming interface as Null and the outgoing as a test vlan with a phone in it. 


I don't see the VPN router interfaces on the mroute outgoing interface list of the core switch and I don't see the mroute on the VPN router. This really doesn't seem to be the problem as the traffic is making it to remote site. 

Multicast isn't wanting to cross to another VLAN on the core switch with another phone in it and the remote site router isn't sending multicast to phone, despite the correct outbound interfaces showing up in "show ip mroute"