cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1434
Views
0
Helpful
4
Replies
Highlighted
Beginner

Multiple VRF for Cisco 892

  Hi All,

Need advice  i am proposing cisco 892 series router for multi VRF Configurations-MPLS. Is there any challenge you foresee in this  architecture.

PE-CE ---> BGP

If possible pls share brief  sample config.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Expert

Multiple VRF for Cisco 892

Hello Nihit,

I have provided a configuration example of a Multi VRF CE not of the PE node.

>> So you can use C892 only as multi VRF CE ( VRF lite).

If you want to use the C892 as a simple CE node the configuration is simpler without using VRFs

Hope to help

Giuseppe

View solution in original post

4 REPLIES 4
Highlighted
Hall of Fame Expert

Re: Multiple VRF for Cisco 892

Hello Nihit,

according to the following document C892 supports up to 5 VRFs with Advanced IP services feature set, but it does not support MPLS.

see

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6557/prod_white_paper0900aecd8051fbdc.html

So you can use C892 only as multi VRF CE ( VRF lite). This means that each VRF requires a distinct logical link to PE router to achieve connectivity.

These logical links can be implemented with Vlan based subinterfaces

If you want to use eBGP as PE-CE routing protocol you will need an eBGP session for each defined VRF using the logical PE-CE link.

ip vrf BLUE

rd 100:1

route-target import 100:10

route-target export 100:10

!

ip vrf RED

rd 100:2

route-target import 100:20

route-target export 100:20

!

interface fas0/1

no ip address

!

interface fas0/1.10

enc dot1q 10

desc subnet link BLUE VRF

ip vrf forwarding BLUE

ip address 10.100.101.1 255.255.255.0

!

interface fas0/1.20

enc dot1q 20

desc subnet link RED VRF

ip vrf forwarding RED

ip address 10.200.201.1 255.255.255.0

!

interface fas0/0

no ip address

!

interface fas0/0.10

enc dot1q 10

desc PE-CE link BLUE VRF

ip vrf forwarding BLUE

ip address 10.100.100.2 255.255.255.252

!

interface fas0/0.20

enc dot1q 20

desc PE-CE link RED VRF

ip vrf forwarding RED

ip address 10.200.200.2 255.255.255.252

!

router bgp 65001

address-family ipv4 vrf BLUE

no sync

redistribute connected

neighbor 10.100.100.1 remote-as 65000

address-family ipv4 vrf RED

no sync

redistribute connected

neighbor 10.200.200.1 remote-as 65000

!

the first eBGP session advertises subnet 10.100.101.0/24 to PE device, the second eBGP session advertises 10.200.201.0/24.

See a full example in the following document

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/31sga/configuration/guide/vrf.html

Hope to help

Giuseppe

Highlighted
Beginner

Multiple VRF for Cisco 892

Thanks Giuseppe for your response,

I guess the above mentioned configs are of PE router. I am looking for CE configs.

The 892 router will be deployed as CE so nt sure why MPLS support is required apart from QoS the Lables/RD/RT will be assigned  from the PE router.

Highlighted
Hall of Fame Expert

Multiple VRF for Cisco 892

Hello Nihit,

I have provided a configuration example of a Multi VRF CE not of the PE node.

>> So you can use C892 only as multi VRF CE ( VRF lite).

If you want to use the C892 as a simple CE node the configuration is simpler without using VRFs

Hope to help

Giuseppe

View solution in original post

Highlighted
Beginner

Multiple VRF for Cisco 892

Thanks , Let me check