cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
160
Views
0
Helpful
1
Replies

NAT Configuration Help

SsamR
Level 1
Level 1

I am working on Packet Tracer. I was told to configure NAT on the Gateway Router linked to Gateway Router and other internal routers.

I was given this example on my lab document 
Assuming, you have been allocated the public IP network 200.57.64.33/29, this means that the usable public IP addresses you own range from 200.57.64.33 to 200.57.64.39 with a subnet mask of 255.255.255.248. You can create a single pool to cover this range using either of the following two commands
ip nat pool nat_pool 200.57.64.33 200.57.64.39 netmask 255.255.255.248
ip nat pool nat_pool 200.57.64.33 200.57.64.39 prefix-length 29
Alternatively, you can create two equal sized pools to allocate to different subnets using:
ip nat pool nat_pool 200.57.64.33 200.57.64.35 prefix-length 30
ip nat pool nat_pool 200.57.64.36 200.57.64.39 prefix-length 30


I noticed that the network address and broadcast address has been used when creating a pool. 

My requirements for creating a NAT pool is : 
Use the NAT Public IP Address Pool provided by the ISP of 141.12.2.0/24
• Divide this pool into 3 sub-pools, do not use VLSM
• Allocate these three sub-pools to VLAN1, VLANXXX and VLANYYY


Does that mean I have to include my network address and broadcast address of this range when configuring NAT pool? If so, please explain why? because I thought we arent allowed to assignt the network / broadcast address of a range. 

Your help is greatly appreciated! Cheers!! 

1 Reply 1

Hello
your /24 public can be used with 3 nat pools (excluding its subnet/broadcast addresses which will not be included by default)

you don’t mention how your network it setup so assumption here is your using ROAS 
example
ip nat pool vlan1 141.12.1.1 141.12.85 prefix-length 24
ip nat pool vlan2 141.12.1.86 141.12.171 prefix-length 24
ip nat pool vlan3 141.12.1.172 141.12.254 prefix-length 24

ip access-list extended Vl1
permit ip 10.1.1.0. 0.0.0.255 any

ip access-list extended Vl2
permit ip 10.1.2.0. 0.0.0.255 any

ip access-list extended Vl3
permit ip 10.1.3.0. 0.0.0.255 any

Ip nat inside source-list Vl1 pool vlan1 overload
Ip nat inside source-list Vl2 pool vlan2 overload
Ip nat inside source-list Vl3 pool vlan3 overload

Int x/x
Description WAN
Ip nat outside

Int x/x
ip nat inside

Int x/x.2
encapsulation dot1q 2
ip nat inside

Int x/x.3
encapsulation dot1q 3
ip nat inside

Ip route 0.0.0.0 0.0.0.0 <wan interface> x.x.x.x 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul