cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
317
Views
5
Helpful
5
Replies
Highlighted
Beginner

NAT Overload Not Working When Applied to Interface

In my lab NAT Overload is not working when applied to the interface but it does work when I apply a NAT IP Pool. What configuration am I missing here?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: NAT Overload Not Working When Applied to Interface

I don't know if anyone will ever see this but I solved it. I pulled that command directly from the book and the book was wrong. The correct command IS "#ip nat inside source list ACL-NAT-CAPABLE interface GigabitEthernet0/0 overload". I did not have "inside" in the original command.

View solution in original post

5 REPLIES 5
Highlighted
Beginner

Re: NAT Overload Not Working When Applied to Interface

My lab layout.

Highlighted
Beginner

Re: NAT Overload Not Working When Applied to Interface

I don't know if anyone will ever see this but I solved it. I pulled that command directly from the book and the book was wrong. The correct command IS "#ip nat inside source list ACL-NAT-CAPABLE interface GigabitEthernet0/0 overload". I did not have "inside" in the original command.

View solution in original post

Highlighted
VIP Mentor

Re: NAT Overload Not Working When Applied to Interface

Hello,

 

on a side note, the original command you used (without the 'inside' keyword) would actually work if you would configure your interfaces with 'ip nat enable' instead of with 'ip nat inside' and 'ip nat outside'. This is what is called the NAT Virtual Interface feature:

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr_nat/configuration/15-mt/nat-15-mt-book/iadnat-addr-consv.html#GUID-1B07F018-EEE8-40AF-953E-7E674D5E4A23

Highlighted
VIP Mentor

Re: NAT Overload Not Working When Applied to Interface

Hello
Nat can be used either with domain (ip inside/outside) or domain-less (ip nat enable - NVI ) The latter is mostly definitive to vrf nat which performs a routing lookup before and after translation which domain nat doesn't with its nat order of preference 

Looking at your original configuration is you specified domain nat on the physical interface but your nat statement was in the domianless nat format

example:
int x/x
ip nat inside/outside

ip nat source list ...etc
but it should have been:
ip nat inside source list



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Re: NAT Overload Not Working When Applied to Interface

It is recommended to use Inside command in the configuration. 

 

Good that you found out. 

Please do not hesitate to click the STAR button if you are satisfied with my answer.