08-16-2012 11:43 AM - edited 03-04-2019 05:17 PM
Hi all,
I've a small problem with NAT. I have a Cisco1861 and that's connected to my ISP's modem via FE0/0. I can ping my intern network without any problem but the NAT isn't working so I can't connect to the internet.
Can somebody check what I've did wrong? Hereby the config:
Many thanks for the help!
ip dhcp excluded-address 192.168.2.1
ip dhcp excluded-address 192.168.3.1
ip dhcp excluded-address 192.168.2.255
ip dhcp excluded-address 192.168.3.255
ip dhcp excluded-address 192.168.2.10
!
ip dhcp pool INTERN
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1 255.255.255.0
dns-server 8.8.8.8
!
ip dhcp pool GUEST
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1 255.255.255.0
dns-server 8.8.8.8
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
license udi pid C1861W-SRST-C-F/K9 sn FGL153422S3
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
ip nat enable
ip virtual-reassembly
duplex auto
speed auto
!
interface Integrated-Service-Engine0/0
no ip address
shutdown
!
interface FastEthernet0/1/0
!
interface FastEthernet0/1/1
switchport mode trunk
!
interface FastEthernet0/1/2
!
interface FastEthernet0/1/3
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/1/4
!
interface FastEthernet0/1/5
!
interface FastEthernet0/1/6
!
interface FastEthernet0/1/7
!
interface FastEthernet0/1/8
!
interface Dot11Radio0/5/0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
!
interface Vlan3
ip address 192.168.3.1 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
access-list 1 permit 192.168.0.0 0.0.255.255
!
!
Solved! Go to Solution.
08-16-2012 01:30 PM
Hi,
you should take this off:
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
as your f0/0 interface gets an IP address by DHCP it should also get a default gateway, verify this after deleting the default static route you entered with sh ip route static command.
Regards.
Alain
Don't forget to rate helpful posts.
08-16-2012 01:30 PM
Hi,
you should take this off:
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
as your f0/0 interface gets an IP address by DHCP it should also get a default gateway, verify this after deleting the default static route you entered with sh ip route static command.
Regards.
Alain
Don't forget to rate helpful posts.
08-16-2012 01:54 PM
Perfect, that was it! Thank you very much!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide