cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1077
Views
0
Helpful
2
Replies

Need Help Forward IP public To Lan

tengkuriza
Beginner
Beginner

Hello All ...Iam new using cisco router 2600

i need help

i want to use dmz like adsl modem to direct ip public to ip lan like 180.15.22.x.x to ip lan 192.168.1.2 ( lrouter mikrotik )  outside to inside

so when i call ip public then forrward to mikrotik

does anybody help me ...

this is my cisco configuration ...iam sorry my english is bad

xxx#sh run

Building configuration...

Current configuration : 2054 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname xxxxxx

!

enable password

ip subnet-zero

ip cef

!

!

!

!

!

!

interface Loopback0

description to Astinet_Telkom180

ip address 180.250.79.xx 255.255.255.248

ip nat outside

!        

interface FastEthernet0/0

description connection to WAN Lokal ( IP domestik BGP telk*m )

ip address 192.168.240.xx 255.255.255.252

ip nat outside

duplex auto

speed auto

!        

interface FastEthernet0/1

description connection to WAN Global ( IP inter BGP telk*m )

ip address 192.168.230.xx 255.255.255.252

ip nat outside

duplex auto

speed auto

!        

interface FastEthernet1/0

description connection to LAN

ip address 192.168.1.1 255.255.255.252

ip nat inside

duplex auto

speed auto

!        

router bgp xxxx

no synchronization

bgp log-neighbor-changes

network 180.250.79.xx mask 255.255.255.248

network 192.168.230.xx mask 255.255.255.252

network 192.168.240.xx mask 255.255.255.252

timers bgp 20 60

neighbor 192.168.230.xx remote-as 17974

neighbor 192.168.240.xx remote-as 17974

no auto-summary

!        

ip nat inside source list 1 interface Loopback0 overload

ip classless

ip route profile

ip route 192.168.0.0 255.255.255.0 192.168.1.2

ip route 192.168.10.0 255.255.255.0 192.168.1.2

ip route 192.168.12.0 255.255.255.0 192.168.1.2

ip route 192.168.14.0 255.255.255.0 192.168.1.2

ip route 192.168.15.0 255.255.255.0 192.168.1.2

ip route 192.168.16.0 255.255.255.0 192.168.1.2

ip route 192.168.17.0 255.255.255.0 192.168.1.2

ip route 192.168.254.0 255.255.255.0 192.168.1.2

no ip http server

ip pim bidir-enable

!        

!        

access-list 1 permit 192.168.1.0 0.0.0.3

access-list 1 permit 192.168.0.0 0.0.0.254

access-list 1 permit 192.168.12.0 0.0.0.254

access-list 1 permit 192.168.14.0 0.0.0.254

access-list 1 permit 192.168.15.0 0.0.0.254

access-list 1 permit 192.168.16.0 0.0.0.254

access-list 1 permit 192.168.17.0 0.0.0.254

access-list 1 permit 192.168.254.0 0.0.0.254

access-list 1 permit 192.168.10.0 0.0.0.254

!        

line con 0

line aux 0

line vty 0 4

password xxxxx

login   

.

thasnks before

1 Accepted Solution

Accepted Solutions

blau grana
Rising star
Rising star

Hello Tengku,

It is really simple, you just need to configure static nat.

ip nat inside source static PRIVATE_IP PUBLIC_IP

When traffic for PUBLIC_IP come to router, it will be forwarded to PRIVATE_IP.

In your case:

PRIVATE_IP = 192.168.1.2

PUBLIC_IP = 180.15.22.x

Problem is, that I can not see this IP on your router, where is this IP?

On Loop0 you have configured subnet 180.250.79.xx/29, you can use one IP from this range as PUBLIC_IP.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

View solution in original post

2 Replies 2

blau grana
Rising star
Rising star

Hello Tengku,

It is really simple, you just need to configure static nat.

ip nat inside source static PRIVATE_IP PUBLIC_IP

When traffic for PUBLIC_IP come to router, it will be forwarded to PRIVATE_IP.

In your case:

PRIVATE_IP = 192.168.1.2

PUBLIC_IP = 180.15.22.x

Problem is, that I can not see this IP on your router, where is this IP?

On Loop0 you have configured subnet 180.250.79.xx/29, you can use one IP from this range as PUBLIC_IP.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

sorry i forgot to include public ip ...

yes corrcet ...

  public ip from my isp

180.250.79.225/29

Let me try your way .....thanks before  

i have try use this config

and exelent ..

thank you very much ....

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: