Need help in configuring Soho 91
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
12-03-2011 11:47 AM - edited 03-04-2019 02:30 PM
Hello,
I am relatively new to Cisco CLI and on the diagram that I am attaching I want the 2008 server to do DHCP for everything behind E0 on the Soho 91. I have tried multiple configs and I seem to get close but never quite get it. I am thinking that adding a DHCP helper on E0 will help but I am not sure. I am just looking for a fresh set of eyes on this and someone who actually knows what they are doing, unlike me
This is my current show run:
clock timezone akst -9
clock summer-time akdt recurring
no aaa new-model
ip subnet-zero
ip tcp path-mtu-discovery
no ip domain lookup
ip dhcp excluded-address 192.168.0.1
ip dhcp excluded-address 192.168.0.2
ip dhcp excluded-address 192.168.0.3 192.168.0.99
!
ip dhcp pool CLIENT
import all
network 192.168.0.0 255.255.255.248
default-router 192.168.0.3
lease 0 2
!
ip dhcp pool client
!
ip dhcp pool LAN
network 192.168.0.0 255.255.255.0
dns-server 192.168.0.2
default-router 192.168.0.3
!
!
ip cef
!
!
!
!
!
!
interface Ethernet0
description CUSTOMER LAN
ip address 192.168.0.3 255.255.255.0
ip nat inside
no cdp enable
hold-queue 32 in
!
interface Ethernet1
description WAN
ip address 192.168.2.1 255.255.255.252
ip nat inside
duplex auto
no cdp enable
!
router rip
redistribute connected
network 192.168.0.0
!
ip nat inside source list 102 interface Ethernet1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
no ip http server
no ip http secure-server
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
!
line con 0
exec-timeout 120 0
no modem enable
stopbits 1
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 120 0
password 7 150B390313073F7679
login local
length 0
!
scheduler max-task-time 5000
!
End
- Labels:
-
Other Routing
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
12-03-2011 12:25 PM
Hi,
if you want the DHCP server to be the Windows 2008 server then you must first delete the DHCP pools on the router
So get rid of all these lines :
ip dhcp excluded-address 192.168.0.1
ip dhcp excluded-address 192.168.0.2
ip dhcp excluded-address 192.168.0.3 192.168.0.99
ip dhcp pool CLIENT
import all
network 192.168.0.0 255.255.255.248
default-router 192.168.0.3
lease 0 2
ip dhcp pool client
ip dhcp pool LAN
network 192.168.0.0 255.255.255.0
dns-server 192.168.0.2
default-router 192.168.0.3
No need for any IP-helper address if the server is on the same subnet as the clients
Secondly: delete this route
ip route 0.0.0.0 0.0.0.0 Ethernet0 because your default route must point to your modem IP address
like this ip route 0.0.0.0 0.0.0.0 x.x.x.x where x.x.x.x is the modem IP address
If the modem is bridged then no need for any default route as you will receive it from ISP via DHCP.
3rd if you want E1 to get IP from DHCP:
interface ethernet1
ip address dhcp
Regards.
Alain
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
12-11-2011 07:21 PM
Alain, the suggestions that you made got me closer but I accidently erased my IOS and it has taken me a while to get it reloaded. I have a new config that I made that seems to be very close to what I want but it is not passing DHCP info from my server to devices behind the router. Can you take a look at this config and offer suggetstions?
Current configuration : 774 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 **************
enable password ************
!
no aaa new-model
!
resource policy
!
no ip routing
!
!
no ip cef
!
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.0.3 255.255.255.0
no ip route-cache
no cdp enable
!
interface Ethernet1
ip address dhcp
no ip route-cache
duplex auto
no cdp enable
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
no modem enable
line aux 0
line vty 0 4
password y21
login
!
scheduler max-task-time 5000
no process cpu extended
no process cpu autoprofile hog
end
Router#show hosts
Default domain is acr.local
Name/address lookup uses domain service
Name servers are 192.168.0.2
Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate
temp - temporary, perm - permanent
NA - Not Applicable None - Not defined
Host Port Flags Age Type Address(es)
Router#show ip interface brief
Interface IP-Address OK? Method Status Prot
ocol
Ethernet0 192.168.0.3 YES NVRAM up up
Ethernet1 192.168.0.15 YES DHCP up up
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
12-12-2011 12:50 AM
Hi,
1)
interface Ethernet0
ip address 192.168.0.3 255.255.255.0 You can't give it this address as it is already the address of your Windows 2008 server
2) ethernet ports on the Soho 91 are switchports( Layer 2) so I even wonder how it accepted an ip address on these ports without changing them to L3 ports.
Anyway here is what I would do:
ip routing
interface eth1
switchport mode access
switchport access vlan 2
interface eth0
switchport mode access
switchport access vlan 1
interface vlan 2
ip address dhcp
interface vlan 1
ip address 192.168.0. x 255.255.255.0
sh ip int br | in Vlan to verify both Vlan interfaces are up/up and got an IP address.
then renew your lease on a client and if it is still unsuccessful, let us know.
Regards.
Alain
