cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
165
Views
10
Helpful
4
Replies
Highlighted
Beginner

Need help setting up Cisco 891f router for basic internet

I have a Cisco 891f with a switch module, so it has 8 gigabit ethernet ports. I have set up dhcp, which I cannot get to work either. When I connect it to my pc, I get a seemingly random ip address, like 169.254.114.181, which has nothing to do with my DHCP. Even if I manually set the IP on my PC, I still cannot get internert through. EDIT: DHCP seems to work, it apparently just needed some time to give me a correct IP

It is connected to the internet from Gi 8, which should obtain an IP using DHCP. It seems to be obtaining the IP address correctly

Here's my config

! Last configuration change at 09:35:16 UTC Sat Feb 9 2019
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ErcoRouter
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
no logging console
enable secret 5 $1$kItV$IyWuNF.qiGbt1wM9ddMdH/
!
no aaa new-model
!
!
!
!
!
!


!
ip dhcp excluded-address 192.168.1.1 192.168.1.12
!
ip dhcp pool ippool
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
default-router 192.168.1.1
!
!
!
no ip domain lookup
ip domain name erco.dk
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
license udi pid C891F-K9 sn FCZ224410K3
!
!
username peter password 0 ******
!
!
!
!
!
ip ssh version 2
!
!
!
!
!
!
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
no ip address
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
no ip address
!
interface GigabitEthernet4
no ip address
!
interface GigabitEthernet5
no ip address
!
interface GigabitEthernet6
no ip address
!
interface GigabitEthernet7
no ip address
!
interface GigabitEthernet8
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async3
no ip address
encapsulation slip
!
router rip
version 2
network 192.168.1.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet8
!
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
no modem enable
line aux 0
line 3
modem InOut
speed 115200
flowcontrol hardware
line vty 0 4
login local
transport input ssh
line vty 5 15
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end

 

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: Need help setting up Cisco 891f router for basic internet

Hello,

 

on a side note, you want to configure 'spanning-tree portfast' on your switchports in order for the DHCP to work faster, if you have end users (e.g. PCs) connected. Also, I am not sure if you need the RIP config, unless you have other routing devices connected to your 891F, you don't need RIP.

 

So the entire config would look like below (important parts maked in bold):

 

! Last configuration change at 09:35:16 UTC Sat Feb 9 2019
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ErcoRouter
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
no logging console
enable secret 5 $1$kItV$IyWuNF.qiGbt1wM9ddMdH/
!
no aaa new-model
!
ip dhcp excluded-address 192.168.1.1 192.168.1.12
!
ip dhcp pool ippool
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
default-router 192.168.1.1
!
no ip domain lookup
ip domain name erco.dk
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
license udi pid C891F-K9 sn FCZ224410K3
!
username peter password 0 ******
!
ip ssh version 2
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
spanning-tree portfast
!
interface GigabitEthernet1
spanning-tree portfast
!
interface GigabitEthernet2
spanning-tree portfast
!
interface GigabitEthernet3
spanning-tree portfast
!
interface GigabitEthernet4
spanning-tree portfast
!
interface GigabitEthernet5
spanning-tree portfast
!
interface GigabitEthernet6
spanning-tree portfast
!
interface GigabitEthernet7
spanning-tree portfast
!
interface GigabitEthernet8
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async3
no ip address
encapsulation slip
!
--> no router rip
version 2
network 192.168.1.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 dhcp
ip nat inside source list 1 interface GigabitEthernet8 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line 3
modem InOut
speed 115200
flowcontrol hardware
line vty 0 4
login local
transport input ssh
line vty 5 15
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end

4 REPLIES 4
VIP Advisor

Re: Need help setting up Cisco 891f router for basic internet

Hi

First of all, i would use ip route 0.0.0.0 0.0.0.0 dhcp instead of the one used in your actual config.

Then you're missing the nat configuration. Add the following commands:

ip access-list extended NAT
permit ip 192.168.1.0 0.0.0.255 any
!
ip nat inside source list NAT interface gig8 overload


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Beginner

Re: Need help setting up Cisco 891f router for basic internet

Thank you very much for your help
VIP Mentor

Re: Need help setting up Cisco 891f router for basic internet

Hello,

 

on a side note, you want to configure 'spanning-tree portfast' on your switchports in order for the DHCP to work faster, if you have end users (e.g. PCs) connected. Also, I am not sure if you need the RIP config, unless you have other routing devices connected to your 891F, you don't need RIP.

 

So the entire config would look like below (important parts maked in bold):

 

! Last configuration change at 09:35:16 UTC Sat Feb 9 2019
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ErcoRouter
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
no logging console
enable secret 5 $1$kItV$IyWuNF.qiGbt1wM9ddMdH/
!
no aaa new-model
!
ip dhcp excluded-address 192.168.1.1 192.168.1.12
!
ip dhcp pool ippool
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
default-router 192.168.1.1
!
no ip domain lookup
ip domain name erco.dk
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
license udi pid C891F-K9 sn FCZ224410K3
!
username peter password 0 ******
!
ip ssh version 2
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0
spanning-tree portfast
!
interface GigabitEthernet1
spanning-tree portfast
!
interface GigabitEthernet2
spanning-tree portfast
!
interface GigabitEthernet3
spanning-tree portfast
!
interface GigabitEthernet4
spanning-tree portfast
!
interface GigabitEthernet5
spanning-tree portfast
!
interface GigabitEthernet6
spanning-tree portfast
!
interface GigabitEthernet7
spanning-tree portfast
!
interface GigabitEthernet8
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Async3
no ip address
encapsulation slip
!
--> no router rip
version 2
network 192.168.1.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 dhcp
ip nat inside source list 1 interface GigabitEthernet8 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line 3
modem InOut
speed 115200
flowcontrol hardware
line vty 0 4
login local
transport input ssh
line vty 5 15
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end

Beginner

Re: Need help setting up Cisco 891f router for basic internet

This fixed, and thank you for the DHCP tip

CreatePlease to create content
Content for Community-Ad

ask the Expert- Cisco's Branch Routing Portfolio