cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
426
Views
0
Helpful
6
Replies

Need help setting up QoS on 1604-R

mmilano008
Level 1
Level 1

I have a point-to-point T1 between our office and our datacenter that has a 1604-R at the office end and a 1601 at the datacenter. Our internet connection is also only at the datacenter. I would like to setup QoS on these routers so that the VoIP phones in our office work properly.

I am not sure how to do this as I have never set up QoS before. Any help would be greatly appreciated.

and how can I setup QoS on it for our VoIP phones.

Thanks

6 Replies 6

thisisshanky
Level 11
Level 11

You will most likely have to upgrade your IOS to a min. of 12 (not sure if LLQ is supported for < 12.0 ios versions).

http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a0080087b13.html

http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a0080094660.shtml

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

Actually the 1604 IS at 12.3 right now. That will be the router at the office. The other router will not be providing QoS, but there is a third router that is connecting us to the internet at the datacenter that is already doing QoS. I just want to know how to setup up the 1604 so that it is providing the QoS from the office.

Thanks

Hello,

a basic QoS for your VoIP traffic would look like this:

class-map match-all VoIP

match access-group name VoIP_TRAFFIC

!

policy-map VOICE

class VoIP

set dscp cs5

!

interface Ethernet0

service-policy VOICE in

!

ip access-list extended VoIP_TRAFFIC

permit tcp any any eq 1720

permit udp host any any range 16384 32767

If your voice traffic is bidirectional, apply that configuration to both routers. TCP port 1720 will take care of the H.323 signaling traffic, and ports 16384 thru 32767 will take care of the payload.

As the previous post stated, you might have to upgrade your IOS version. Under the policy map, instead of ´set dscp cs5´, you might have to use ´set precedence 5´...

Can you try and see if that works for you ?

Regards,

GP

I cannot seem to get the "set dscp cs5" or the "set precedence 5" part worked out. Here is what happens:

random-detect precedence 5 ?

<1-4096> minimum threshold (number of packets)

I do not know what to put for minimum and maximum values, but if I put some numbers in there this happens:

random-detect precedence 5 5 1000

bandwidth on the class is required to issue this command

Then if I try to set bandwidth, here is what happens:

CBWFQ : Can be enabled as an output feature only

Anyway, here is what I have setup so far. Please help me with all the info you can.

class-map match-all VoIP

match access-group name Voice_Traffic

!

!

policy-map VOICE

class VoIP

!

!

!

interface Ethernet0

service-policy input VOICE

Hello,

what are your options under the 'class VoIP' ? You should see something like 'set ip precedence', can you enter a ? when you are configuring the class and check what your options are ?

Regards,

GP

Mark,

You should not use RED if you are using VOIP, as they can cause packet loss. VOIP does not tolerate packet loss. What you can do is mark the packets on the inbound interface (Ethernet) and then based on those markings, you can prioritize voip traffic on the outbound serial interface. Note that CBWFQ is always applied outbound. (not inbound).

class-map match-all VoIP

match ip precedence 5

class-map match-all VoIPC

match ip precedence 3

!

!

policy-map VOICE

class VoIP

priority 512 (allocates 512k for voip)

class VoIPC

bandwidth 64 (allocates 128k for voip signalling)

class class-default

fair-queue (WFQ for rest of traffic)

int s0

service-policy output VOICE

ip access-list extended Voice_Traffic

permit udp any any range 16384 32767

ip access-list extended Voice_Control

permit tcp any eq 1720 any

permit tcp any any eq 1720

The above ACL should take care of VOIP Payload and H323 signalling packets.

int e0

ip policy route-map MarkTOS

route-map MarkTOS permit 10

match ip address Voice_Traffic

set ip precedence 5

route-map MarkTOS permit 20

match ip address Voice_Control

set ip precedence 3

route-map MarkTOS permit 30

set ip precedence 0

The above route-map will apply policy routing to the ethernet interface and all it does is mark Voice traffic (payload) with precedence of 5, Voice signalling with precedence of 3 and Data packets with precedence of 0.

HTH

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus
Review Cisco Networking for a $25 gift card