11-19-2012 12:07 AM - edited 03-04-2019 06:10 PM
Dear everyone,
I'm trying to setup QoS here but I'm having a problem. It seems that the 'match' does not work. How can I fix this?
This is what I have in the configuration:
class-map match-any VoiceLan
match dscp af11
match ip dscp af11
match access-group 101
Comment: I used match dscp and match ip dscp just in case, maybe thats why it wasn't working. I also made a access-list, still doesnt catch
!
!
policy-map markVoiceLan
class class-default
set ip dscp af11
policy-map p_serialqos
class class-default
shape average 256000
service-policy serialqos
policy-map serialqos
class VoiceLan
priority percent 40
class class-default
fair-queue
!
The markVoiceLan is applied as input on a ethernet port and works great. all packets arriving at that port get marked with dscp af11:
abc#show policy-map interface g0/0.101
GigabitEthernet0/0.101
Service-policy input: markVoiceLan
Class-map: class-default (match-any)
8091 packets, 1547092 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
QoS Set
dscp af11
Packets marked 8091
Now when it comes to an outgoing interface, it does not see it! They all go through class-default: =(
abcl#show policy-map interface serial 0/1/0.100
Serial0/1/0.100
Service-policy output: p_serialqos
Class-map: class-default (match-any)
93884 packets, 12431112 bytes
5 minute offered rate 40000 bps, drop rate 0 bps
Match: any
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/30/0
(pkts output/bytes output) 93853/12210601
shape (average) cir 256000, bc 1024, be 1024
target shape rate 256000
lower bound cir 0, adapt to fecn 0
Service-policy : serialqos
queue stats for all priority classes:
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 0/0
Class-map: VoiceLan (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: dscp af11 (10)
0 packets, 0 bytes
5 minute rate 0 bps
Match: ip dscp af11 (10)
0 packets, 0 bytes
5 minute rate 0 bps
Match: access-group 101
0 packets, 0 bytes
5 minute rate 0 bps
Priority: 40% (102 kbps), burst bytes 2550, b/w exceed drops: 0
Class-map: class-default (match-any)
93883 packets, 12431013 bytes
5 minute offered rate 40000 bps, drop rate 0 bps
Match: any
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops/flowdrops) 0/30/0/30
(pkts output/bytes output) 93853/12210601
Fair-queue: per-flow queue limit 16
Why is this happenign and how can I fix this?
Appriciate any help!
11-19-2012 05:19 AM
I tried bunch of other 'match ...', and it doesn't work. What might be preventing the 'match' command to work?
11-19-2012 07:29 AM
Haji,
Can you post the interface configurations? What model router/switch is this and version of IOS? I labbed this up and don't have the same issue you have unfortunately....
HTH,
John
11-20-2012 05:03 AM
Hey John,
Thank you for your reply.
Router:
Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(24)T2, RELEASE SOFTWARE (fc2)
Here it is:
interface GigabitEthernet0/0.101
description voice-lan
encapsulation dot1Q 101
ip address 172.16.16.254 255.255.255.0
ip pim dense-mode
no cdp enable
service-policy input markvoice //seems to work
interface Serial0/1/0
bandwidth 256
ip address 172.16.254.6 255.255.255.252
ip nat outside
ip virtual-reassembly
service-policy output serialqos // (or p_serialqos)
Thanks!
11-20-2012 07:28 AM
I noticed that you've got the policy applied to s0/1/0, but above you show the stats for s0/1/0.100. Can you post the configuration for s0/1/0.100, or is it not applied there anymore? After I get that config, I could lab this up sometime today to see if I get the same issue...
HTH,
John
11-20-2012 09:16 PM
Dear John,
There's no more s0/1/0.100, just s0/1/0. Basically, I had frame relay there, then I thought maybe CBWFQ is not supported by FR so I just reversed back to the default hdlc. Still didn't work. =(
Thanks
11-21-2012 05:38 AM
I was able to lab this up and unfortunately didn't have an issue. Maybe you could update your IOS? I looked but couldn't find a specific bug related to this issue. Below is what I did to get it to work:
Here are the results:
R2#sh policy-map int
FastEthernet0/0.100
Service-policy input: markAF
Class-map: class-default (match-any)
11 packets, 1058 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
QoS Set
dscp af11
Packets marked 11
Serial0/0
Service-policy output: matchAF
Class-map: matchAF (match-all)
5 packets, 520 bytes
5 minute offered rate 0 bps
Match: dscp af11 (10)
Class-map: class-default (match-any)
6 packets, 304 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
Here are is my class and policy maps:
class-map match-all matchAF
match dscp af11
policy-map markAF
class class-default
set dscp af11
policy-map matchAF
class matchAF
What I would do is remove the policy that you have applied to the serial side. Since you're marking everything, you should change your class map to only match on dscp af11. (I've tested with marking "dscp af11" and then matching on both "dscp af11" and "ip dscp af11".)
In short, try these changes:
class-map VoiceLan
match ip dscp af11
policy-map serialqos
class VoiceLan
priority percent 40
class class-default
fair-queue
Then reapply the policy and retest. Let me know how it goes
HTH,
John
*** Please rate all useful posts ***
11-21-2012 05:49 AM
Thank you John!
I am very happy to see that it works on your router. I've also tried this on another pair of routers and it worked there.
But not on this one omg :/
I will do what you suggested as soon as I get the connection back with the router and will update you here. (It is somewhere in the sea)
ttyl
Haji
11-21-2012 05:53 AM
Thanks Haji! I look forward to hearing from you
11-22-2012 05:41 AM
John,
I tried everything. I even updated the IOS. Still not working ://
Regards
Haji
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide