cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1307
Views
0
Helpful
2
Replies
Highlighted
Beginner

Need info on "VRRP: Header ip address count sanity check failed" message

Hi,

I am running VRRP on Cisco 2811 router (Cisco IOS Software, 2800 Software (C2800NM-ADVENTERPRISEK9-M), Version 12.4(15)T1), with another device.

i am getting following error message "VRRP: Header ip address count sanity check failed" on Cisco router, because of this Cisco router is always acting as Master even when priority of other device is more and other device is also acting as VRRP master.

The debug messages seen on Cisco 2811 router,

*May  2 12:13:37.043: VRRP: Grp 10 sending Advertisement checksum C9EB

*May  2 12:13:37.047: VRRP: Header ip address count sanity check failed

*May  2 12:13:39.995: VRRP: Grp 10 sending Advertisement checksum C9EB

*May  2 12:13:40.051: VRRP: Header ip address count sanity check failed

*May  2 12:13:42.783: VRRP: Grp 10 sending Advertisement checksum C9EB

*May  2 12:13:43.055: VRRP: Header ip address count sanity check failed

If i replace the Cisco with Juniper SSG 140 things are working with the same VRRP configuration. 

Here is the information i need,

1. Why this error is coming on Cisco router

2. Do we have a solution for this issue

3. Or the other device is sending corrupted VRRP advertisiment packet

Test bed information

Cisco 2811 ------------------------------------------ Motorola Device

VRRP settings on Cisco 2811   (VRRP settings are same on Motorola device except higher priority is configured)

----------------------------------------------------------------------------------------------

Router#show running-config

Building configuration...

Current configuration : 1606 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$R8O5$nO06IMmFZExQd0qRuOfoM0

!

no aaa new-model

!

!

ip cef

!

!

!

multilink bundle-name authenticated

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

username symbol password 0 symbol

archive

log config

  hidekeys

!

!

!

track 10 interface FastEthernet0/0 line-protocol

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 10

ip address 172.16.10.2 255.255.255.0

ip nat inside

ip virtual-reassembly

vrrp 5 ip 172.16.10.10

vrrp 5 timers advertise 2

vrrp 5 priority 90

!

interface FastEthernet0/1.2

encapsulation dot1Q 5

ip address 172.16.15.2 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username 08051504243_kk@airtelbroadband.in password 0 123456

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

ip http server

no ip http secure-server

ip nat inside source static 172.16.10.100 122.167.146.93

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password symbol

login

line vty 5 15

password symbol

login

!

scheduler allocate 20000 1000

!

webvpn cef

!

end

-------------------------------------------------------------------------------------------------

2 REPLIES 2
Highlighted
Beginner

Any information on this one is really helpful.

With Regards,

Channareddy

Highlighted

Do you have authentification for vrrp to the other side of network ?