05-13-2022 02:41 AM - edited 05-13-2022 03:27 AM
Topology: https://i.imgur.com/a1azOy0.jpg
R1#show run
Building configuration...
Current configuration : 1269 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
ip name-server 8.8.8.8
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.1.121 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
no ip http server
no ip http secure-server
ip nat inside source list 10 interface FastEthernet1/0 overload
!
access-list 10 permit 0.0.0.0
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
Network config for the VM:
network:
version: 2
renderer: networkd
ethernets:
enp0s3:
addresses:
- 192.168.0.3/24
gateway4: 192.168.0.1
nameservers:
search: [mydomain, otherdomain]
addresses: [8.8.8.8, 8.8.4.4]
Wireshark capture: https://i.imgur.com/7zruy6a.jpg
Someone told me this on another forum yesterday:
> Does the "cloud" have a route back to 192.168.0.0/24? [...] If you didn't put it there, the answer is no. So that's your problem. The return traffic has no route to your VM.
I was reading https://networklessons.com/cisco/ccie-routing-switching/ip-nat-inside-source-vs-ip-nat-outside-source and wonder if I need to do...
R1(config)#ip nat inside source static 192.168.0.1 192.168.1.121
R1(config)#ip nat inside source static 172.16.0.1 192.168.1.121
Is that correct?
05-13-2022 05:48 AM
Do it from router.
05-13-2022 06:08 AM - edited 05-13-2022 06:10 AM
Oh, right. Well, that comes back:
Tracing the route to dns.google (8.8.8.8)
1 192.168.1.1 72 msec 72 msec 72 msec
2 ae50-ner001.msp.as13285.net (78.144.1.33) 108 msec 112 msec 112 msec
3 ae50-scr001-msp.as13285.net (78.144.1.32) 104 msec 80 msec 76 msec
4 ae63-scr102.thw.as13285.net (78.144.1.128) 72 msec 108 msec 108 msec
5 74.125.51.108 108 msec 72 msec
74.125.51.110 68 msec
6 * * *
7 dns.google (8.8.8.8) 56 msec 120 msec
172.253.65.210 96 msec
I hope I have made it clear that I can ping 8.8.8.8 fine from the router though? It was only the VMs that are having any issues connecting to the web when I made my post. In fact, compared to this guide https://docs.gns3.com/docs/using-gns3/advanced/connect-gns3-internet/ I can do all that. Like I said, I can even ping Google from the router, but not from the VMs.
Edit: this is a Wireshark capture, where 192.168.0.2 is one of my VMs
05-13-2022 06:32 AM
From the network perspective I believe this is it. The packet from Lab machine should go to the router, the router should send it to your physical machine, then to internet and return. All it set for that.
Try to replace the Linux VM for a router and see the result.
And nop, I did not realize that from router you were able to ping on the internet since the begining You start this post asking about NAT.
05-13-2022 05:53 AM - edited 05-13-2022 05:56 AM
2/ Actually, I was able to run traceroute from my Observium VM. It just comes back...
192.168.0.1 (192.168.0.1) [and so on...]
For the first hop, and that's it, no other IPs shown. And that it is with the firewall right off.
05-13-2022 06:09 AM
You need to add a route on the router like
ip route 0.0.0.0 0.0.0.0 "Physical Machine Ip address "
05-13-2022 06:27 AM
I thought I had that already though? That's 192.168.1.1 isn't it?
On the GNS3 router:
Gateway of last resort is 192.168.1.1 to network 0.0.0.0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, FastEthernet0/1
C 192.168.0.0/24 is directly connected, FastEthernet0/0
C 192.168.1.0/24 is directly connected, FastEthernet1/0
S* 0.0.0.0/0 [1/0] via 192.168.1.1
05-13-2022 06:46 AM
I think it is not right. You are using your home router as the Lab Router´s gateway? If so, you need to use your machine as your Lab gateway. Your home router does not know your Lab network so it can not reply back. Unless you can add routes on your home router. That´s why you added static routes on your windows machine.
05-13-2022 08:01 AM - edited 05-13-2022 08:24 AM
> You are using your home router as the Lab Router´s gateway?
I think I originally tried to set the lab router's gateway to 192.168.1.121, but that didn't work, because it said something like 'invalid next hop - it's this router!'
I really don't know what to do next, to be honest. But it seems like you are saying to delete the static routes from the lab router and set them up on my home router instead, I suppose.
To be quite honest, I'm really tired and demoralised by all this. I've been working on this for 21 days from start to finish now, and when I saw pings come back from the router, I thought I was nearly there. But it seems like actually I was still nowhere near succeeding.
05-13-2022 07:12 AM - edited 05-13-2022 07:22 AM
I think it is not right. You are using your home router as the Lab Router´s gateway? If so, you need to use your machine as your Lab gateway. Your home router does not know your Lab network so it can not reply back. Unless you can add routes on your home router. That´s why you added static routes on your windows machine.
S* 0.0.0.0/0 [1/0] via 192.168.1.1 (It is your home router??)
S* 0.0.0.0/0 [1/0] via (Your physical machine)
05-13-2022 08:15 AM
> S* 0.0.0.0/0 [1/0] via 192.168.1.1 (It is your home router??)
Yes, that is my home router.
05-13-2022 08:34 AM
Do as I said please.
The virtual machine send to lab router....Lab router to your machine and not to your home router.
Follow the draw above.
05-13-2022 08:55 AM
Ah right, I think maybe I have got you now; hope so anyway.
S* 0.0.0.0/0 [1/0] via 192.168.1.1
...should read...
S* 0.0.0.0/0 [1/0] via 192.168.1.11
Is that correct please??
05-13-2022 09:00 AM
Yes.
You windows machine need to be the gateway as it has ´ "Physical" contact with the Lab and it has the static routes do the LAB and access to the internet too.
05-13-2022 09:16 AM - edited 05-13-2022 09:23 AM
OK, well I tried that, but now I can't ping 8.8.8.8 from the router, I can only ping the physical router, and the VM isn't getting any pings back except 192.168.0.1.
Edit: I don't understand what has happened to those routes I thought I added before for 192.168.0.1 and 172.16.0.1?? Where have they gone??
05-13-2022 09:32 AM
did you reload the PC?
add them again. They need to be in place to work
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide