07-21-2008 10:57 PM - edited 03-03-2019 10:50 PM
I have the following config
class-map match-any L_QOS
match access-group name L_BTS
class-map match-any E_QOS
match access-group name E_BTS
class-map match-any voip-sat
match ip dscp ef
policy-map sat-qos-child
class voip-sat
priority percent 33
class class-default
fair-queue
policy-map sat-qos-parent
class E_QOS
shape average 96000
service-policy sat-qos-child
class L_QOS
shape average 128000
service-policy sat-qos-child
I have applied the sat-qos-parent to the s2/1 interface.
interface Serial2/1
ip address 192.168.xxx.xxx 255.255.255.252
service-policy output sat-qos-parent
When I check the policy-map on the interface, I dont get any matches for the voip-sat class, however I do get the traffic shaping as specified.
Any ideas as to why?
sh policy-map int s2/1
......
Service-policy : sat-qos-child
Class-map: voip-sat (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
Strict Priority
Output Queue: Conversation 24
Bandwidth 33 (%)
Bandwidth 31 (kbps) Burst 775 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0
Class-map: class-default (match-any)
32820 packets, 26876527 bytes
5 minute offered rate 95000 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 16
(total queued/total drops/no-buffer drops) 11/0/0
Class-map: class-default (match-any)
15220 packets, 1012103 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
.....
07-21-2008 11:27 PM
Hi,
When doing shaping with nested qos, the child policy only gets used when there is congestion on the interface, as specified by the parent policy map, shape commands.
You must use the class-default class on the parent policy, and speciy your shaping contraints on this, then match the child policy map.
IE.
policy-map ptop
class class-default
shape average 128000
service-policy sat-qos-child
class-map match-any voip-sat
match ip dscp ef
policy-map sat-qos-child
class voip-sat
priority percent 33
class class-default
fair-queue
interface Serial2/1
ip address 192.168.xxx.xxx 255.255.255.252
service-policy output ptop
HTH
LR
07-22-2008 12:53 AM
Hi LR
Thanks for that.
How do I distinguish between different sites?
For instance in my config L_QOS and E_QOS. These class-maps reference different access-lists.
Thanks
07-22-2008 12:56 AM
Hi,
You just create the individual class-map and match it in the child policy map.
The idea is that the child policy map does not get called upon, until there is congestion on the inteface, when there is congestion, then the packets are treated as per the child policy, ie you can give voip traffic from one site 32k, voip from other site 32k, and then class default for everything else..
HTH
LR
07-22-2008 12:59 AM
Hi,
You just create the individual class-map and match it in the child policy map.
The idea is that the child policy map does not get called upon, until there is congestion on the inteface, when there is congestion, then the packets are treated as per the child policy, ie you can give voip traffic from one site 32k, voip from other site 32k, and then class default for everything else..
HTH
LR
07-22-2008 01:12 AM
Hi LR,
Thanks for your quick response.
Could you please give me an example...
07-22-2008 01:15 AM
Hi,
IE.
policy-map ptop
class class-default
shape average 128000
service-policy sat-qos-child
class-map match-any voip-site1
match access-group 101
class-map match-any voip-site2
match access-group 102
policy-map sat-qos-child
class voip-site1
priority percent 33
class voip-site1
priority percent 33
class class-default
fair-queue
interface Serial2/1
ip address 192.168.xxx.xxx 255.255.255.252
service-policy output ptop
HTH
LR
07-22-2008 02:02 AM
Would something like this do the trick?
class-map match-all voip-qos-e
match access-group name E_BTS
match ip dscp ef
class-map match-all voip-qos-l
match access-group name L_BTS
match ip dscp ef
policy-map sat-qos-child
class voip-qos-e
priority percent 33
class voip-qos-l
priority percent 33
class class-default
fair-queue
policy-map ptop
class class-default
shape average 128000
service-policy sat-qos-child
I'm assuming that all sites will get the same 128000 shaping.
07-22-2008 02:07 AM
Hi,
Yep looks good!
Yes correct, the shaping applies to all sites, but only when you have congestion, ie are sending more than 128000, when that happens traffic is de-queued as per the config in the child policy, LLQ for voip and BE for class default.
HTH
LR
07-22-2008 02:21 AM
Just to make sure the policy will shape each site to 128000, not the overall bandwidth?
07-22-2008 02:33 AM
hi,
the shape average will shape all traffic to 128000, so both sites will be subject to this.
What is your bandwidth on the pipe to where you are sending this voip traffic?
HTH
LR
07-22-2008 03:44 AM
I have 1Mps aggregate connection and 128k to each site.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide