04-03-2023 01:46 PM
Hi,
I have a Cisco ASR 1001-X with adventerprise running Cisco IOS XE Software Version 16.06.06.
Following are the router configs.
The netflow output for interfaces BDI3194 and interface BDI1208 show no entries and I have confirmed traffic and packets are passing through. While the netflow input on these interfaces show proper data. This issue seems to be only with the bridge domain interfaces and their physical interfaces and I would want either to give both the netflow output and netflow input data. I even configured the flow monitor on the physical interfaces GigabitEthernet0/0/2 and GigabitEthernet0/0/3 having service instance BDIs but they neither show netflow output nor netflow input.
Please help me find the solution.
Thank you
flow record netflow-record-in
match flow direction
match interface input
match ipv4 destination address
match ipv4 protocol
match ipv4 source address
match ipv4 tos
match transport destination-port
match transport source-port
collect counter packets long
collect counter bytes long
collect interface output
!
!
flow record netflow-record-out
match flow direction
match interface output
match ipv4 destination address
match ipv4 protocol
match ipv4 source address
match ipv4 tos
match transport destination-port
match transport source-port
collect counter bytes long
collect counter packets long
collect interface input
!
!
flow record netflow-record
match ipv4 tos
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
match interface input
collect interface output
collect counter bytes
collect counter packets
!
!
flow exporter netflow-exporter
destination 103.1.1.51
source Port-channel1.100
transport udp 2055
!
!
flow exporter netflow-exporter1
destination 103.1.1.61
source Port-channel1.100
transport udp 2055
template data timeout 60
option interface-table timeout 60
option sampler-table timeout 60
!
!
flow monitor netflow-monitor-in
exporter netflow-exporter
exporter netflow-exporter1
cache timeout inactive 60
cache timeout active 60
cache entries 8192
record netflow-record-in
!
!
flow monitor netflow-monitor-out
exporter netflow-exporter
exporter netflow-exporter1
cache timeout inactive 60
cache timeout active 60
cache entries 8192
record netflow-record-out
!
!
flow monitor netflow-monitor
exporter netflow-exporter
exporter netflow-exporter1
cache timeout inactive 60
cache timeout active 60
cache entries 8192
record netflow-record
!
sampler sampler
mode random 1 out-of 100
interface GigabitEthernet0/0/0
ip flow monitor netflow-monitor-in sampler sampler input
ip flow monitor netflow-monitor-out sampler sampler output
ip address 119.1.1.2 255.255.255.254
no ip proxy-arp
ip access-group inside in
ip access-group outside out
ip tcp adjust-mss 1436
load-interval 30
negotiation auto
no mop enabled
!
interface GigabitEthernet0/0/1
ip flow monitor netflow-monitor-in sampler sampler input
ip flow monitor netflow-monitor-out sampler sampler output
ip address 110.1.1.2 255.255.255.252
no ip proxy-arp
ip access-group inside in
ip access-group outside out
ip tcp adjust-mss 1436
load-interval 30
negotiation auto
no mop enabled
!
interface GigabitEthernet0/0/2
no ip address
no ip proxy-arp
ip tcp adjust-mss 1436
load-interval 30
negotiation auto
no mop enabled
service instance 3194 ethernet
encapsulation dot1q 3194
rewrite ingress tag pop 1 symmetric
bridge-domain 3194
!
service instance 3259 ethernet
encapsulation dot1q 3259
rewrite ingress tag pop 1 symmetric
bridge-domain 3259
!
!
interface GigabitEthernet0/0/3
no ip address
no ip proxy-arp
ip tcp adjust-mss 1436
load-interval 30
negotiation auto
no mop enabled
service instance 1207 ethernet
encapsulation dot1q 1207
rewrite ingress tag pop 1 symmetric
bridge-domain 1207
!
service instance 1208 ethernet
encapsulation dot1q 1208
rewrite ingress tag pop 1 symmetric
bridge-domain 1208
!
!
!
interface BDI1207
no ip address
no ip proxy-arp
ip access-group inside in
load-interval 30
no mop enabled
!
interface BDI1208
ip flow monitor netflow-monitor-in sampler sampler input
ip flow monitor netflow-monitor-out sampler sampler output
ip address 203.1.1.2 255.255.255.254
no ip proxy-arp
ip access-group inside in
ip access-group outside out
ip tcp adjust-mss 1436
load-interval 30
no mop enabled
!
interface BDI3194
ip flow monitor netflow-monitor-in sampler sampler input
ip flow monitor netflow-monitor-out sampler sampler output
ip address 202.1.1.2 255.255.255.252
no ip proxy-arp
ip access-group inside in
ip access-group outside out
ip tcp adjust-mss 1436
load-interval 30
no mop enabled
!
interface BDI3259
no ip address
no ip proxy-arp
ip access-group inside in
load-interval 30
no mop enabled
show flow monitor netflow-monitor-in cache filter interface input gi0/0/0
Cache type: Normal (Platform cache)
Cache size: 8192
Current entries: 509
High Watermark: 649
Flows added: 10748
Flows aged: 10239
- Active timeout ( 60 secs) 10239
IPV4 SOURCE ADDRESS:
show flow monitor netflow-monitor-out cache filter interface output gi0/0/0
Cache type: Normal (Platform cache)
Cache size: 8192
Current entries: 212
High Watermark: 352
Flows added: 4949
Flows aged: 4737
- Active timeout ( 60 secs) 4737
IPV4 SOURCE ADDRESS:
show flow monitor netflow-monitor-in cache filter interface input bdi3194
Cache type: Normal (Platform cache)
Cache size: 8192
Current entries: 538
High Watermark: 649
Flows added: 13400
Flows aged: 12862
- Active timeout ( 60 secs) 12862
IPV4 SOURCE ADDRESS:
show flow monitor netflow-monitor-out cache filter interface output bdi3194
Cache type: Normal (Platform cache)
Cache size: 8192
Current entries: 188
High Watermark: 352
Flows added: 6063
Flows aged: 5875
- Active timeout ( 60 secs) 5875
There are no matching cache entries to display.
flow record netflow-record-in
match flow direction
match interface input
match ipv4 destination address
match ipv4 protocol
match ipv4 source address
match ipv4 tos
match transport destination-port
match transport source-port
collect counter packets long
collect counter bytes long
collect interface output
!
!
flow record netflow-record-out
match flow direction
match interface output
match ipv4 destination address
match ipv4 protocol
match ipv4 source address
match ipv4 tos
match transport destination-port
match transport source-port
collect counter bytes long
collect counter packets long
collect interface input
!
!
flow record netflow-record
match ipv4 tos
match ipv4 protocol
match ipv4 source address
match ipv4 destination address
match transport source-port
match transport destination-port
match interface input
collect interface output
collect counter bytes
collect counter packets
!
!
flow exporter netflow-exporter
destination 103.1.1.51
source Port-channel1.100
transport udp 2055
!
!
flow exporter netflow-exporter1
destination 103.1.1.61
source Port-channel1.100
transport udp 2055
template data timeout 60
option interface-table timeout 60
option sampler-table timeout 60
!
!
flow monitor netflow-monitor-in
exporter netflow-exporter
exporter netflow-exporter1
cache timeout inactive 60
cache timeout active 60
cache entries 8192
record netflow-record-in
!
!
flow monitor netflow-monitor-out
exporter netflow-exporter
exporter netflow-exporter1
cache timeout inactive 60
cache timeout active 60
cache entries 8192
record netflow-record-out
!
!
flow monitor netflow-monitor
exporter netflow-exporter
exporter netflow-exporter1
cache timeout inactive 60
cache timeout active 60
cache entries 8192
record netflow-record
!
sampler sampler
mode random 1 out-of 100
interface GigabitEthernet0/0/0
ip flow monitor netflow-monitor sampler sampler input
ip address 119.1.1.2 255.255.255.254
no ip proxy-arp
ip access-group inside in
ip access-group outside out
ip tcp adjust-mss 1436
load-interval 30
negotiation auto
no mop enabled
!
interface GigabitEthernet0/0/1
ip flow monitor netflow-monitor sampler sampler input
ip address 110.1.1.2 255.255.255.252
no ip proxy-arp
ip access-group inside in
ip access-group outside out
ip tcp adjust-mss 1436
load-interval 30
negotiation auto
no mop enabled
!
interface GigabitEthernet0/0/2
no ip address
no ip proxy-arp
ip tcp adjust-mss 1436
load-interval 30
negotiation auto
no mop enabled
service instance 3194 ethernet
encapsulation dot1q 3194
rewrite ingress tag pop 1 symmetric
bridge-domain 3194
!
service instance 3259 ethernet
encapsulation dot1q 3259
rewrite ingress tag pop 1 symmetric
bridge-domain 3259
!
!
interface GigabitEthernet0/0/3
no ip address
no ip proxy-arp
ip tcp adjust-mss 1436
load-interval 30
negotiation auto
no mop enabled
service instance 1207 ethernet
encapsulation dot1q 1207
rewrite ingress tag pop 1 symmetric
bridge-domain 1207
!
service instance 1208 ethernet
encapsulation dot1q 1208
rewrite ingress tag pop 1 symmetric
bridge-domain 1208
!
!
!
interface BDI1207
no ip address
no ip proxy-arp
ip access-group inside in
load-interval 30
no mop enabled
!
interface BDI1208
ip flow monitor netflow-monitor sampler sampler input
ip address 203.1.1.2 255.255.255.254
no ip proxy-arp
ip access-group inside in
ip access-group outside out
ip tcp adjust-mss 1436
load-interval 30
no mop enabled
!
interface BDI3194
ip flow monitor netflow-monitor sampler sampler input
ip address 202.1.1.2 255.255.255.252
no ip proxy-arp
ip access-group inside in
ip access-group outside out
ip tcp adjust-mss 1436
load-interval 30
no mop enabled
!
interface BDI3259
no ip address
no ip proxy-arp
ip access-group inside in
load-interval 30
no mop enabled
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide