cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
211
Views
0
Helpful
0
Replies
Highlighted
Beginner

NetFlow not working on ASR1000 through vrf

I am trying to get a flow exporter to work on a Cisco ASR 1000.  I get flow traffic on the monitor, but it does not appear to be forwarding to the exporter correctly.  I have tried v4 and v9.  I have also tried setting the interface to send input traffic, output traffic, and both.  I don't know if the issue is that I am using a vrf for the export port, the fact that the monitored ports and the exporter port are on different networks, or something else entirely. 

 

#sh flow monitor NetFlow statistics
Cache type: Normal (Platform cache)
Cache size: 200000
Current entries: 808
High Watermark: 947

Flows added: 10177
Flows aged: 9369
- Active timeout ( 60 secs) 421
- Inactive timeout ( 15 secs) 8948


#sh flow exporter NetFlow statistics
Flow Exporter NetFlow:
Packet send statistics (last cleared 2d23h ago):
Successfully sent: 0 (0 bytes)

Client send statistics:
Client: Flow Monitor NetFlow
Records added: 0
Bytes added: 0

 

 

 

 

Here is the relevant config:

 

flow exporter NetFlow
destination (internal IP address) vrf netflow
source GigabitEthernet0/0/0
transport udp 9996
export-protocol netflow-v9
template data timeout 60
!

!
flow monitor NetFlow
exporter NetFlow
cache timeout active 60
record netflow-original
!

!
interface GigabitEthernet0/0/0
description Management/Netflow
vrf forwarding netflow
ip address (internal IP address)
negotiation auto


!
interface TenGigabitEthernet0/1/0
description Uplink
ip address (external IP address)
ip flow monitor NetFlow input

 

Everyone's tags (1)
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards