cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

161
Views
0
Helpful
1
Replies
Highlighted
Beginner

Nexus - BGP --> EIGRP route-map problem

Hello experts

I have facing a problem on the redistribution 

background

in my company mainly EIGRP, but recently we have 1 site setup VXLAN, so some of the Eigrp router they need to exchange the route will becomes  EIGRP---> BGP ---> EIGRP  but seems that is not possible to redistribute the "BGP, external metric " back to EIGRP. so I try to retain the TAG at least.

 

so my logic is:-

when EIGRP--> BGP

I will match the TAG 222/300/301 from EIGRP then convert to BGP community 999:222/300/301 (and default is 301)

when  BGP--> EIGRP

I will match the Community 999:222/300/301 then convert to EIGRP Tag 222/300/301 (and default is 301) and hard code some metric

 

the problem is 2), the route map only fall to the last one permit-bgp-eigrp999 100 

 

 

router bgp 65010

<skipped>
vrf dc1_default
address-family ipv4 unicast
redistribute static route-map permit-static-bgp
redistribute eigrp Vxlan_overlay route-map permit-eigrp999-bgp

 

router eigrp Vxlan_overlay
<skipped>

vrf dc1_default
address-family ipv4 unicast
autonomous-system 999
passive-interface default
redistribute bgp 65010 route-map permit-bgp-eigrp999

 

# sh run | sec route-map
route-map permit-bgp-eigrp999 permit 10
match community 999:222
set tag 222
set metric 400000 90000 255 1 1472
route-map permit-bgp-eigrp999 permit 20
match community 999:300
set tag 300
set metric 100 90000 255 1 1472
route-map permit-bgp-eigrp999 permit 30
match community 999:301
set tag 301
set metric 10000000 2000 255 1 1500
route-map permit-bgp-eigrp999 permit 100
match route-type internal
set tag 301

set metric 10000000 1000 255 1 1500


route-map permit-eigrp999-bgp permit 10
match tag 222
set community 999:222
route-map permit-eigrp999-bgp permit 20
match tag 300
set community 999:300
route-map permit-eigrp999-bgp permit 30
match tag 301
set community 999:301
route-map permit-eigrp999-bgp permit 100
set community 999:301

 

# sh ip bgp 10.1.0.0/16 vrf dc
BGP routing table information for VRF dc1_default, address family IPv4 Unicast
BGP routing table entry for 10.1.0.0/16, version 9392
Paths: (1 available, best #1)
Flags: (0x8008001a) (high32 00000000) on xmit-list, is in urib, is best urib route, is in HW
vpn: version 14255, (0x00000000100002) on xmit-list
Multipath: iBGP

Advertised path-id 1, VPN AF advertised path-id 1
Path type: internal, path is valid, is best path, no labeled nexthop, in rib
Imported from 10.x.x.x:x:[5]:[0]:[0]:[16]:[10.1.0.0]/224
AS-Path: NONE, path sourced internal to AS
10.x.x.x(metric 45) from 10.x.x.x (10.x.x.x)
Origin incomplete, MED 52224, localpref 100, weight 0
Received label 50000
Community: 999:222
Extcommunity: RT:65010:50000 ENCAP:8 Router MAC:4ce1.7660.3f47
Originator: 10.247.51.6 Cluster list: 10.247.51.1

VRF advertise information:
Path-id 1 not advertised to any peer

VPN AF advertise information:
Path-id 1 not advertised to any peer

#

 

# sh ip eigrp topology 10.1.0.0/16 vrf dc

IP-EIGRP (AS 999): Topology entry for 10.1.0.0/16
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 256256
Routing Descriptor Blocks:
10.51.132.5, from Redistributed, Send flag is 0x0
Composite metric is (256256/0), Route is External
Vector metric:
Minimum bandwidth is 10000000 Kbit
Total delay is 10000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 0
Internal tag is 0
External data:
Originating router is 10.x.x.x(this system)
AS number of route is 65010
External protocol is BGP, external metric is 52224

Everyone's tags (3)
1 REPLY 1
Highlighted
Beginner

Re: Nexus - BGP --> EIGRP route-map problem

after another google, I have changed that to IP community list instead of just putting match community in the route-map but could help....

route-map permit-bgp-eigrp999 permit 10
match community CL_222
set tag 222
set metric 400000 90000 255 1 1472

 


ip community-list standard CL_222 seq 5 permit 0:222