10-22-2013 02:59 AM - edited 03-04-2019 09:22 PM
Hi ,
I am configured VRF SW1 and SW2 in the below topo in both R1 and R2, but still i am not able to get the correct output for sh ip ro VRF..
Configs in R1 :
ip vrf SW1
rd 100:1
route-target export 100:1
route-target import 100:1
!
ip vrf SW2
rd 100:2
route-target export 100:2
route-target import 100:2
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
serial restart-delay 0
!
interface Ethernet1/0
ip vrf forwarding SW2
ip address 20.1.1.1 255.255.255.0
full-duplex
!
interface Ethernet1/1
ip vrf forwarding SW1
ip address 30.1.1.1 255.255.255.0
full-duplex
!
router eigrp 100
network 10.1.1.0 0.0.0.255
no auto-summary
!
address-family ipv4 vrf SW2
redistribute connected
network 20.1.1.0 0.0.0.255
network 0.0.0.0
auto-summary
autonomous-system 100
exit-address-family
!
address-family ipv4 vrf SW1
redistribute connected
network 30.1.1.0 0.0.0.255
network 0.0.0.0
auto-summary
autonomous-system 100
exit-address-family
!
Configs in R2:
ip vrf SW1
rd 100:1
route-target export 100:1
route-target import 100:1
!
ip vrf SW2
rd 100:2
route-target export 100:2
route-target import 100:2
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
serial restart-delay 0
!
interface Ethernet1/0
ip vrf forwarding SW1
ip address 40.1.1.1 255.255.255.0
half-duplex
!
interface Ethernet1/1
ip vrf forwarding SW2
ip address 40.1.1.1 255.255.255.0
half-duplex
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
router eigrp 100
network 10.1.1.0 0.0.0.255
no auto-summary
!
address-family ipv4 vrf SW2
redistribute connected
network 40.1.1.0 0.0.0.255
network 0.0.0.0
auto-summary
autonomous-system 100
exit-address-family
!
address-family ipv4 vrf SW1
redistribute connected
network 40.1.1.0 0.0.0.255
network 0.0.0.0
auto-summary
autonomous-system 100
exit-address-family
!
R1#sh ip route vrf SW1
Routing Table: SW1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
30.0.0.0/24 is subnetted, 1 subnets
C 30.1.1.0 is directly connected, Ethernet1/1
Please kindly give me some suggestion in this....
10-22-2013 03:06 AM
Hi Ramesh,
Inside address-family, change anyone of the VRF's autonomous-system to something other than 100.
Regards,
Smitesh
10-22-2013 03:14 AM
Hi Smitesh,
as you told i changed in both the ends for the AS, but still it's not working
In R2:
router eigrp 100
network 10.1.1.0 0.0.0.255
no auto-summary
!
address-family ipv4 vrf SW2
redistribute connected
network 40.1.1.0 0.0.0.255
network 0.0.0.0
auto-summary
autonomous-system 100
exit-address-family
!
address-family ipv4 vrf SW1
network 40.1.1.0 0.0.0.255
auto-summary
autonomous-system 200
exit-address-family
!
In R1:
router eigrp 100
network 10.1.1.0 0.0.0.255
no auto-summary
!
address-family ipv4 vrf SW2
redistribute connected
network 20.1.1.0 0.0.0.255
network 0.0.0.0
auto-summary
autonomous-system 100
exit-address-family
!
address-family ipv4 vrf SW1
redistribute connected
network 30.1.1.0 0.0.0.255
auto-summary
autonomous-system 200
exit-address-family
!
i have changed the RD also 200:1 in both the routers.
But , if i add any one of the VRF in the Serial 0/0 that perticular VRF is working fine...
10-22-2013 03:21 AM
Ramesh,
I observer that you have not advertised your Serial link inside the address-family.
Can you advertise the same inside the address-family and check again.
Regards,
Smitesh
10-22-2013 03:24 AM
Your Serial link is in Global VRF.
You will need to do sub-interfaces on the serial with members in each VRF if you want to run your VRFs between R1 and R2 or do some route leaking between VRF and Global.
10-22-2013 03:39 AM
Hello ramesh,
When you configure VRF, router created virtual router and it is locally significant. All configuration is done under VRF.in your case you have 2 vrf instances and one global routing table .When you configure vrf all routing table are independent unless you do special configuration.
Link between r1 and r2 , create sub interface on both site and put it under vrf like shown below
conf t
int s0/0.100
ip vrf forwarding SW1
int s0/0.200
ip vrf forwarding SW2
Hope it helps
Regards,
Ashish
10-22-2013 04:05 AM
Hi,
I have configured sub interfaces as per your suggession, but it's still not working,
R1:
interface Serial0/0
no ip address
!
interface Serial0/0.100
ip vrf forwarding SW1
ip address 10.1.1.1 255.255.255.0
!
interface Serial0/0.200
ip vrf forwarding SW2
ip address 10.1.1.1 255.255.255.0
!
R2:
interface Serial0/0
no ip address
!
interface Serial0/0.100
ip vrf forwarding SW1
ip address 10.1.1.2 255.255.255.0
!
interface Serial0/0.200
ip vrf forwarding SW2
ip address 10.1.1.2 255.255.255.0
!
R1:
R1#sh ip route vrf SW1
Routing Table: SW1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0.100
30.0.0.0/24 is subnetted, 1 subnets
C 30.1.1.0 is directly connected, Ethernet1/1
10-22-2013 04:30 AM
Hello Ramesh,
by default serial interface has HDLC encapsulation change it frame-relay .As you don’t have FR switch in between use back to back FR method.
Hers is config for your routers
R1:
interface Serial0/0
no ip address
encapsulation frame-relay
frame-relay intf-type dce
end
interface Serial0/0.100 point-to-point
ip vrf forwarding SW1
ip address 10.1.1.1 255.255.255.252
frame-relay interface-dlci 101
interface Serial0/0.200 point-to-point
ip vrf forwarding SW2
ip address 10.1.1.1 255.255.255.252
frame-relay interface-dlci 102
end
For R2:
interface Serial0/0
no ip address
encapsulation frame-relay
end
interface Serial0/0.100 point-to-point
ip vrf forwarding SW1
ip address 10.1.1.2 255.255.255.252
frame-relay interface-dlci 101
end
interface Serial0/0.200 point-to-point
ip vrf forwarding SW2
ip address 10.1.1.2 255.255.255.252
frame-relay interface-dlci 102
end
Regards,
Ashish Shirkar
Technical Community Manager - NI
10-22-2013 04:49 AM
You also need to put the Serial interfaces under the VRF EIGRP process
router eigrp 100
no network 10.1.1.0 0.0.0.255
!
address-family ipv4 vrf SW2
no auto-sum
network 10.1.1.0 0.0.0.255
exit-address-family
!
address-family ipv4 vrf SW1
no auto-sum
network 10.1.1.0 0.0.0.255
exit-address-family
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide