cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3868
Views
10
Helpful
14
Replies

Not on common subnet error, while using EIGRP routing protocol.

noob_route
Level 1
Level 1

Requirements: HUB-ACTIVE, HUB-STANDBY, SPOKE2 must communicate through DMVPN, using EIGRP routing protocol.

But when i advertise the network connected to the routers (hub-active, hub-standby, spoke2), it showing the error on all three routers:

 *Dec 5 09:37:01.611: EIGRP-IPv4(1): Neighbor 1.1.1.1 not on common subnet for FastEthernet1/1


NOTE: PoC is attached below.


Configuration :

HUB-ACTIVE
redundancy
!
!
ip tcp synwait-time 5
!
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
!
crypto isakmp policy 2
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key FORISP1 address 1.1.1.4
crypto isakmp key FORISP2 address 2.2.2.4
!
!
crypto ipsec transform-set ISP1SET esp-3des esp-md5-hmac
crypto ipsec transform-set ISP2SET esp-3des esp-md5-hmac
!
crypto map ISP1MAP 1 ipsec-isakmp
set peer 1.1.1.4
set transform-set ISP1SET
match address 100
!
crypto map ISP2MAP 2 ipsec-isakmp
set peer 2.2.2.4
set transform-set ISP2SET
match address 100
!
!
!
!
!
!
interface Tunnel1
description ***ACTIVE-PATH-1-****
ip address 172.16.10.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1111
!
!
interface Tunnel2
description ***ACTIVE-PATH-2-****
ip address 90.90.90.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 2
delay 6000
tunnel source FastEthernet1/1
tunnel mode gre multipoint
tunnel key 2222
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.2 255.255.255.0
duplex auto
speed auto
standby 2 ip 1.1.1.5
standby 2 priority 110
standby 2 preempt
standby 2 name wlanisp1
crypto map ISP1MAP
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.10.2 255.255.255.0
--More--
*Dec 5 09:34:06.915: EIGRP-IPv4(1): Neighbor 2.2.2.1 not on common subnet for FastEthernet0/0
duplex auto
speed auto
standby 1 ip 192.168.10.5
standby 1 priority 110
standby 1 preempt
standby 1 name inlan
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.2 255.255.255.0
duplex auto
speed auto
standby 3 ip 2.2.2.5
standby 3 priority 110
standby 3 preempt
standby 3 name wanisp2
crypto map ISP2MAP
!
!
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 2.2.2.0 0.0.0.255
network 90.90.90.0 0.0.0.255
network 172.16.10.0 0.0.0.255
network 192.168.10.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.30.0 255.255.255.0 1.1.1.4
ip route 192.168.30.0 255.255.255.0 2.2.2.4 10
ip route 192.168.50.0 255.255.255.0 192.168.10.4
!
access-list 100 permit ip 192.168.50.0 0.0.0.255 192.168.30.0 0.0.0.255
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!
HUB-STANDBY
redundancy
!
!
ip tcp synwait-time 5
!
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
!
crypto isakmp policy 2
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key FORISP1 address 1.1.1.4
crypto isakmp key FORISP2 address 2.2.2.4
!
!
crypto ipsec transform-set ISP1SET esp-3des esp-md5-hmac
crypto ipsec transform-set ISP2SET esp-3des esp-md5-hmac
!
crypto map ISP1MAP 1 ipsec-isakmp
set peer 1.1.1.4
set transform-set ISP1SET
match address 100
!
crypto map ISP2MAP 2 ipsec-isakmp
set peer 2.2.2.4
set transform-set ISP2SET
match address 100
!
!
!
!
!
!
interface Tunnel3
description ***STANDBY-PATH-1-***
ip address 200.200.200.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 3
delay 7000
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 3333
!
!
interface Tunnel4
description ***STANDBY-PATH-2-***
ip address 50.50.50.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 4
delay 8000
tunnel source FastEthernet1/1
tunnel mode gre multipoint
tunnel key 4444
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
standby 2 ip 1.1.1.5
standby 2 preempt
standby 2 name wanisp1
crypto map ISP1MAP
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.10.5
standby 1 preempt
standby 1 name inlan
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.1 255.255.255.0
duplex auto
speed auto
standby 3 ip 2.2.2.5
standby 3 preempt
standby 3 name wanisp2
crypto map ISP2MAP
!
!
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 2.2.2.0 0.0.0.255
network 50.50.50.0 0.0.0.255
network 192.168.10.0
network 200.200.200.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.30.0 255.255.255.0 1.1.1.4
ip route 192.168.30.0 255.255.255.0 2.2.2.4 10
ip route 192.168.50.0 255.255.255.0 192.168.10.4
!
access-list 100 permit ip 192.168.50.0 0.0.0.255 192.168.30.0 0.0.0.255
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!
SPOKE2
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface Tunnel1
description ***ACTIVE-PATH-1-****
ip address 172.16.10.2 255.255.255.0
no ip redirects
ip nhrp map multicast 1.1.1.2
ip nhrp map 172.16.10.1 1.1.1.2
ip nhrp network-id 1
ip nhrp nhs 172.16.10.1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1111
!
!
interface Tunnel2
ip address 90.90.90.2 255.255.255.0
no ip redirects
ip nhrp map multicast 2.2.2.2
ip nhrp map 90.90.90.1 2.2.2.2
ip nhrp network-id 2
ip nhrp nhs 90.90.90.1
delay 6000
tunnel source FastEthernet1/1
tunnel mode gre multipoint
tunnel key 2222
!
!
interface Tunnel3
description ***STANDBY-PATH-1-***
ip address 200.200.200.2 255.255.255.0
no ip redirects
ip nhrp map multicast 1.1.1.1
ip nhrp map 200.200.200.1 1.1.1.1
ip nhrp network-id 3
ip nhrp nhs 200.200.200.1
delay 7000
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 3333
!
!
interface Tunnel4
description ***STANDBY-PATH-2-***
ip address 50.50.50.2 255.255.255.0
no ip redirects
ip nhrp map multicast 2.2.2.1
ip nhrp map 50.50.50.1 2.2.2.1
ip nhrp network-id 4
ip nhrp nhs 50.50.50.1
delay 8000
tunnel source FastEthernet1/1
tunnel mode gre multipoint
tunnel key 4444
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.3 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.3 255.255.255.0
duplex auto
speed auto
!
!
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 2.2.2.0 0.0.0.255
network 50.50.50.0 0.0.0.255
network 90.90.90.0 0.0.0.255
network 172.16.10.0 0.0.0.255
network 192.168.20.0
network 200.200.200.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!

 

14 Replies 14

Hello,

 

add the physical interfaces to your topology diagram, so we can see what the physical connections look like.

configuration has attached below.

just try one thing, 
Hub have two tunnel to same Spoke, just remove one tunnel and see result.

Hello,

IT Showing the same error.

 

HUB-ACTIVE:  *Dec 5 19:39:43.427: EIGRP-IPv4(1): Neighbor 2.2.2.1 not on common subnet for FastEthernet0/0

                         *Dec 5 19:40:05.819: EIGRP-IPv4(1): Neighbor 2.2.2.1 not on common subnet for FastEthernet0/0

 

HUB-STANDBY:  *Dec 5 19:39:24.435: EIGRP-IPv4(1): Neighbor 1.1.1.1 not on common subnet for FastEthernet1/1

                            *Dec 5 19:39:44.731: EIGRP-IPv4(1): Neighbor 2.2.2.3 not on common subnet for FastEthernet0/0

SPOKE2:  *Dec 5 19:38:15.123: EIGRP-IPv4(1): Neighbor 2.2.2.1 not on common subnet for FastEthernet0/0

                  *Dec 5 19:38:25.131: EIGRP-IPv4(1): Neighbor 1.1.1.3 not on common subnet for FastEthernet1/1

 

 

 

HUB-STANDBY:

redundancy
!
!
ip tcp synwait-time 5
!
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
!
crypto isakmp policy 2
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key FORISP1 address 1.1.1.4
crypto isakmp key FORISP2 address 2.2.2.4
!
!
crypto ipsec transform-set ISP1SET esp-3des esp-md5-hmac
crypto ipsec transform-set ISP2SET esp-3des esp-md5-hmac
!
crypto map ISP1MAP 1 ipsec-isakmp
set peer 1.1.1.4
set transform-set ISP1SET
match address 100
!
crypto map ISP2MAP 2 ipsec-isakmp
set peer 2.2.2.4
set transform-set ISP2SET
match address 100
!
!
!
!
!
!
interface Tunnel3
description ***STANDBY-PATH-1-***
ip address 200.200.200.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 3
delay 7000
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 3333
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
standby 2 ip 1.1.1.5
standby 2 preempt
standby 2 name wanisp1
crypto map ISP1MAP
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.10.5
standby 1 preempt
standby 1 name inlan
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.1 255.255.255.0
duplex auto
speed auto
standby 3 ip 2.2.2.5
standby 3 preempt
standby 3 name wanisp2
crypto map ISP2MAP
!
!
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 2.2.2.0 0.0.0.255
network 192.168.10.0
network 200.200.200.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.30.0 255.255.255.0 1.1.1.4
ip route 192.168.30.0 255.255.255.0 2.2.2.4 10
ip route 192.168.50.0 255.255.255.0 192.168.10.4
!
access-list 100 permit ip 192.168.50.0 0.0.0.255 192.168.30.0 0.0.0.255
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!

 

 

 

HUB-ACTIVE:

redundancy
!
!
ip tcp synwait-time 5
!
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
!
crypto isakmp policy 2
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key FORISP1 address 1.1.1.4
crypto isakmp key FORISP2 address 2.2.2.4
!
!
crypto ipsec transform-set ISP1SET esp-3des esp-md5-hmac
crypto ipsec transform-set ISP2SET esp-3des esp-md5-hmac
!
crypto map ISP1MAP 1 ipsec-isakmp
set peer 1.1.1.4
set transform-set ISP1SET
match address 100
!
crypto map ISP2MAP 2 ipsec-isakmp
set peer 2.2.2.4
set transform-set ISP2SET
match address 100
!
!
!
!
!
!
interface Tunnel1
description ***ACTIVE-PATH-1-****
ip address 172.16.10.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1111
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.2 255.255.255.0
duplex auto
speed auto
standby 2 ip 1.1.1.5
standby 2 priority 110
standby 2 preempt
standby 2 name wlanisp1
crypto map ISP1MAP
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.10.2 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.10.5
standby 1 priority 110
standby 1 preempt
standby 1 name inlan
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.2 255.255.255.0
duplex auto
speed auto
standby 3 ip 2.2.2.5
standby 3 priority 110
standby 3 preempt
standby 3 name wanisp2
crypto map ISP2MAP
!
!
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 2.2.2.0 0.0.0.255
network 172.16.10.0 0.0.0.255
network 192.168.10.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.30.0 255.255.255.0 1.1.1.4
ip route 192.168.30.0 255.255.255.0 2.2.2.4 10
ip route 192.168.50.0 255.255.255.0 192.168.10.4
!
access-list 100 permit ip 192.168.50.0 0.0.0.255 192.168.30.0 0.0.0.255
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown

!

SPOKE2:

redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface Tunnel1
description ***ACTIVE-PATH-1-****
ip address 172.16.10.2 255.255.255.0
no ip redirects
ip nhrp map multicast 1.1.1.2
ip nhrp map 172.16.10.1 1.1.1.2
ip nhrp network-id 1
ip nhrp nhs 172.16.10.1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1111
!
!
interface Tunnel3
description ***STANDBY-PATH-1-***
ip address 200.200.200.2 255.255.255.0
no ip redirects
ip nhrp map multicast 1.1.1.1
ip nhrp map 200.200.200.1 1.1.1.1
ip nhrp network-id 3
ip nhrp nhs 200.200.200.1
delay 7000
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 3333
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.3 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.3 255.255.255.0
duplex auto
speed auto
!
!
!
router eigrp 1
network 1.1.1.0 0.0.0.255
network 2.2.2.0 0.0.0.255
network 172.16.10.0 0.0.0.255
network 192.168.20.0
network 200.200.200.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!

 

now showing this error on HUB_STANDBY: *Dec 5 20:03:43.723: %DUAL-5-NBRCHANGE: EIGRP-IPv4 1: Neighbor 200.200.200.2 (Tunnel3) is down: retry limit exceeded

can I see the config ?

SPOKE2 cannot find the route for 192.168.50.0/24 using eigrp, now what shoud i do ??

HELP !!

 

 

HUB-STANDBY:

!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
!
crypto isakmp policy 2
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key FORISP1 address 1.1.1.4
crypto isakmp key FORISP2 address 2.2.2.4
!
!
crypto ipsec transform-set ISP1SET esp-3des esp-md5-hmac
crypto ipsec transform-set ISP2SET esp-3des esp-md5-hmac
!
crypto map ISP1MAP 1 ipsec-isakmp
set peer 1.1.1.4
set transform-set ISP1SET
match address 100
!
crypto map ISP2MAP 2 ipsec-isakmp
set peer 2.2.2.4
set transform-set ISP2SET
match address 100
!
!
!
!
!
!
interface Tunnel3
description ***STANDBY-PATH-1-***
ip address 200.200.200.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 3
delay 7000
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 3333
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
standby 2 ip 1.1.1.5
standby 2 preempt
standby 2 name wanisp1
crypto map ISP1MAP
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.10.5
standby 1 preempt
standby 1 name inlan
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.1 255.255.255.0
duplex auto
speed auto
standby 3 ip 2.2.2.5
standby 3 preempt
standby 3 name wanisp2
crypto map ISP2MAP
!
!
!
router eigrp 1
network 192.168.10.0
network 200.200.200.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.30.0 255.255.255.0 1.1.1.4
ip route 192.168.30.0 255.255.255.0 2.2.2.4 10
ip route 192.168.50.0 255.255.255.0 192.168.10.4
!
access-list 100 permit ip 192.168.50.0 0.0.0.255 192.168.30.0 0.0.0.255
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!

 

HUB-ACTIVE:

!
redundancy
!
!
ip tcp synwait-time 5
!
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
!
crypto isakmp policy 2
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key FORISP1 address 1.1.1.4
crypto isakmp key FORISP2 address 2.2.2.4
!
!
crypto ipsec transform-set ISP1SET esp-3des esp-md5-hmac
crypto ipsec transform-set ISP2SET esp-3des esp-md5-hmac
!
crypto map ISP1MAP 1 ipsec-isakmp
set peer 1.1.1.4
set transform-set ISP1SET
match address 100
!
crypto map ISP2MAP 2 ipsec-isakmp
set peer 2.2.2.4
set transform-set ISP2SET
match address 100
!
!
!
!
!
!
interface Tunnel1
description ***ACTIVE-PATH-1-****
ip address 172.16.10.1 255.255.255.0
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1111
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.2 255.255.255.0
duplex auto
speed auto
standby 2 ip 1.1.1.5
standby 2 priority 110
standby 2 preempt
standby 2 name wlanisp1
crypto map ISP1MAP
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.10.2 255.255.255.0
duplex auto
speed auto
standby 1 ip 192.168.10.5
standby 1 priority 110
standby 1 preempt
standby 1 name inlan
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.2 255.255.255.0
duplex auto
speed auto
standby 3 ip 2.2.2.5
standby 3 priority 110
standby 3 preempt
standby 3 name wanisp2
crypto map ISP2MAP
!
!
!
router eigrp 1
network 172.16.10.0 0.0.0.255
network 192.168.10.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 192.168.30.0 255.255.255.0 1.1.1.4
ip route 192.168.30.0 255.255.255.0 2.2.2.4 10
ip route 192.168.50.0 255.255.255.0 192.168.10.4
!
access-list 100 permit ip 192.168.50.0 0.0.0.255 192.168.30.0 0.0.0.255
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!

 

SPOKE2:

!
!
redundancy
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
interface Tunnel1
description ***ACTIVE-PATH-1-****
ip address 172.16.10.2 255.255.255.0
no ip redirects
ip nhrp map multicast 1.1.1.2
ip nhrp map 172.16.10.1 1.1.1.2
ip nhrp network-id 1
ip nhrp nhs 172.16.10.1
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 1111
!
!
interface Tunnel2
no ip address
!
!
interface Tunnel3
description ***STANDBY-PATH-1-***
ip address 200.200.200.2 255.255.255.0
no ip redirects
ip nhrp map multicast 1.1.1.1
ip nhrp map 200.200.200.1 1.1.1.1
ip nhrp network-id 3
ip nhrp nhs 200.200.200.1
delay 7000
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 3333
!
!
interface FastEthernet0/0
description ***ISP-1-PRIMARY***
ip address 1.1.1.3 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet0/1
description ***LAN-INTERFACE***
ip address 192.168.20.1 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet1/1
description ***ISP-2-SECONDARY***
ip address 2.2.2.3 255.255.255.0
duplex auto
speed auto
!
!
!
router eigrp 1
network 172.16.10.0 0.0.0.255
network 192.168.20.0
network 200.200.200.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
nls resp-timeout 1
cpd cr-id 1
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
gatekeeper
shutdown
!

hjhkgjk.png
                                                                                                                    gdfjghdkgh.png

this is my Note about the DMVPN, 
I see the topology you share before you config SW between Hubs and Spokes, instead the internet cloud will represent Router that connect to all hub and spoke. 
let assume this Internet cloud as Rcloud, and all Hub and Spoke can talk to each other before config the tunnel. 
after they reachable then we can config the tunnel and specify the source and NHS ip address. 

for HSRP, the HSRP in other side of Hub not the side that connect to Internet but the side that serve LAN.

NOTE:- one same tunnel key for each DMVPN cloud "by the way the DMVPN cloud is the subnet of the tunnel you config."

Hello,

 

add the physical interfaces and IP addresses used on these interfaces to your topology drawing...

I use this topology as general whatever the ip address of ISP.
thanks a lot for your note.

Hello,

 

what interfaces are directly connected to the interfaces marked in bold:

 

HUB-ACTIVE: *Dec 5 19:39:43.427: EIGRP-IPv4(1): Neighbor 2.2.2.1 not on common subnet for FastEthernet0/0

*Dec 5 19:40:05.819: EIGRP-IPv4(1): Neighbor 2.2.2.1 not on common subnet for FastEthernet0/0

 

HUB-STANDBY: *Dec 5 19:39:24.435: EIGRP-IPv4(1): Neighbor 1.1.1.1 not on common subnet for FastEthernet1/1

*Dec 5 19:39:44.731: EIGRP-IPv4(1): Neighbor 2.2.2.3 not on common subnet for FastEthernet0/0

SPOKE2: *Dec 5 19:38:15.123: EIGRP-IPv4(1): Neighbor 2.2.2.1 not on common subnet for FastEthernet0/0

*Dec 5 19:38:25.131: EIGRP-IPv4(1): Neighbor 1.1.1.3 not on common subnet for FastEthernet1/1

HUB-ACTIVE:

1.1.1.0/24 is directly connected, FastEthernet0/0
2.2.2.0/24 is directly connected, FastEthernet1/1
192.168.10.0/24 is directly connected, FastEthernet0/1
172.16.10.0/24 is directly connected, Tunnel1
90.90.90.0/24 is directly connected, Tunnel2

 

HUB-STANDBY:

192.168.10.0/24 is directly connected, FastEthernet0/1
2.2.2.0/24 is directly connected, FastEthernet1/1
1.1.1.0/24 is directly connected, FastEthernet0/0

200.200.200.0/24 is directly connected, Tunnel3

50.50.50.0/24 is directly connected, Tunnel4

 

SPOKE2:

1.1.1.0/24 is directly connected, FastEthernet0/0
2.2.2.0/24 is directly connected, FastEthernet1/1
192.168.20.0/24 is directly connected, FastEthernet0/1
172.16.10.0/24 is directly connected, Tunnel1
90.90.90.0/24 is directly connected, Tunnel2
200.200.200.0/24 is directly connected, Tunnel3
50.50.50.0/24 is directly connected, Tunnel4

Hi friend any news about your issue? do you complete the lab or not?

Review Cisco Networking for a $25 gift card