Obtaining an ip address automatically (cable modem)?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
07-20-2006 03:42 PM - edited 03-03-2019 01:24 PM
Hello, I am new to the forums, I've searched Cisco's site for what im looking for, and also tried to google it, after looking for a long long time, I decided to ask.
I am trying to get my Cisco 2600 Series router to do just that, route. I want to setup my cable modem on my Ethernet0/1 port, (needs to obtain IP automatically) and then setup DHCP on Ethernet0/0 (I may have figured this out, not sure).
Any help would be awesome, Im sure someone has done this before, I just maybe not looking in the right spot.
This is what I have so far.
//code//
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Mike
!
enable secret 5 /
enable password
!
ip subnet-zero
no ip routing
!
!
!
ip dhcp pool Mypool
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
no ip redirects
no ip unreachables
no ip route-cache
speed auto
full-duplex
!
interface Serial0/0
no ip address
no ip route-cache
shutdown
!
interface FastEthernet0/1
ip address gets automatically from cable modem
no ip redirects
no ip unreachables
ip nat inside
no ip route-cache
speed auto
full-duplex
!
//end of code//
Thanks again, for the help.
~Mike
- Labels:
-
Routing Protocols
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
07-20-2006 05:10 PM
Hi, Mike,
If you want to configure a Cisco router as a DHCP client, you can have a look at the following url:
and if you want to the router be a DHCP server, the following url may be useful to you:
btw, what's the reason for that you have a command in your config shows "no ip routing" ?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
07-20-2006 05:39 PM
no ip routing is something that was in there before hand. Im not sure why its there.
Im not exactly sure if this is what im looking for. Let me elaberate a bit more.
I use this 2600 Series for VOIP currently. Im using a Linksys router, with DMZ on the router, I basically want the 2600, to do what my Linksys router does, so I can just use one of them instead of both.
I hope this makes more sense.
Thanks again for the help.
~Mike
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
07-21-2006 01:02 AM
Hi
from my understanding of your network:
ip dhcp pool Mypool
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
ip nat inside
!
interface FastEthernet0/1
ip address negotiated
ip nat outside
ip nat inside source list 1 interface f0/1 overload
access-list 1 permit 10.10.10.0 0.0.0.255
Hope it helps.
Pls rate helpful posts
Regards
JD
