06-07-2018 10:13 AM - edited 03-05-2019 10:34 AM
I have the above topology.
On R3, I have the following confguration
R3
int lo0
ip add 3.3.3.3 255.255.255.255
ip ospf 1 area 10
interface Loopback1
ip address 33.33.33.33 255.255.255.255
int e0/0
ip add 10.10.10.3 255.255.255.0
ip ospf 1 area 10
no shut
int e0/1
ip add 172.16.3.3 255.255.255.224
ip ospf 1 area 10
no shut
Router ospf 1
router-id 3.3.3.3
passive-interface lo0
red eigrp 10
redistribute connected subnets
Router eigrp 10
network 10.10.10.0 255.255.255.0
On R4
Int lo0
ip add 4.4.4.4 255.255.255.255
ip ospf 1 area 20
Int e0/2
ip add 172.16.4.4 255.255.255.224
ip ospf 1 area 20
no shut
Int e0/1
ip add 10.10.10.4 255.255.255.0
no shut
Router ospf 1
router-id 4.4.4.4
passive-interface lo0
My questions are while 33.33.33.33 has Routing-bit set, but 6.6.6.6 does not
R4#show ip ospf data external 6.6.6.6
OSPF Router with ID (4.4.4.4) (Process ID 1)
Type-5 AS External Link States
LS age: 19
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 6.6.6.6 (External Network Number )
Advertising Router: 3.3.3.3
LS Seq Number: 8000000A
Checksum: 0x242B
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 10.10.10.6
External Route Tag: 0
R4#show ip ospf data external 33.33.33.33
OSPF Router with ID (4.4.4.4) (Process ID 1)
Type-5 AS External Link States
Routing Bit Set on this LSA in topology Base with MTID 0
LS age: 1085
Options: (No TOS-capability, DC, Upward)
LS Type: AS External Link
Link State ID: 33.33.33.33 (External Network Number )
Advertising Router: 3.3.3.3
LS Seq Number: 80000003
Checksum: 0x9578
Length: 36
Network Mask: /32
Metric Type: 2 (Larger than any link state path)
MTID: 0
Metric: 20
Forward Address: 0.0.0.0
External Route Tag: 0
I know how to fix it. After I added ip ospf 1 area 20 on e0/1 on R4, routing bit will be set.
I do not know why 6.6.6.6 does not have routing bit set without ip ospf 1 area 20 on e0/1 on R4, but 33.33.33.33 has.
thanks !!
06-07-2018 02:13 PM - edited 06-07-2018 02:15 PM
Hello,
usually, no routing bit set means that (R4 in your case) is not the preferred path for the network in question. Can you reach 6.6.6.6 from R4, is there a route in the routing table ?
06-07-2018 02:23 PM
R4 could not reach 6.6.6.6.
If I add ip ospf 1 area 20 under e0/1 on R4, R4 could reach 6.6.6.6. Also Routing Bit Set appears.
What I don't understand is why Routing Bit Set is not there without configuring ip ospf 1 area 20 under e0/1 for R4. But 33.33.33.33 has Routing Bit Set. Both are redistributed into ospf on R3.
R4 can reach advertising router 3.3.3.3.
thanks !!
06-07-2018 02:24 PM
I do not understand why it is not preferred.
thanks !!
06-07-2018 02:36 PM
Hello,
not preferred or no route essentially cause the same thing, which is the routing bit not being present.
The routing bit being present simply means that the network is being routed by this router. When you look at the routing table of R4, it probably looks like this:
R4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/3] via 172.16.4.1, 00:34:37, GigabitEthernet0/2
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/3] via 172.16.4.1, 00:33:48, GigabitEthernet0/2
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/24 is directly connected, GigabitEthernet0/1
L 10.10.10.4/32 is directly connected, GigabitEthernet0/1
33.0.0.0/32 is subnetted, 1 subnets
O E2 33.33.33.33 [110/20] via 172.16.4.1, 00:34:37, GigabitEthernet0/2
140.143.0.0/30 is subnetted, 1 subnets
O IA 140.143.1.0 [110/2] via 172.16.4.1, 00:34:37, GigabitEthernet0/2
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
O IA 172.16.3.0/27 [110/2] via 172.16.4.1, 00:34:37, GigabitEthernet0/2
C 172.16.4.0/27 is directly connected, GigabitEthernet0/2
L 172.16.4.4/32 is directly connected, GigabitEthernet0/2
There is no route for 6.6.6.6.
Adding the interface to the OSPF area makes 6.6.6.6 reachable:
R4#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/3] via 172.16.4.1, 00:38:41, GigabitEthernet0/2
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/3] via 172.16.4.1, 00:37:52, GigabitEthernet0/2
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
6.0.0.0/32 is subnetted, 1 subnets
O E2 6.6.6.6 [110/20] via 10.10.10.6, 00:00:10, GigabitEthernet0/1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.10.10.0/24 is directly connected, GigabitEthernet0/1
L 10.10.10.4/32 is directly connected, GigabitEthernet0/1
33.0.0.0/32 is subnetted, 1 subnets
O E2 33.33.33.33 [110/20] via 172.16.4.1, 00:38:41, GigabitEthernet0/2
140.143.0.0/30 is subnetted, 1 subnets
O IA 140.143.1.0 [110/2] via 172.16.4.1, 00:38:41, GigabitEthernet0/2
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
O IA 172.16.3.0/27 [110/2] via 172.16.4.1, 00:38:41, GigabitEthernet0/2
C 172.16.4.0/27 is directly connected, GigabitEthernet0/2
L 172.16.4.4/32 is directly connected, GigabitEthernet0/2
06-07-2018 02:43 PM
Yes, if I add enabling ospf on e0/1 for R4, it works.
without enabling ospf on e0/1 for R4, Routing Bit Set disappears based on what ?
I searched the internet, most mentions either the advertising router is not reachable or some route is more preferred than ospf.
But in this scenarios, the advertising route is reachable, and no other route exists for the prefix 6.6.6.6.
That is where I am lost.
thanks !!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide