cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

247
Views
0
Helpful
15
Replies
Beginner

OSPF Virtual Link Question

Studying for my ROUTE exam and had a practice question yesterday that I am kind of stuck on. Here is a picture of what the topology was like....

 

https://imgur.com/a/7iGH2CN

 

Every router ID was it's router number 4 times (R1 = 1.1.1.1, R2 = 2.2.2.2, R3 = 3.3.3.3). The issue is the loopback of R3 was not showing up in the routing table of R1. Obviously it is because R3 needs a virtual link to connect it to Area 0. So I did a show run on R3 and there was already a virtual link configured and it was conifigured as "area 10 virtual link 2.2.2.2". 

 

Well I know that is wrong because the area you specify needs to be the transit area. So I then issued the following command.......

 

R3:
conf t router ospf 1 area 1 virtual link 2.2.2.2

R2:
conf t
router ospf 1
area 1 virtual link 3.3.3.3

When I did this, a "show ip ospf virtual links" told me that the virtual link was "down". The other incorrect virtual link was still in the config, so I did negated it was a "no" and got rid of it on both routers. After doing this, it made no difference, the new virtual link was still down and I could not get the loopback of R3 to show up in the routing table of R1.

 

Does anyone have any idea how to troubleshoot a down virutal link? I had never run into this before so was very confused. I also just set this up in GNS3 and had no issues getting it to work.

15 REPLIES 15
VIP Mentor

Re: OSPF Virtual Link Question

Hello,

 

I cannot tell if R1 and R3 in your drawing are ABRs. Make sure the configs look like below, the VL should work then:

 

R1

 

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
description Link to R2
ip address 10.0.1.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
router ospf 1
router-id 1.1.1.1
area 1 virtual-link 3.3.3.3
network 1.1.1.1 0.0.0.0 area 0
network 10.0.1.0 0.0.0.255 area 1

 

R2

 

interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
description Link to R1
ip address 10.0.1.2 255.255.255.0
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet0/1
description Link to R3
ip address 10.0.2.1 255.255.255.0
duplex auto
speed auto
media-type rj45
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 1
network 10.0.1.0 0.0.0.255 area 1
network 10.0.2.0 0.0.0.255 area 1


R3

 

interface Loopback3
ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
description Link to R2
ip address 10.0.2.2 255.255.255.0
duplex auto
speed auto
media-type rj45
!
router ospf 1
router-id 3.3.3.3
area 1 virtual-link 1.1.1.1
network 3.3.3.3 0.0.0.0 area 10
network 10.0.2.0 0.0.0.255 area 1

 

Beginner

Re: OSPF Virtual Link Question

 
Beginner

Re: OSPF Virtual Link Question

So maybe I messed up. I see that you put on R3 "area 1 virtual-link 1.1.1.1". Is that correct? I thought you needed to put the IP of the next hop you are using to get to the backbone area. So wouldn't the command on R3 be " area 1 virtual link 2.2.2.2"? And from my understanding, it needs to be on the opposite side as well, so wouldn't R2 need "area 1 virtual like 3.3.3.3"? Or am I wrong?

VIP Mentor

Re: OSPF Virtual Link Question

Hello,

 

test the configs I posted, it should work.

 

The link below has a pretty good sample configuration:

 

https://www.cisco.com/c/en/us/support/docs/ip/open-shortest-path-first-ospf/47866-ospfdb7.html

Beginner

Re: OSPF Virtual Link Question

Don't mean to be rude but the config you posted is incorrect. 

Highlighted
VIP Mentor

Re: OSPF Virtual Link Question

Hello,

 

which config is incorrect, and what is incorrect ?

Beginner

Re: OSPF Virtual Link Question

The virtual link config. Needs to be configured on R2 and R3

 

R2
area 1 virtual-link 3.3.3.3

R3
area 1 virtual-link 2.2.2.2

VIP Mentor

Re: OSPF Virtual Link Question

Hello,

 

which config are you referring to ? In the one I posted, R1 and R3 are the ABRs. VL is between ABRs...

Beginner

Re: OSPF Virtual Link Question

R2 and R3 are the ABRs in my topology. R1 is the backbone router

VIP Mentor

Re: OSPF Virtual Link Question

Hello,

 

post the full running configs of all your three routers. My configs are just an example. As initially stated, I could not tell from your drawing what areas you networks belong to.

VIP Advisor

Re: OSPF Virtual Link Question

Hello


@hhhax7 wrote:

So maybe I messed up. I see that you put on R3 "area 1 virtual-link 1.1.1.1". Is that correct? I thought you needed to put the IP of the next hop you are using to get to the backbone area. So wouldn't the command on R3 be " area 1 virtual link 2.2.2.2"? And from my understanding, it needs to be on the opposite side as well, so wouldn't R2 need "area 1 virtual like 3.3.3.3"? Or am I wrong?


Your correct the VL needs to be configured between ABR's -  in your toplogy that would be R2 (area 0-1), R3 (area1-10)
R2
area 1 virtual-link 3.3.3.3

R3
area 1 virtual-link 2.2.2.2

As to the reason why it didnt work , Did you clear the opsf process after you had deleted the previous VL?



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: OSPF Virtual Link Question

I did not clear it. But what is weird is I deleted the original VL, the new one still didnt work (showed as down), so I put the original one back on and it came up. 

VIP Advisor

Re: OSPF Virtual Link Question

Hello

It would hard to say now what could have been the issue, However I would just to confirm that your original query reagrds the VL configuration relating to your topology was indeed correct.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: OSPF Virtual Link Question

So I have been researching and have not found a solid answer. What would you do if you has a VL showing as down? In all my studies so far for the ROUTE, I have no come across anything about it yet. This include the OCG, a class through Global Knowledge, a course on Udemy by Chris Bryant, Chris Bryant's study guide, as well as cisco docs. 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards