03-01-2017 04:59 PM - edited 03-05-2019 08:07 AM
From the above Topology (Sorry for size), I've gotten everything except the NBMA to form an adjacency, and I had kind of some derp moments like forgetting to no shut interfaces - However I think I finally got all the configs correct but it JUST WON'T FORM AN ADJACENCY TO ITS SPOKEY ROUTERS!
I also did a "debug ipv6 ospf pack" and literally got no output at all, which to me was very odd, given the config confirms it is up and active below.
Would a more knowledgeable individual on the matter look at the hub and two spoke router running configs, and see what I did wrong?
It will be in S0/0 on R1 and R2, and S0/2 on R3 in the NBMA (And I did double check the link-local addy's):
R1
R1#sh run
Building configuration...
*Mar 1 21:50:26.320: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 1198 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$hFVy$8y19EZ2x/uk.bCGWnWZrB/
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
ipv6 address 2001::1/64
ipv6 enable
ipv6 ospf neighbor FE80::20F:23FF:FE09:B180
ipv6 ospf neighbor FE80::20E:D7FF:FE10:6C60
ipv6 ospf 1 area 123
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
!
!
ip http server
no ip http secure-server
!
ipv6 router ospf 1
router-id 1.1.1.1
log-adjacency-changes
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password CCNP
logging synchronous
login
!
!
end
R1#
R2
R2#sh run
Building configuration...
Current configuration : 1274 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$zkNU$E1C2GXoGTu9942xIPNrro/
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback2
no ip address
ipv6 address 2022::1/128
ipv6 enable
ipv6 ospf 1 area 2
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2023::2/64
ipv6 enable
ipv6 ospf 1 area 0
!
interface Serial0/0
no ip address
encapsulation frame-relay
ipv6 address 2001::2/64
ipv6 enable
ipv6 ospf priority 0
ipv6 ospf 1 area 123
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
!
!
ip http server
--More--
no ip http secure-server
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password CCNP
logging synchronous
login
!
!
end
R2#
R3
R3#sh run
Building configuration...
Current configuration : 1374 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$QFdX$9tC33yHOlq4pSVjJcmMnd0
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0
framing sf
linecode ami
!
controller T1 0/1
framing sf
linecode ami
!
!
!
!
!
!
interface Loopback3
no ip address
ipv6 address 2033::1/128
ipv6 ospf 1 area 3
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2023::3/64
ipv6 enable
ipv6 ospf 1 area 0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2034::3/64
ipv6 enable
ipv6 ospf 1 area 34
!
interface Serial0/2
no ip address
encapsulation frame-relay
ipv6 address 2001::3/64
ipv6 enable
ipv6 ospf priority 0
ipv6 ospf 1 area 123
no frame-relay inverse-arp
!
interface Serial0/3
no ip address
shutdown
!
!
!
ip http server
no ip http secure-server
!
ipv6 router ospf 1
router-id 3.3.3.3
log-adjacency-changes
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password CCNP
logging synchronous
login
!
!
end
R3#
And to show my work, I have everything addressed and working aside from this NBMA:
My route table on R4:
R4#sh ipv6 route ospf
IPv6 Routing Table - default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
D - EIGRP, EX - EIGRP external, NM - NEMO, ND - Neighbor Discovery
l - LISP
O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
OI 2001::/64 [110/65]
via FE80::20F:23FF:FE09:B181, FastEthernet0/1
OI 2022::1/128 [110/2]
via FE80::20F:23FF:FE09:B181, FastEthernet0/1
OI 2023::/64 [110/2]
via FE80::20F:23FF:FE09:B181, FastEthernet0/1
OI 2033::1/128 [110/1]
via FE80::20F:23FF:FE09:B181, FastEthernet0/1
A ping over to R2's loopback:
R4#ping 2022::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2022::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/4 ms
R4#
I can ping everything except those two serial interfaces in the NBMA network on R1 and R2 2001::1 and 2001::2, though R3's 2001::3 works without an issue. I've tried adding the encap from / no frame inverse arp, I've tried shutting down all other OSPFv3 interfaces and clearing the ipv6 OSPF proc several times, it will not change from ATTEMPT/DOWN:
Neighbor ID Pri State Dead Time Interface ID Interface
N/A 0 ATTEMPT/DROTHER 00:00:20 0 Serial0/0
N/A 0 ATTEMPT/DROTHER 00:00:20 0 Serial0/0
R1#
The odd thing is, it will show they fail to form adjacencies twice, then it stops trying and the Time field actually goes blank.
Any Idears?
03-01-2017 05:49 PM
Hi David,
Good day!!
Can you try making use of neighbor command?
Bibin Paul
03-01-2017 06:10 PM
Hey Bibin,
Thanks so much for taking a look at this, under the R1 "sh run" this is configured on the Hub's interface on that topology as follows:
!
interface Serial0/0
no ip address
encapsulation frame-relay
ipv6 address 2001::1/64
ipv6 enable
ipv6 ospf neighbor FE80::20F:23FF:FE09:B180
ipv6 ospf neighbor FE80::20E:D7FF:FE10:6C60
ipv6 ospf 1 area 123
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
I made a quick post on my blog here:
https://loopedback.com/2017/03/01/part-2-ipv6-ospfv3-configuration-on-hub-in-nbma-hub-stuck-with-neighbors-in-attemptdrother-state/
Of the configuration, it was strictly of the R1 Serial0/0 interface and pointing out the error it throws if you use IPv6 address instead of the link-local, etc, and could just never get the adjacency to form.
The spokes both have "ipv6 ospf pri 0" on NBMA interfaces, and of course their own ospfv3 configs on their respective serial interfaces.
It is driving me mad, any ideas are very welcome :)
03-04-2017 06:02 AM
So someone had mentioned it appears I was missing fame maps for my NBMA, and I added them with or without broadcast as an option even though IPv6 doesn't do Broadcasts and that configuration didn't work either :(
I am going to wr er my NBMA Hub and Spokes, and only configure their 3 NBMA interfaces as Area 0 for OSPv3 and see if I can get this working in any way shape or form!!
05-23-2018 08:52 AM
I am studying for ccnp route, and was following Chris Bryant video. Got stuck at the same issue as you were. Adjacencies are not forming and its driving me insane.
here are the run config of router 1,2 and 3 of nbma network.
R1#show run
Building configuration...
Current configuration : 1746 bytes
!
! Last configuration change at 11:37:16 UTC Wed May 23 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
no ip address
ipv6 address 2010::1/64
ipv6 enable
ipv6 ospf 1 area 1
!
interface FastEthernet0/0
no ip address
speed auto
duplex auto
ipv6 address 2015::1/64
ipv6 enable
ipv6 ospf 1 area 0
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
ipv6 address 2001::1/64
ipv6 enable
ipv6 ospf 1 area 123
ipv6 ospf neighbor FE80::C803:7FF:FEA5:8
ipv6 ospf neighbor FE80::C802:7FF:FE96:8
serial restart-delay 0
frame-relay map ipv6 2001::3 103 broadcast
frame-relay map ipv6 2001::2 102 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
ipv6 address 2014::1/64
ipv6 enable
ipv6 ospf 1 area 14
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
router-id 1.1.1.1
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
R1#
R2#show run
Building configuration...
Current configuration : 1492 bytes
!
! Last configuration change at 11:41:09 UTC Wed May 23 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
ipv6 address 2001::2/64
ipv6 enable
ipv6 ospf 1 area 123
ipv6 ospf priority 0
serial restart-delay 0
frame-relay map ipv6 2001::3 202 broadcast
frame-relay map ipv6 2001::1 202 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
router-id 2.2.2.2
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
R2#
Building configuration...
Current configuration : 1492 bytes
!
! Last configuration change at 11:31:08 UTC Wed May 23 2018
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet0/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial1/0
no ip address
encapsulation frame-relay
ipv6 address 2001::3/64
ipv6 enable
ipv6 ospf 1 area 123
ipv6 ospf priority 0
serial restart-delay 0
frame-relay map ipv6 2001::2 303 broadcast
frame-relay map ipv6 2001::1 303 broadcast
no frame-relay inverse-arp
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
router-id 3.3.3.3
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end
R3#
R1#show ipv6 osp
*May 23 11:51:39.495: OSPFv3-1-IPv6 ADJ Se1/0: Sending poll to 0.0.0.0 address FE80::C803:7FF:FEA5:8
*May 23 11:51:39.515: OSPFv3-1-IPv6 ADJ Se1/0: Sending poll to 0.0.0.0 address FE80::C802:7FF:FE96:8
R1#show ipv6 ospf ne
OSPFv3 Router with ID (1.1.1.1) (Process ID 1)
Neighbor ID Pri State Dead Time Interface ID Interface
5.5.5.5 1 FULL/DR 00:00:35 8 FastEthernet0/0
4.4.4.4 0 FULL/ - 00:00:36 5 Serial1/1
N/A 0 ATTEMPT/DROTHER - 0 Serial1/0
N/A 0 ATTEMPT/DROTHER - 0 Serial1/0
R1#
Any help on what is wrong with this configuration? why is R1 not forming adjacencies with R2 and R3?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide