cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
644
Views
0
Helpful
7
Replies

Packet tracer OSPF into BGP setup help/suggestions

thom784e
Level 1
Level 1

thom784e_0-1705487735155.png

 

Hello i currently have this small setup. i have configured ip routing on the L3's and want to use those as gateways on the PC's and then have them send the data to the router.

Right now the PC's send their data to the HSRP standby IP i've setup between the L3 switches.

How should i configure the switches to be able to have a redundant link to the router? do i add more ports to the router and do a port channel between the router and both the L3 switches and then set an IP on the port channel and do the
"

ip default-gateway (ip of port channel 5 interface on router)


on one L3-01 and do the same but with a different port channel and IP on L3-02?

i will be doing a copy paste setup next to this aswell and plan on trying to do a BGP setup to allow PC1 to access some stuff on the other OSPF Area but i haven't worked with BGP before so if you guys have a good tutorial you could recommend i would appriciate that

if you need any other info to be able to help i will do my best to provide it asap

thanks for your time

1 Accepted Solution

Accepted Solutions

two solution 
1- use Dual HSRP and static route toward HSRP VIP 
Screenshot (680).png

R1#show run
R1#show running-config
Building configuration...
(C7200-ADVIPSERVICESK9-M), Version 15.2(4)S5, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Thu 20-Feb-14 06:51 by prod_rel_team
Current configuration : 1746 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
track 1 interface FastEthernet1/1 line-protocol
!
track 2 interface FastEthernet0/0 line-protocol
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
standby 10 ip 10.0.0.10
standby 10 priority 110
standby 10 preempt
standby 10 track 1 decrement 30
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 20.0.0.1 255.255.255.0
standby 20 ip 20.0.0.20
standby 20 priority 110
standby 20 preempt
standby 20 track 2 decrement 30
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 30.0.0.0 255.255.255.0 20.0.0.3
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end







R2#show run
R2#show running-config
Building configuration...

Current configuration : 1554 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.0
standby 10 ip 10.0.0.10
standby 10 priority 90
standby 10 preempt
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 20.0.0.2 255.255.255.0
standby 20 ip 20.0.0.20
standby 20 preempt
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 30.0.0.0 255.255.255.0 20.0.0.3
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

R3#show run
R3#show running-config
Building configuration...

Current configuration : 1441 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 30.0.0.3 255.255.255.0
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 20.0.0.3 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 10.0.0.0 255.255.255.0 20.0.0.20
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end




or 

2- use EEM with HSRP

R3#
R3#
R3#show run
R3#show running-config
Building configuration...

Current configuration : 2339 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
track 10 ip sla 10 reachability
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
ip address 200.0.0.3 255.255.255.0
ip ospf cost 100
speed auto
duplex auto
!
interface Serial3/0
ip address 100.0.0.3 255.255.255.0
ip ospf cost 1000
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
ip ospf cost 100
serial restart-delay 0
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
router ospf 100
network 3.3.3.3 0.0.0.0 area 0
network 100.0.0.0 0.0.0.255 area 0
network 200.0.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 10.0.0.2 255.255.255.255 FastEthernet2/1 permanent
!
ip sla 10
icmp-echo 10.0.0.2 source-interface FastEthernet2/1
ip sla schedule 10 life forever start-time now
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
event manager applet HSRP-VIP1
event track 10 state down
action 1.0 cli command "enable"
action 1.1 cli command "conf t"
action 1.2 cli command "router ospf 100"
action 1.3 cli command "no net 200.0.0.0 0.0.0.255 area 0"
action 1.4 cli command "exit"
event manager applet HSRP-VIP2
event track 10 state up
action 1.0 cli command "enable"
action 1.1 cli command "conf t"
action 1.2 cli command "router ospf 100"
action 1.3 cli command "net 200.0.0.0 0.0.0.255 area 0"
action 1.4 cli command "exit"
!
end

Screenshot (681).png

otherwise the router always send traffic toward the one l3SW even if it not active 
MHM

View solution in original post

7 Replies 7

IGP with hsrp is need alot of work 

Instead 

In router config static route toward VIP of HSRP

In each l3SW config defualt route toward router 

MHM

In router config static route toward VIP of HSRP

so i should set a static route that anything that needs to go to vlan 1 gets sent to the vlan 1 HSRP IP

(ip route x.x.x.xip of other network on the other bgp x.x.x.xhsrp ip

so set an ip on the 2 interfaces on the router, and configure both L3 switches to point to both? or just the one connected.

let lab it and send to you the exact steps 
MHM

Hello,

can you post your (zipped) Packet Tracer project (.pkt) file ?

Are you using HSRP standby tracking ?

there you go

yes i have HSRP standby on the L3 switches

two solution 
1- use Dual HSRP and static route toward HSRP VIP 
Screenshot (680).png

R1#show run
R1#show running-config
Building configuration...
(C7200-ADVIPSERVICESK9-M), Version 15.2(4)S5, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Thu 20-Feb-14 06:51 by prod_rel_team
Current configuration : 1746 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
track 1 interface FastEthernet1/1 line-protocol
!
track 2 interface FastEthernet0/0 line-protocol
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
standby 10 ip 10.0.0.10
standby 10 priority 110
standby 10 preempt
standby 10 track 1 decrement 30
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 20.0.0.1 255.255.255.0
standby 20 ip 20.0.0.20
standby 20 priority 110
standby 20 preempt
standby 20 track 2 decrement 30
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 30.0.0.0 255.255.255.0 20.0.0.3
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end







R2#show run
R2#show running-config
Building configuration...

Current configuration : 1554 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.0
standby 10 ip 10.0.0.10
standby 10 priority 90
standby 10 preempt
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 20.0.0.2 255.255.255.0
standby 20 ip 20.0.0.20
standby 20 preempt
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 30.0.0.0 255.255.255.0 20.0.0.3
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end

R3#show run
R3#show running-config
Building configuration...

Current configuration : 1441 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 30.0.0.3 255.255.255.0
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
ip address 20.0.0.3 255.255.255.0
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
no ip address
shutdown
speed auto
duplex auto
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 10.0.0.0 255.255.255.0 20.0.0.20
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
!
end




or 

2- use EEM with HSRP

R3#
R3#
R3#show run
R3#show running-config
Building configuration...

Current configuration : 2339 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
track 10 ip sla 10 reachability
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex full
!
interface FastEthernet1/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet1/1
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/0
no ip address
shutdown
speed auto
duplex auto
!
interface FastEthernet2/1
ip address 200.0.0.3 255.255.255.0
ip ospf cost 100
speed auto
duplex auto
!
interface Serial3/0
ip address 100.0.0.3 255.255.255.0
ip ospf cost 1000
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
ip ospf cost 100
serial restart-delay 0
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
router ospf 100
network 3.3.3.3 0.0.0.0 area 0
network 100.0.0.0 0.0.0.255 area 0
network 200.0.0.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 10.0.0.2 255.255.255.255 FastEthernet2/1 permanent
!
ip sla 10
icmp-echo 10.0.0.2 source-interface FastEthernet2/1
ip sla schedule 10 life forever start-time now
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
event manager applet HSRP-VIP1
event track 10 state down
action 1.0 cli command "enable"
action 1.1 cli command "conf t"
action 1.2 cli command "router ospf 100"
action 1.3 cli command "no net 200.0.0.0 0.0.0.255 area 0"
action 1.4 cli command "exit"
event manager applet HSRP-VIP2
event track 10 state up
action 1.0 cli command "enable"
action 1.1 cli command "conf t"
action 1.2 cli command "router ospf 100"
action 1.3 cli command "net 200.0.0.0 0.0.0.255 area 0"
action 1.4 cli command "exit"
!
end

Screenshot (681).png

otherwise the router always send traffic toward the one l3SW even if it not active 
MHM

thanks a lot, i think i can use some of this to edit my setup.

Review Cisco Networking for a $25 gift card