cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3239
Views
0
Helpful
2
Replies

PAT configuration in Packet Tracer 6.2

oarga_mihai1
Level 1
Level 1

Hello,

I'm having trouble with setting up PAT in packet tracer. The problem is that if i set up PAT i can no access the http server. With static nat everything is ok. Can you give me a hint what i'm doing wrong?

Building configuration...

Current configuration : 823 bytes

!

version 15.1

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

!

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

!

!

license udi pid CISCO2901/K9 sn FTX1524G3J2

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

!

!

interface GigabitEthernet0/0

ip address 1.0.0.2 255.255.255.252

ip nat inside

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 2.0.0.1 255.255.255.252

ip nat outside

duplex auto

speed auto

!

interface Vlan1

no ip address

shutdown

!

router eigrp 10

network 2.0.0.0

network 1.0.0.0

!

ip nat inside source list 1 interface GigabitEthernet0/1 overload

ip classless

!

ip flow-export version 9

!

!

access-list 1 permit 10.0.0.0 0.0.0.255

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

2 Replies 2

Borgenstrand
Level 1
Level 1

I can see that you are doing PAT on CopyRouter4 according to your topology.
As it is now, the PC do not know which IP the Server-PT is using. If you want the Server to have a public IP address, you need to use static NAT so you know which IP address it is using. You can give it 2.0.0.1:80 or 2.0.0.1:443 if you want to give it just a port-number instead of the entire IP address.

Hello


Youll need a Nat static to identify a specific port to nat towards, As PAT wont know what to translate to without it.

So if there is only one HTTP destination device then you can add a static defining the outside interface and inside ip address of the http server and port number, However is their are multiple destination inside your network then you can do the same but using different inside host and port number

ip nat inside source static tcp x.x.x.x interface gig0/1 80
ip nat inside source static tcp x.x.x.x interface gig0/1 8080


or as you have already stated, you can use individual statics  with individual public addressing (thats if you have public ips free to use)

ip nat inside source static tcp  x.x.x.x 80 2.0.0.5 80
ip nat inside source static tcp  x.x.x.x 80 2.0.0.6 80

res
Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul