cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
259
Views
5
Helpful
4
Replies
Highlighted
Beginner

Pinging from within VLAN to router (Access layer - core layer)

Hi,

I've got a network set up in a hierarchical design and want to get the PCs on the access layer to be able to ping the routers at the core layer. Currently they can all ping each other, within and outside their VLANs, but cannot ping any further than this. 

I'll include a config of the switches/router below. All the devices at each layer have the same setup, so I'll just include one for each. If anyone could give me any pointers, that'd be great. I'm still pretty new to this, I've tried a few things but I haven't made any progress for a while.

Thanks

-Stuart

 

Switches:

interface Port-channel1

switchport mode trunk

!

interface FastEthernet0/1

switchport mode trunk

channel-group 1 mode active

!

interface FastEthernet0/2

switchport mode trunk

channel-group 1 mode active

!

interface FastEthernet0/3

switchport mode trunk

!

interface FastEthernet0/10

switchport access vlan 10

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 20

switchport mode access

 

 

 

Multilayer Switches:

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel4

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel5

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

!

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode active

!

interface FastEthernet0/3

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

!

interface FastEthernet0/4

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode active

!

interface FastEthernet0/5

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 3 mode active

!

interface FastEthernet0/6

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 3 mode active

!

interface FastEthernet0/7

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode active

!

interface FastEthernet0/8

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode active

!

interface FastEthernet0/9

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode active

!

interface FastEthernet0/10

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode active

!

interface FastEthernet0/15

no switchport

ip address 192.168.1.5 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/24

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode active

!

interface GigabitEthernet0/1

no switchport

ip address 10.1.1.1 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan10

mac-address 0002.1658.5d01

ip address 192.168.10.1 255.255.255.0

!

interface Vlan20

mac-address 0002.1658.5d02

ip address 192.168.20.1 255.255.255.0

!

interface Vlan30

mac-address 0002.1658.5d03

ip address 192.168.30.1 255.255.255.0

!

interface Vlan40

mac-address 0002.1658.5d04

ip address 192.168.40.1 255.255.255.0

!

interface Vlan99

mac-address 0002.1658.5d05

ip address 192.168.99.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 192.168.1.0 0.0.0.255 area 0

!

ip classless

 

 

 

Router:

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

standby version 2

standby 1 ip 192.168.1.254

standby 1 preempt

!

interface Serial0/0/0

ip address 10.1.1.1 255.255.255.252

clock rate 128000

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 192.168.1.0 0.0.0.255 area 0

network 10.1.1.0 0.0.0.3 area 0

!

ip classless

 

I have HSRP set up with the routers, so their virtual IP is 192.168.1.254. This shouldn't affect my ability to ping, should it?

 

ScreenHunter_452 Apr. 29 17.25.jpg

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Master

Re: Pinging from within VLAN to router (Access layer - core layer)

I would not think that HSRP has anything to do with your issue about pinging. The main issue is in the way that you configured routing on the switch:

router ospf 1

log-adjacency-changes

network 192.168.1.0 0.0.0.255 area 0

 

Your network statement identifies only a single subnet, which is the subnet where you are neighbor with the router. But nothing in the config tells OSPF to advertise the subnets of the vlans. You need either to have network statements for those subnets or you need to redistribute connected.

 

HTH

 

Rick

4 REPLIES 4
Advocate

Re: Pinging from within VLAN to router (Access layer - core layer)

Hi @Stuart D ,

 

If you like, you can attach your exercise to review what you have done so far.

 

Regards

Hall of Fame Master

Re: Pinging from within VLAN to router (Access layer - core layer)

I would not think that HSRP has anything to do with your issue about pinging. The main issue is in the way that you configured routing on the switch:

router ospf 1

log-adjacency-changes

network 192.168.1.0 0.0.0.255 area 0

 

Your network statement identifies only a single subnet, which is the subnet where you are neighbor with the router. But nothing in the config tells OSPF to advertise the subnets of the vlans. You need either to have network statements for those subnets or you need to redistribute connected.

 

HTH

 

Rick

Beginner

Re: Pinging from within VLAN to router (Access layer - core layer)

Thanks Rick! I had tried that earlier but I must have typed it in wrong because it wasn't working, I could've spent forever trying to figure that out! Maybe one day I'll get the hang of this whole networking thing!
Hall of Fame Master

Re: Pinging from within VLAN to router (Access layer - core layer)

Glad to know that you got it working and that my suggestion pointed you in the right direction. There are several possibilities about why it did not work before. Without knowing the specifics of what you tried we do not know why it did not work. And the fact that it is working now is ultimately more important than why it did not work before. Thank you for marking this question as solved. This will help other participants in the community to identify discussions which have helpful information. This community is an excellent place to ask questions and to learn about networking. I hope to see you continue to be active in the community.

 

HTH

 

Rick

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards