cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
8897
Views
45
Helpful
37
Replies

Please help to configure 871W Router for internet connection!

David Belmont
Level 1
Level 1

Hi, everybody!

I've just started styding for CCNA, so I'm totaly new to Cisco stuff. Bought a router 871W recently and spent two days straight trying to configure internet connection with no luck! I use console port to do the configs and SDM/CCP. Would be greateful if somebody could tell me how to do simple internet connection configs. I googled everything but it's still confusing. I can't assing any IP to FA ports 0 - 3. I used VLAN instead. But all tutorials use FA0 and when I try to assign an IP to FA0 it gives me some L2 can't be assigned or something... :/ And I'm also confused what IP address should I use for WAN.

I plugged the cable from Modem to PC's LAN port and wrote down some IP addresses which I think I'll have to use to configure the router for internet connection. And here they are:


ISP IP: 76.114.54.255

SUBNET: 255.255.248.0

GATEWAY: 76.114.48.1

DHCP: 69.252.97.4

DNS: 75.75.75.75

         75.75.76.76

If you can, please help! Thanks!

4 Accepted Solutions

Accepted Solutions

hi david,

seems like your 871w can't get any dynamic IP: %Unknown DHCP problem.. No allocation possible

could you ask your ISP to perform a reset/clear MAC add and try again?

also, kindly post lastest 'show run'

edit: just saw you've updated your screenshot. could you add command under FE4

mac-add 0001.4af9.8b83

View solution in original post

Hello David, the MAC address on FE4 should be this: 001f.ca6b.d8c8

As this is the MAC address of the router itself. I could see that you had configured your interface to have a mac of the Sony device I think. But we do not want that.

Try changing it to the mac mentioned above and see if it works.

Sent from Cisco Technical Support iPhone App

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

Hello, your mac address for the actual router interface is displayed in show interface fe4

show int fa4
FastEthernet4 is up, line protocol is up
Hardware is PQUICC_FEC, address is 0001.4af9.8b83 (bia 001f.ca6b.d8c8)

Here we can see that the BIA (burnt in address) is a MAC address of a Cisco device - being the router itself. However, because you have configured it to use the MAC address of the Sony device the router is now using that to communicate with the modem. 0001.4af9.8b83 belongs to your sony device. So the router will see the MAC address of the Sony device, but it may get confused because its own MAC address is configured to be the same!

The MAC address should be FE4 so it can get an IP from the modem as 'itself' and not appear to be the Sony device.

It's working with PC1 because you're not using the MAC address of PC1, so I think this is what's happening! :-)

Router(config-if)#mac-address 001f.ca6b.d8c8

So please try this and see if there are any changes in the results

Hope this helps.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

Hello David, thanks for this - sorry I was a bit unclear, I wanted to see what happens when you use your routers mac address instead - do you see its mac address on the motorola?

But before we do this, I want you to try this for us please:

interface FastEthernet4

no mac-address 0001.4af9.8b83

no ip address dhcp client-id FastEthernet4

ip dhcp client-id hex 001fca6bd8c8

ip dhcp client hostname Point38

ip address dhcp

Then shut the interface down, then bring it back up after 5 seconds or so.

If you configure a Cisco router as a DHCP client, it may use a weird client-id in its DHCP requests. Instead of using the interface MAC address as the client ID (as most workstations do), the client ID is the string 'cisco-dotted.mac.ascii-ifname' where the dotted.mac.ascii is the interface MAC address in ascii and the ifname is the short interface name.

So give this a go - I tried this between two cisco routers, I know its not the same tests but I saw different behaviour with these commands.

Hope this helps

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

37 Replies 37

johnlloyd_13
Level 9
Level 9

hi david,

did you set your PC to auto obtain an IP?

if it is, probably the ISP assigns a dynamic IP, configure FE4 as below.

interface fa4

ip address dhcp client-id fastethernet 4

FE 0-3 are layer 2 only ports and under VLAN 1 by default. configure SVI/LAN gateway IP with your preferred private IP address (google or refer RFC 1918).

interface vlan 1

ip address

you'll need DHCP and NAT enabled for other LAN clients/hosts to surf the web.

ip dhcp pool

network /SUBNET MASK

default-router

dns-server 75.75.75.75 75.75.75.76

int fa4

ip nat outside

int vlan1

ip nat inside

access-list 1 permit

ip nat inside source list 1 fa4 overload

add a static default route so that clients can go to the web. remember to save your config ("copy run start" for CCNAs)

ip route 0.0.0.0 0.0.0.0 dhcp

write memory  

Thanks for quick reply John!

I've tried to punch in your configs but now sure if I've done it right due to lack of subnetting knowledge... Yes, I set my PC to obtain IPs by using DHCP. I can give it a static IP if necessary. Currently I'm able to ping the router from pc and pc from the router. But still no internet connection. I've tried to test FastEthernet4 with CCP and it gave me this:


Checking interface IP address..                               |         Failed

No IP address for the interface has been obtained. The interface is configured to obtain an IP address through DHCP. The remote end may not be configured with a DHCP server or the DHCP pool may be empty.

But I'm not sure if I can trust this software just because yesterday connection was successful and still there was no internt connection.

___________________________________________________________________________________________________

Here are my Router configs:

Router#show run

Building configuration...

Current configuration : 2951 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

no ip dhcp use vrf connected

!

ip dhcp pool DHCP_POOL

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 75.75.75.75 75.75.76.76

!

crypto pki trustpoint TP-self-signed-2115742889

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2115742889

revocation-check none

rsakeypair TP-self-signed-2115742889

!

crypto pki certificate chain TP-self-signed-2115742889

certificate self-signed 01

  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32313135 37343238 3839301E 170D3131 30393037 32313133

  30335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31313537

  34323838 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100CD81 CACC71A5 2A0A35C4 5A6598E9 A78B8167 11D2EA22 EA7C6B63 3D12AD5C

  671E5896 D3BA86CD AF2F9230 A8C1DBC9 65D529EC F9E44975 175A6554 EE3CE29E

  C3B6AB9E 2FDD5A55 4D1249CC 37101125 F55BC25D D9FF17C3 282DA1EF A2BA56F4

  3060E197 5C963A39 4ED08A8D C2CFB556 899D5D50 1FFF9F59 A9243C46 3F501566

  60950203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603

  551D1104 0B300982 07526F75 7465722E 301F0603 551D2304 18301680 14EEE106

  6C3A65DC E574C5A4 FEAD137B 2F950691 17301D06 03551D0E 04160414 EEE1066C

  3A65DCE5 74C5A4FE AD137B2F 95069117 300D0609 2A864886 F70D0101 04050003

  81810057 9E0A85A2 274C3B42 2D79FC55 CF70C7D0 AB3E3ABB 06310C37 80569306

  6C94D8D3 DAB3FFE2 D743FD3F DAF8CB5C DEF84219 07F942F9 CA2BF41B A5471257

  C9B12A20 F448B577 E162BDBC 6DCDBD41 E40AB3D2 AE5B50E9 713BB2D5 54B32602

  A06FFB2C BB96DF24 3B258827 BDFE4AFA 811912C1 37FFDAC8 AF1E0213 5A0A06C6 4BA6D5

  quit

username Point38 privilege 15 password 0 Terminal38

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address dhcp client-id FastEthernet4

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip classless

ip route 0.0.0.0 0.0.0.0 dhcp

!

ip http server

ip http secure-server

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

control-plane

!

alias exec s show ip int brief

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

PC Configs assigned by DHCP:

IP: 192.168.1.2

SUBNET: 255.255.255.0

GATEWAY: 192.168.1.1

DHCP Server: 192.168.1.1

DNS Servers: 75.75.75.75

                    75.75.76.76

Please have a look when you'll have a chance. Thanks!

hi david,

your config looks ok and i believe you're on track.

ccp is not very flexible when it comes to troubleshooting. was internet working prior?

could you post show ip interface brief?

try rebooting cable modem (advisable to remove/insert power source) and do a shut/no shut on FE4. give it a try and let me know.

Nope, there was no internet connection on this router. I've a cheap Belkin $30 and it works just fine, plug the cable and that's it. Rebooted, turned off and on FA4.

Router#s

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0              unassigned      YES unset  up                    up

FastEthernet1              unassigned      YES unset  up                    down

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

FastEthernet4              unassigned      YES DHCP   up                    up

Dot11Radio0                unassigned      YES TFTP   administratively down down

Vlan1                      192.168.1.1     YES NVRAM  up                    up

NVI0                       unassigned      YES unset  up                    up

Virtual-Dot11Radio0        unassigned      YES TFTP   administratively down down

Hi,

Can you do this:

config t

no service timestamp debug

logging buffered debug 100000

do debug dhcp detail

int fa4

shut

no shut

do sh log

and post output here

then disable this debug: do undebug  all

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

debug dhcp helped a lot. will add this command under my tool belt.

+5 alain! 

Hello, I just wanted to point out the 'ip route 0.0.0.0 0.0.0.0 dhcp' is that correct?

When you pick up an IP address from DHCP the default router option is given out with that lease and the router automatically adds a static default route in place towards its default gateway.

Not sure about the dhcp address not being given out.... Could we simply try 'ip address dhcp' only?

Hope this helps

Sent from Cisco Technical Support iPhone App

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Could you also kindly show us the output from 'show interface fa4' please?

Sent from Cisco Technical Support iPhone App

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

hi bilal,

you've got a point there and could be right. i just put the command there out on top of my head.

OP can alternatively use 'import all' on the DHCP option.

david,

could you try removing the static default route and add in import all on DHCP.

also, perform 'renew dhcp f4' and the debug as per alain's advice to help us further dignose.

no ip route 0.0.0.0 0.0.0.0 dhcp

ip dhcp pool DHCP_POOL

import all

Hi john,

import all and ip route 0.0.0.0 0.0.0.0 dhcp are not related to my best knowledge, what import all does is use DHCP infos received on the client side and advertise it on the server side to the clients.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

hi alain,

last time i've checked it works with both static route pointing to dhcp and with import all enabled.

maybe OP can play around and try which one works.

Oh boy, what a nightmare.

Have tried everything above, hope it's not hardware's fault.

______________________________________________________

Stpep 1 per Alain: do debug dhcp detail (it was a nice show btw.)

                           (Haven't done any changes since the last time.)

______________________________________________________

Router(config)#no service timestamp debug

Router(config)#logging buffered debug 100000

Translating "buffered"...domain server (255.255.255.255)

                                      ^

% Invalid input detected at '^' marker.

Router(config)#do debug dhcp detail

DHCP client activity debugging is on (detailed)

Router(config)#int fa4

Router(config-if)#shut

Router(config-if)#no shut

Router(config-if)#do sh log

DHCP: Release IPL called for interface FastEthernet4 in state 9

RAC: DHCP stopped on interface FastEthernet4

DHCP: DHCP client process started: 10

RAC: Starting DHCP discover on FastEthernet4

DHCP: Try 1 to acquire address for FastEthernet4

DHCP: allocate request

DHCP: zapping entry in DHC_PURGING state for Fa4

DHCP: deleting entry 83578C6C 0.0.0.0 from list

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 9 Purging

   DHCP transaction id: 156

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:23

   Retry count: 0   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: new entry. add to queue, interface FastEthernet4

DHCP: SDiscover attempt # 1 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1146

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 1   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: SDiscover attempt # 2 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1146

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 2   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: SDiscover attempt # 3 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1146

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 3   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible

DHCP: Waiting for 5 seconds on interface FastEthernet4

DHCP: Try 2 to acquire address for FastEthernet4

DHCP: allocate request

DHCP: zapping entry in DHC_PURGING state for Fa4

DHCP: deleting entry 83578C6C 0.0.0.0 from list

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 9 Purging

   DHCP transaction id: 1146

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:26

   Retry count: 0   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: new entry. add to queue, interface FastEthernet4

DHCP: SDiscover attempt # 1 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1147

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 1   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: SDiscover attempt # 2 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1147

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 2   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: SDiscover attempt # 3 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1147

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 3   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

Syslog logging: enabled (1 messages dropped, 1 messages rate-limited,

                0 flushes, 0 overruns, xml disabled, filtering disabled)

    Console logging: level debugging, 566 messages logged, xml disabled,

                     filtering disabled

    Monitor logging: level debugging, 0 messages logged, xml disabled,

                     filtering disabled

    Buffer logging: disabled, xml disabled,

                    filtering disabled

    Logging Exception size (4096 bytes)

    Count and timestamp logging messages: disabled

No active filter modules.

    Trap logging: level informational, 34 message lines logged

DHCP: QScan: Timed out Selecting state

Router(config-if)#do undebug  all

____________________________________________________

____________________________________________________

Step 2 per Bilal:

ip address dhcp (didn't help)

____________________________________________________

Router#show interface fa4

FastEthernet4 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 001f.ca6b.d8c8 (bia 001f.ca6b.d8c8)

  Internet address will be negotiated using DHCP

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1000 bits/sec, 3 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     109 packets input, 6540 bytes

     Received 109 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     7 packets output, 3185 bytes, 0 underruns

     0 output errors, 0 collisions, 3 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

Router#

_________________________________________________

__________________________________________________________________________

Step 3 per John: when renewing DHCP I got this message: Not in Bound state.
somebody had the same problem over here: https://supportforums.cisco.com/thread/25334

__________________________________________________________________________

Router#conf t

Router(config)#no ip route 0.0.0.0 0.0.0.0 dhcp

Router(config)#ip dhcp pool DHCP_POOL

Router#renew dhcp fa4

Not in Bound state.

Router#s

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0              unassigned      YES unset  up                    up

FastEthernet1              unassigned      YES unset  up                    down

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

FastEthernet4              unassigned      YES DHCP   up                    up

Dot11Radio0                unassigned      YES TFTP   administratively down down

Vlan1                      192.168.1.1     YES NVRAM  up                    up

NVI0                       unassigned      YES unset  up                    up

Virtual-Dot11Radio0        unassigned      YES TFTP   administratively down down

Router#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#no service timestamp debug

Router(config)#logging buffered debug 100000

Translating "buffered"...domain server (255.255.255.255)

                                      ^

% Invalid input detected at '^' marker.

Router(config)#do debug dhcp detail

DHCP client activity debugging is on (detailed)

Router(config)#int fa4

Router(config-if)#shut

Router(config-if)#no shut

Router(config-if)#do sh log

DHCP: Release IPL called for interface FastEthernet4 in state 1

RAC: DHCP stopped on interface FastEthernet4

DHCP: DHCP client process started: 10

RAC: Starting DHCP discover on FastEthernet4

DHCP: Try 1 to acquire address for FastEthernet4

DHCP: allocate request

DHCP: zapping entry in DHC_PURGING state for Fa4

DHCP: deleting entry 834DBAB0 0.0.0.0 from list

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 9 Purging

   DHCP transaction id: 2B

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:31

   Retry count: 0   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: new entry. add to queue, interface FastEthernet4

DHCP: SDiscover attempt # 1 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1CD4

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 1   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: SDiscover attempt # 2 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1CD4

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 2   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: SDiscover attempt # 3 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1CD4

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 3   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible

DHCP: Waiting for 5 seconds on interface FastEthernet4

DHCP: Try 2 to acquire address for FastEthernet4

DHCP: allocate request

DHCP: zapping entry in DHC_PURGING state for Fa4

DHCP: deleting entry 833F6198 0.0.0.0 from list

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 9 Purging

   DHCP transaction id: 1CD4

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:26

   Retry count: 0   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: new entry. add to queue, interface FastEthernet4

DHCP: SDiscover attempt # 1 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1CD5

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 1   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: SDiscover attempt # 2 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1CD5

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 2   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: SDiscover attempt # 3 for entry:

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 1 Selecting

   DHCP transaction id: 1CD5

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:04

   Retry count: 3   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible

DHCP: Waiting for 10 seconds on interface FastEthernet4

DHCP: Try 3 to acquire address for FastEthernet4

DHCP: allocate request

DHCP: zapping entry in DHC_PURGING state for Fa4

DHCP: deleting entry 837DC944 0.0.0.0 from list

Temp IP addr: 0.0.0.0  for peer on Interface: FastEthernet4

Temp  sub net mask: 0.0.0.0

   DHCP Lease server: 0.0.0.0, state: 9 Purging

   DHCP transaction id: 1CD5

   Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs

   Next timer fires after: 00:00:21

   Retry count: 0   Client-ID: 001f.ca6b.d8c8

   Client-ID hex dump: 001FCA6BD8C8

   Hostname: Router

DHCP: SDiscover: sending 275 byte length DHCP packet

DHCP: SDiscover 275 bytes

            B'cast on FastEthernet4 interface from 0.0.0.0

DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x2DBE858E

DHCP: QScan: Timed out Selecting state

DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x2DBE858E%Unknown DHCP problem.. No allocation possible

DHCP: Waiting for 15 seconds on interface FastEthernet4

Syslog logging: enabled (1 messages dropped, 1 messages rate-limited,

                0 flushes, 0 overruns, xml disabled, filtering disabled)

    Console logging: level debugging, 288 messages logged, xml disabled,

                     filtering disabled

    Monitor logging: level debugging, 0 messages logged, xml disabled,

                     filtering disabled

    Buffer logging: disabled, xml disabled,

                    filtering disabled

    Logging Exception size (4096 bytes)

    Count and timestamp logging messages: disabled

No active filter modules.

    Trap logging: level informational, 30 message lines logged

Router(config-if)#do undebug  all

All possible debugging has been turned off

Router(config-if)#

DHCP: Received a BOOTREP pkt Not for us..:  xid: 0x14791A2A

Router(config-if)#exit

_________________________________________________________________________

Maybe this might be helpful:

Router#show ip route

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Vlan1

____________________________________________________________________________________

And once again the print screen of my other router configs where internet works. Maybe it is possible to use these settings instead of DHCP?

P.S. I don't know if it matters or not but my Modem's ip is 192.168.100.1 should've tried to ping it I guess...

hi david,

seems like your 871w can't get any dynamic IP: %Unknown DHCP problem.. No allocation possible

could you ask your ISP to perform a reset/clear MAC add and try again?

also, kindly post lastest 'show run'

edit: just saw you've updated your screenshot. could you add command under FE4

mac-add 0001.4af9.8b83

Wow, I think adding MAC to FA4 gid the trick! According to the ping from the router there is internet connection! But can't tell for sure, another problem appeared like I can't ping my router form PC and PC from the router!?

Latest show run:

Router#s

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0              unassigned      YES unset  up                    up

FastEthernet1              unassigned      YES unset  up                    down

FastEthernet2              unassigned      YES unset  up                    down

FastEthernet3              unassigned      YES unset  up                    down

FastEthernet4              76.114.54.255   YES DHCP   up                    up

Dot11Radio0                unassigned      YES TFTP   administratively down down

Vlan1                      192.168.1.1     YES NVRAM  up                    up

NVI0                       unassigned      YES unset  up                    up

Virtual-Dot11Radio0        unassigned      YES TFTP   administratively down down

Router#sh

Router#show run

Building configuration...

Current configuration : 2959 bytes

!

version 12.4

no service pad

no service timestamps debug uptime

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool DHCP_POOL

   import all

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 75.75.75.75 75.75.76.76

!

!

!

!

crypto pki trustpoint TP-self-signed-2115742889

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2115742889

revocation-check none

rsakeypair TP-self-signed-2115742889

!

!

crypto pki certificate chain TP-self-signed-2115742889

certificate self-signed 01

  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32313135 37343238 3839301E 170D3131 30393037 32313133

  30335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31313537

  34323838 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100CD81 CACC71A5 2A0A35C4 5A6598E9 A78B8167 11D2EA22 EA7C6B63 3D12AD5C

  671E5896 D3BA86CD AF2F9230 A8C1DBC9 65D529EC F9E44975 175A6554 EE3CE29E

  C3B6AB9E 2FDD5A55 4D1249CC 37101125 F55BC25D D9FF17C3 282DA1EF A2BA56F4

  3060E197 5C963A39 4ED08A8D C2CFB556 899D5D50 1FFF9F59 A9243C46 3F501566

  60950203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603

  551D1104 0B300982 07526F75 7465722E 301F0603 551D2304 18301680 14EEE106

  6C3A65DC E574C5A4 FEAD137B 2F950691 17301D06 03551D0E 04160414 EEE1066C

  3A65DCE5 74C5A4FE AD137B2F 95069117 300D0609 2A864886 F70D0101 04050003

  81810057 9E0A85A2 274C3B42 2D79FC55 CF70C7D0 AB3E3ABB 06310C37 80569306

  6C94D8D3 DAB3FFE2 D743FD3F DAF8CB5C DEF84219 07F942F9 CA2BF41B A5471257

  C9B12A20 F448B577 E162BDBC 6DCDBD41 E40AB3D2 AE5B50E9 713BB2D5 54B32602

  A06FFB2C BB96DF24 3B258827 BDFE4AFA 811912C1 37FFDAC8 AF1E0213 5A0A06C6 4BA6D5

  quit

username Point38 privilege 15 password 0 Terminal38

!

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

mac-address 0001.4af9.8b83

ip address dhcp client-id FastEthernet4

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Dot11Radio0

no ip address

shutdown

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip classless

!

!

ip http server

ip http secure-server

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

!

control-plane

!

alias exec s show ip int brief

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

_____________________________________________

Router#show int vlan1

Vlan1 is up, line protocol is up

  Hardware is EtherSVI, address is 001f.ca6b.d8be (bia 001f.ca6b.d8be)

  Internet address is 192.168.1.1/24

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:01, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1000 bits/sec, 1 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     3681 packets input, 329981 bytes, 0 no buffer

     Received 1697 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     682 packets output, 48756 bytes, 0 underruns

     0 output errors, 1 interface resets

     0 output buffer failures, 0 output buffers swapped out

______________________________________________

Router#show int fa4

FastEthernet4 is up, line protocol is up

  Hardware is PQUICC_FEC, address is 0001.4af9.8b83 (bia 001f.ca6b.d8c8)

  Internet address is 76.114.54.255/21

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, 100BaseTX/FX

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:01, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 3000 bits/sec, 8 packets/sec

  5 minute output rate 0 bits/sec, 1 packets/sec

     9332 packets input, 649471 bytes

     Received 8421 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog

     0 input packets with dribble condition detected

     1221 packets output, 217311 bytes, 0 underruns

     0 output errors, 0 collisions, 4 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

_______________________________________________

Router#ping 4.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/34/52 ms

Router#ping www.google.com

Translating "www.google.com"...domain server (75.75.75.75) [OK]

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 74.125.239.83, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 28/44/56 ms

Router#

Review Cisco Networking for a $25 gift card