cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
593
Views
0
Helpful
1
Replies
Highlighted
Beginner

Port Forwarding - WAN/LAN

Hello people good night.

All right?

I would like a help! I have a a router 1905 and a switch 3750 , I wanted to make a port forwarding to access my file server from WAN to LAN . I tried to do a NAT , but without success.

Follow my config Router:

version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CoelhoRouter
!
boot-start-marker
boot-end-marker
!
enable secret 5 --------------
enable password ---------
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp pool VLAN10
network 10.1.10.0 255.255.255.0
default-router 10.1.10.1
dns-server 10.1.10.1
domain-name CoelhoVLAN10
lease 0 0 3
!
ip dhcp pool VLAN20
network 10.1.20.0 255.255.255.0
default-router 10.1.20.1
dns-server 10.1.20.1
domain-name CoelhoVLAN20
lease 0 0 3
!
!
ip domain name coelho.com.br
ip name-server -------------
ip name-server --------------
ip ddns update method ---------
DDNS
interval maximum 2 0 0 0
!
multilink bundle-name authenticated
!

!
username ------- privilege 15 secret 5 ---------
username -------privilege 15 secret 5 ------------
!
!
ip ssh version 2
!
!
interface Loopback1
ip address 172.16.1.20 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/0.1
!
interface GigabitEthernet0/1
ip address 10.2.1.1 255.255.255.0
duplex full
speed auto
!
interface GigabitEthernet0/1.1
encapsulation dot1Q 1
ip address 10.1.1.1 255.255.255.0
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 10.1.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface GigabitEthernet0/1.20
encapsulation dot1Q 20 native
ip address 10.1.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
interface Dialer1
mtu 1492
ip ddns update hostname -------------
ip ddns update ---------
ip address negotiated
ip nat outside
ip nat enable
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname --------
ppp chap password 0 ------------
ppp pap sent-username ----------- password 0 -----------
ppp ipcp dns request accept
no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http access-class 1
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 10.1.10.16 3389 interface Dialer1 3389
ip route 0.0.0.0 0.0.0.0 ------------
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended HTTPS
permit tcp any any eq 443
ip access-list extended OUTSIDE
permit ip any any
!
access-list 1 permit 10.1.10.0 0.0.0.255
access-list 1 permit 10.1.20.0 0.0.0.255
access-list 101 permit udp any any eq domain
access-list 101 permit udp any eq domain any
access-list 103 permit tcp any eq 3389 host 10.1.10.16
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
password -------
logging synchronous
login
line aux 0
line vty 0 4
password --------
login local
transport input telnet ssh
!
scheduler allocate 20000 1000

end

If anyone can help me. Thank you.

Hugs,

Lucas Esteves

1 REPLY 1
Highlighted

Hi,

why do you have 2 default routes? Please make sure you have RDP enable on host 10.1.10.16.

other than that the configuration looks fine.