01-05-2016 12:29 AM - edited 03-05-2019 03:03 AM
Can any one help me to configure the PPPOE in FE interface on the mentioned router?
Regards ,
Jawhar.
Solved! Go to Solution.
01-05-2016 12:32 AM
what are you using chap or pap from ISP ? Did you get there credentials you will need them to authenticate on their line
Do you have a fixed public ip address or dynamic off them ?
01-05-2016 12:32 AM
what are you using chap or pap from ISP ? Did you get there credentials you will need them to authenticate on their line
Do you have a fixed public ip address or dynamic off them ?
01-05-2016 12:38 AM
HI Mark
Thank for your respond .
ISP provided me the credentials to authenticate the PPPOE and we dont have fixed public IP ,its dynamic only
Regards,
Jawhar
01-05-2016 12:57 AM
This is what you need obviously replace your ips , acl no etc and add your passwords and stuff but the syntax is what you need for pppoe to connect to ISP negotiate authentication and then pull itself an ip address
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
interface Ethernet0
description My LAN Interface
ip address 10.10.10.1 255.255.255.0
ip nat inside
!
no ip mroute-cache
no cdp enable
!
interface Ethernet1
description Physical ADSL Interface (Facing the ISP)
no ip address
pppoe enable
pppoe-client dial-pool-number 1
!
no cdp enable
!
interface Dialer1
description Logical ADSL Interface
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname [your username, provided by ISP]
ppp chap password 0 [your username password, given by ISP]
!
ip nat inside source list 10 interface Dialer1 overload
!
no ip http server
ip classless
!
access-list 10 permit 10.10.10.0 0.0.0.255
!
dialer-list 1 protocol ip permit
01-05-2016 06:28 AM
did you have any luck getting it up and running
01-05-2016 03:13 PM
Hii
First of all thanks for your support ,
As per the above configuration, i can enable vpdn but unable to configure pppoe under vpdn , then i tried the below configuration and the link became up and running
Building configuration...
Current configuration : 2693 bytes
!
! Last configuration change at 13:49:09 UTC Tue Jan 5 2016
! NVRAM config last updated at 14:23:24 UTC Tue Jan 5 2016
! NVRAM config last updated at 14:23:24 UTC Tue Jan 5 2016
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FRG
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
memory-size iomem 10
crypto pki token default removal timeout 0
!
!
ip source-route
!
!
!
!
ip dhcp pool FUR
network 192.168.8.0 255.255.255.0
default-router 192.168.8.1
dns-server 4.2.2.2 8.8.8.8
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO881W-GN-E-K9 sn FCZ1651C2KV
!
!
!
!
!
!
!
!
!
!
crypto ipsec client ezvpn
connect auto
group key
!
!
!
!
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
description #phisical WAN interface #
bandwidth inherit
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
duplex auto
speed auto
pppoe-client dial-pool-number 1
hold-queue 224 in
!
interface Virtual-Template1 type tunnel
no ip address
tunnel mode ipsec ipv4
!
interface wlan-ap0
description Service module interface to manage the embedded AP
no ip address
arp timeout 0
!
interface Wlan-GigabitEthernet0
description Internal switch interface connecting to the embedded AP
no ip address
!
interface Vlan1
ip address 192.168.8.1 255.255.255.0
ip nat inside
!
interface Dialer0
ip address negotiated
no ip redirects
no ip unreachables
ip directed-broadcast
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
ip verify unicast reverse-path
encapsulation ppp
ip tcp adjust-mss 1400
load-interval 30
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname
ppp chap password
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 10 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 10 permit 192.168.8.0 0.0.0.255
!
!
!
!
!
line con 0
password
login
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
line vty 0 4
password
login
transport input all
!
end
Regards,
Jawhar .
01-06-2016 12:24 AM
Ah great glad you got it sorted , some of the ISPs use that vpdn group but its not a necessity all the time as you seen for your setup :)
01-06-2016 03:58 AM
Thanks for your info.
02-21-2019 02:40 AM
Hi Guys,
I'm trying to configure PPOE on the WAN interface of the cisco 881w router. Issue is the WAN interface needs to be on VLAN 10. Can anyone advise?
02-21-2019 03:54 AM
Hello,
you need to use a subinterface. Post your current configuration so we can fill in the necessary bits and pieces...
02-21-2019 05:17 AM
02-21-2019 05:23 AM
Hello,
subinterface should look like below.
interface FastEthernet4.10
description #phisical WAN interface #
encapsulation dot1q 10
bandwidth inherit
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip flow ingress
duplex auto
speed auto
pppoe-client dial-pool-number 1
hold-queue 224 in
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide