10-23-2021 11:05 AM - edited 10-23-2021 11:08 AM
Hi, I am configuring a PPPoE server and it works correctly, but the pppoe clients receive as gateway address the one of the pppoe server router and I want to specify a different one.
In my scenario, I don't want the pppoe server to be the gateway, I want the gateway to be another router on the same network segment.
For example, the network is a 192.168.88.0/23
The pppoe server router has the IP address 192.168.88.19
When a client is authenticated by the pppoe server, it sends it an IP address and its gateway, but in my case the gateway is not 192.168.88.19, I want it to be another router that has the IP address 192.168.88.1.
I have tried to create a dhcp for the pppoe, in which I specify the default route, but it doesn't work, the server keeps assigning to the pppoe clients their ip address (192.168.88.19) instead of the gateway address I need (192.168.88.1).
This is the configuration:
------------------------------------
Router#show run
Building configuration...
Current configuration : 1615 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.88.1 192.168.88.20
!
ip dhcp pool dhcp_pool
network 192.168.88.0 255.255.255.0
default-router 192.168.88.1
dns-server 8.8.8.8 1.1.1.1
domain-name pppoe1
lease 0 0 10
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username hola password 0 hola1234
!
!
!
!
!
!
bba-group pppoe PPPoE
virtual-template 1
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 192.168.88.19 255.255.255.0
duplex auto
speed auto
pppoe enable group PPPoE
!
interface Virtual-Template1
mtu 1492
ip unnumbered Loopback0
peer default ip address dhcp-pool dhcp_pool
ppp authentication chap callin
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.88.1
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end
-----------------------------------
Could someone tell me how I can specify another gateway to the pppoe clients different from the pppoe server.
Thanks.
Solved! Go to Solution.
10-23-2021 07:45 PM
Hello @loperoniCCNA ,
what you see is normal and expected because PPPoE is based on PPP and PPP uses its own network control protocol IPCP to negotiate IP parameters with clients and it does not use DHCP at all.
It uses a local pool of addresses.
Probably using an external Radius server and using the appropriate AV pair you could provide a default gateway that is different from the IP address of PPPoE server.
However, think about PPPoE sessions: they are terminated on the PPPoE server that has to extract the IP packet inside the PPPoE frame and then it will route it.
So providing to clients a default gateway that is not the PPPoE server would be useless because:
the third party router cannot be simply resolved by ARP the PPPoE frame has destination MAC = PPPoE server MAC address.
In any case the client sends frames that need to be processed by PPPoE server as explained above , the third party router would simply discard the PPPoE frames if they would arrive directly at its interface.
Hope to help
Giuseppe
10-23-2021 07:45 PM
Hello @loperoniCCNA ,
what you see is normal and expected because PPPoE is based on PPP and PPP uses its own network control protocol IPCP to negotiate IP parameters with clients and it does not use DHCP at all.
It uses a local pool of addresses.
Probably using an external Radius server and using the appropriate AV pair you could provide a default gateway that is different from the IP address of PPPoE server.
However, think about PPPoE sessions: they are terminated on the PPPoE server that has to extract the IP packet inside the PPPoE frame and then it will route it.
So providing to clients a default gateway that is not the PPPoE server would be useless because:
the third party router cannot be simply resolved by ARP the PPPoE frame has destination MAC = PPPoE server MAC address.
In any case the client sends frames that need to be processed by PPPoE server as explained above , the third party router would simply discard the PPPoE frames if they would arrive directly at its interface.
Hope to help
Giuseppe
10-25-2021 01:12 AM
Thank you very much Giuseppe,
I have not thought that indeed the pppoe server encapsulates the frames.
I was thinking from the point of view of a service, for example in a network you can have a DHCP server that is not the gateway, but that answers dhcp requests, or a dns server that resolves DNS queries, but I had not thought that in the case of pppoe is different because the server adds the ppp header.
Thank you very much for your help.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide