cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1087
Views
5
Helpful
5
Replies
Highlighted
Beginner

PPPOE username

                   I am attempting to bring up a remote router using a pppoe connection by replacing the current Tenda 308R router with a Cisco 1921 using the ethernet connection on the WAN side.  The connection works fine with the Tenda in place but when I put the Cisco in I get no connection and no answer for my PADI queries.

I always get padi timer expired.  The error and config is below, Any Ideas?  I do not think it is even getting to the ppp authentication.

000832: *Oct 16 18:55:13 Bulg: pppoe_send_padi:

contiguous pak, size 60

         FF FF FF FF FF FF A4 4C 11 CE 3E C0 88 63 11 09

         00 00 00 10 01 01 00 00 01 03 00 08 97 00 00 02

         00 00 11 31 00 00 00 00 00 00 00 00 00 00 00 00

         00 00 00 00 00 00 00 00 00 00 00 00

000833: *Oct 16 18:55:46 Bulg:  padi timer expired

current config

interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

interface Dialer0

bandwidth 1000

ip address 1.1.1.1  255.255.255.0

ip mtu 1492

ip nat outside

ip inspect DEFAULT100 out

no ip virtual-reassembly in

encapsulation ppp

ip tcp adjust-mss 1300

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp chap hostname sfb

ppp chap password 7 095F5B07161503130D030B2E38

ppp pap sent-username sfb password 7 04481E080031584F0F160A1301

end

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Master

Keep circuit off for a while, or call ISP, they may have a lock or cache to the other router MAC address.

Otherwise you could try setting that MAC address on g0/0 as well.

Note, adjust-mss adjust should be 1452, not 1300. And pppoe enable is not needed.

For good performances, avoid 'ip inspect'.

View solution in original post

5 REPLIES 5
Highlighted
Beginner

Hi Steve,

it sounds like the other side is not responding.

Also, you are sending pap and chap.. which authentication is the other side using?

Can you do:

debug ppp authentication

debug pppoe errors

debug pppoe events

debug ppp negotiation

As a last resort, I would do "dialer persistant" under the Dialer config.

Nick Bonifacio CCIE #38473
Highlighted
Hall of Fame Master

Keep circuit off for a while, or call ISP, they may have a lock or cache to the other router MAC address.

Otherwise you could try setting that MAC address on g0/0 as well.

Note, adjust-mss adjust should be 1452, not 1300. And pppoe enable is not needed.

For good performances, avoid 'ip inspect'.

View solution in original post

Highlighted
Beginner

I will leave the connection open for 5 minutes and see if that produces any better results.  I have enabled the debugs but there is no information, i suspect this is because the padi never completes.

Highlighted

Hi Steve,

Paolo brings up a good point and I have actually had this happen to me.  The ISPs like to hold on to those macs for a long time, and in some instances they will even sticky them to the port.  You might want to call them and tell them you are changing out devices.

Thanks,

Nick

Nick Bonifacio CCIE #38473
Highlighted
Beginner

Thanks for the tip Paolo.  As soon as the ISP released the MAC the circuit came up.