04-03-2013 02:10 AM - edited 03-04-2019 07:28 PM
Can I configure Priority Queuing in Gigabit Interfaces of a router? or it will work only Serial interfaces?
Solved! Go to Solution.
04-03-2013 05:50 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
For QoS to prioritize, it needs to "see" congestion.
As Paolo has mentioned, first you'll want to shape. Then you can prioritize under the shaper.
To meet your requirements, something like:
ip access-list extended sample
permit ip host 192.168.10.1 any
permit ip host 192.168.10.2 any
class-map match-any sample
match access-group sample
policy-map sampleParent
class class-default
shape average 2000000
service-policy sampleChild
policy-map sampleChild
class sample
bandwidth percent 99
int g0/2
service-policy output sampleParent
04-03-2013 03:29 AM
First of all, "priority queueing" is an obsolete method of pseudo-QoS that should not be used anymore.
Then, describe you problem in full, e.g. you have a gigabit connection but the actual bandwith is 10 mpbs.
In that case you will need to configure shaping before queuing, there are many threads, you can search here or on cisco.com
04-03-2013 03:49 AM
I have a Wan Link of 2Mbps(with Ethernet output) connected in Gi0/2 of Cisco 2911.
Requirement:
I want to prioritize the traffic of two source ip's for eg: 192.168.10.1 & 10.2, like if it needs it should take the full 2 Mbps. If it doesn't need then others can utilize the available bw.
04-03-2013 04:10 AM
Answered above, you have to do MQC with LLC. Can use search function for many examples.
04-03-2013 05:50 AM
Disclaimer
The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
Liability Disclaimer
In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
Posting
For QoS to prioritize, it needs to "see" congestion.
As Paolo has mentioned, first you'll want to shape. Then you can prioritize under the shaper.
To meet your requirements, something like:
ip access-list extended sample
permit ip host 192.168.10.1 any
permit ip host 192.168.10.2 any
class-map match-any sample
match access-group sample
policy-map sampleParent
class class-default
shape average 2000000
service-policy sampleChild
policy-map sampleChild
class sample
bandwidth percent 99
int g0/2
service-policy output sampleParent
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide