cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
277
Views
0
Helpful
1
Replies

Problem with load sharing

laoussa07
Level 1
Level 1

Hi all,

   I have two ISP links one with a fix Ip address and I want to use them in a cisco 1900 router in load sharing and allow to my partner to acces to our server with FTP and use the IP fix.

  the problem is that i already used NAt but it seems that there is something messing in my configuration cause the server obtiens the non fixed IP address so our clients can't access to our server and if I use just the link with adsl IP fix it's working fine: can some one please help me to clear this probleme.

   my configuration is as follow:

 

 

! Last configuration change at 16:29:43 UTC Mon Sep 1 2014 by admin
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!

no aaa new-model
!
ip cef
!
!
!
!
!
!
ip domain name *******
no ipv6 cef
multilink bundle-name authenticated
!
!

!
controller VDSL 0/0/0
!
controller VDSL 0/1/0
!
ip ssh time-out 60
ip ssh logging events
ip ssh version 2
!
track 1 interface Dialer0 ip routing
!
track 2 interface Dialer1 ip routing
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip tcp adjust-mss 1452
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface Ethernet0/0/0
 no ip address
 shutdown
!
interface ATM0/1/0
 no ip address
 no atm ilmi-keepalive
 pvc 8/35
  pppoe-client dial-pool-number 2
 !
!
interface Ethernet0/1/0
 no ip address
 shutdown
!
interface Dialer0
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp chap hostname ***********
 ppp chap password **********
 ppp pap ********* password **************
 ppp multilink
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 2
 dialer-group 2
 ppp chap hostname ********
 ppp chap password ************
 ppp pap sent-username ******** password ****************
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source static tcp 192.168.2.200 21 interface Dialer0 21
ip nat inside source static udp 192.168.2.200 21 interface Dialer0 21
ip nat inside source static tcp 192.168.2.209 9092 interface Dialer0 9092
ip nat inside source static udp 192.168.2.209 9092 interface Dialer0 9092
ip nat inside source route-map adsl1 interface Dialer0 overload
ip nat inside source route-map adsl2 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer0 10 track 1
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 2
!
access-list 11 permit 192.168.2.0 0.0.0.255
!
route-map adsl2 permit 10
 match ip address 11
 match interface Dialer1
!
route-map adsl1 permit 10
 match ip address 11
 match interface Dialer0
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 password **************
 login local
 transport input ssh
!
scheduler allocate 20000 1000
!
end

 

 

 

this is an apercu of the sh ip route:

 

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
                is directly connected, Dialer0
      41.0.0.0/32 is subnetted, 3 subnets
C        41.141.64.1 is directly connected, Dialer0
C        41.251.32.1 is directly connected, Dialer1
C        41.251.37.7 is directly connected, Dialer1
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/0
L        192.168.2.1/32 is directly connected, GigabitEthernet0/0
      196.217.245.0/32 is subnetted, 1 subnets
C        196.217.245.125 is directly connected, Dialer0

 

#do sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down
GigabitEthernet0/0         192.168.2.1     YES NVRAM  up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down
ATM0/0/0                   unassigned      YES NVRAM  up                    up
Ethernet0/0/0              unassigned      YES NVRAM  administratively down down
ATM0/1/0                   unassigned      YES NVRAM  up                    up
Ethernet0/1/0              unassigned      YES NVRAM  administratively down down
Dialer0                    196.217.245.125 YES IPCP   up                    up
Dialer1                    41.251.37.7     YES IPCP   up                    up
NVI0                       192.168.2.1     YES unset  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    up

 

 

192.217.245.125 is the IP Public that we want to use to access remotly using ftp the server with the ip address 192.168.2.200 

 

 

thanks in advance.

 

1 Reply 1

Tagir Temirgaliyev
Spotlight
Spotlight

first of all you dont need udp 21

but you need tcp 20 too

 

ip nat inside source static tcp 192.168.2.200 21 interface Dialer0 21
no ip nat inside source static udp 192.168.2.200 21 interface Dialer0 21

ip nat inside source static tcp 192.168.2.200 20 interface Dialer0 20
 

 

not concernig two nat

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card