cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1188
Views
0
Helpful
4
Replies
Highlighted
Beginner

Problems with HSRP output

Hello dear all!!

I have the following topology::

Cisco 3845 gi0/0 -----   Foundry Switch---- fa0/0 Cisco 7206VXR

***CISCO 3845***

interface GigabitEthernet0/0
ip address 192.168.80.90 255.255.255.128
no ip proxy-arp
ip accounting output-packets
duplex full
speed 100
media-type rj45
standby 2 ip 192.168.80.89
standby 2 priority 130
service-policy input LAN


***CISCO 7206***

interface FastEthernet0/0
  ip address 192.168.80.91 255.255.255.128
no ip proxy-arp
ip summary-address eigrp 100 172.31.255.0 255.255.255.0 5
duplex full
speed 100
no cdp enable
standby 2 ip 192.168.80.89
standby 2 priority 150
standby 2 preempt delay minimum 60
standby 2 track Serial6/0 80
service-policy input LAN

This devices are running HSRP but i have been diagnostic the following output in both routers using "show standby"

show standby

***Cisco 3845***

FastEthernet0/0 - Group 2
  State is Active
    2 state changes, last state change 5w6d
  Virtual IP address is 192.168.80.89
  Active virtual MAC address is 0000.0c07.ac02
    Local virtual MAC address is 0000.0c07.ac02 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.488 secs
  Preemption enabled, delay min 60 secs
  Active router is local
  Standby router is unknown----------------------??????????????????
  Priority 150 (configured 150)
    Track interface Serial6/0 state Up decrement 80
  IP redundancy name is "hsrp-Fa0/0-2" (default)

show standy

***Cisco 7206VXR***

GigabitEthernet0/0 - Group 2
  State is Init (interface down)
  Virtual IP address is 192.168.80.89
  Active virtual MAC address is unknown
    Local virtual MAC address is 0000.0c07.ac02 (v1 default)
  Hello time 3 sec, hold time 10 sec
  Preemption disabled
  Active router is unknown----------------------????????
  Standby router is unknown----------------------????????
  Priority 130 (configured 130)
  Group name is "hsrp-Gi0/0-2" (default)

I can ping to both devices using Virtual ip address.
The work around to solve the lines "Active router is unknown and Standby router is unknown "  is to delete the hsrp configuration in Standby device, after that the problem is solved but is happend againd after some days.
The problem is that i dont have access to Foundry switch but i think that HSRP configuration don't have any problem, even in LogBuffer i didn't saw any problem related with HSRP.

Does any one have similar problem or any idea?

Thanks in addition

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

Re: Problems with HSRP output

Hi,

I'd try

a) Using HSRP ver 2 (see http://www.cisco.com/en/US/docs/ios/ipapp/configuration/guide/ipapp_hsrp_ps6922_TSD_Products_Configuration_Guide_Chapter.html#wp1102891 )

b) It looks a little stange to me you do have preemption configured  on one router only.

c) There might be some problems with your Foundry switch sending/receiving multicasts used by HSRP?

HTH,

Milan

View solution in original post

4 REPLIES 4
Advocate

Re: Problems with HSRP output

Hi,

I'd try

a) Using HSRP ver 2 (see http://www.cisco.com/en/US/docs/ios/ipapp/configuration/guide/ipapp_hsrp_ps6922_TSD_Products_Configuration_Guide_Chapter.html#wp1102891 )

b) It looks a little stange to me you do have preemption configured  on one router only.

c) There might be some problems with your Foundry switch sending/receiving multicasts used by HSRP?

HTH,

Milan

View solution in original post

Beginner

Re: Problems with HSRP output

***Cisco 7206VXR***

GigabitEthernet0/0 - Group 2

  State is Init (interface down)

In the 'init' state no hsrp packets are sent/received.   thats why there is no info listed for active/standby router.  The bigger question is why is gi0/0 on the 7206 down?  Could you repost sh standby output and running config for the 2 interfaces running hsrp again, seems like something isnt matching up right

Beginner

Re: Problems with HSRP output

Hi

What happens when you put a

standby 2 authentication xxxxxxx on? Does it follow the same 

I also wondering whats in you service-policy

Hall of Fame Master

Re: Problems with HSRP output

I agree with Milan that since the 7206 is configured with higher priority and is tracking an interface that the CISCO 3845 is the one that needs preempt. And my advice is that really both of the routers should be configured with preempt.

But I do not think that the fundamental problem is related to preempt or not preempt. I believe that the fundamental problem is that the interface of the 7206 appears to be down. Perhaps it would be helpful to have the output of show interface from the 7206.

HTH

Rick

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards