cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
555
Views
0
Helpful
6
Replies
Limitless1801
Beginner

QoS help!!!!

Hi,

I need some help with a QoS configuration I am trying to apply. I have two router R1 and R1 which are connected via Metro Ethernet. I have configured and applied the QoS configuration show below but as you can see R2 is not matching any of the traffic. The two configurations are identical. What am I doing wrong?

Thanks, RG

Router1

sh ip access-lists

Extended IP access list InternalApps-ACL

    130 permit ip host 172.16.1.46 any (236393444 matches)

    140 permit ip host 172.16.20.51 any (6363243 matches)

    150 permit ip host 172.16.20.52 any (6358344 matches)

    160 permit ip host 172.16.20.53 any (6748823 matches)

    170 permit ip host 172.16.20.54 any (5920358 matches)

    180 permit ip host 172.16.20.55 any (6648240 matches)

    190 permit ip host 172.16.20.56 any (8083640 matches)

    200 permit ip host 172.16.20.57 any (4520785 matches)

    210 permit ip host 172.16.20.58 any (14518513 matches)

    220 permit ip host 172.16.20.59 any (8527696 matches)

    230 permit ip host 172.16.1.123 any (322333615 matches)

    240 permit ip host 172.16.1.124 any (2243133 matches)

class-map match-any VCONTROL

match ip dscp cs3  af31

class-map match-any InternalApps

match access-group name InternalApps-ACL

class-map match-any VOICE-VIDEO

match ip dscp af41  ef

!        

!        

policy-map VGENERIC

class VOICE-VIDEO

  priority percent 40

class VCONTROL

  bandwidth percent 5

class InternalApps

  bandwidth percent 30

class class-default

  fair-queue

interface GigabitEthernet0/1

bandwidth 10000

no ip address

service-policy output VGENERIC

duplex auto

speed auto

!        

interface GigabitEthernet0/1.1896

bandwidth 10000

encapsulation dot1Q 1896

ip address 10.10.10.1 255.255.255.0

----------------------------

Router2

b28-metroe-2851#sh ip access-list InternalApps-ACL

Extended IP access list InternalApps-ACL

    130 permit ip host 172.16.1.46 any

    140 permit ip host 172.16.20.51 any

    150 permit ip host 172.16.20.52 any

    160 permit ip host 172.16.20.53 any

    170 permit ip host 172.16.20.54 any

    180 permit ip host 172.16.20.55 any

    190 permit ip host 172.16.20.56 any

    200 permit ip host 172.16.20.57 any

    210 permit ip host 172.16.20.58 any

    220 permit ip host 172.16.20.59 any

    230 permit ip host 172.16.1.123 any

    240 permit ip host 172.16.1.124 any

class-map match-any VCONTROL

match ip dscp cs3  af31

class-map match-any InternalApps

match access-group name InternalApps-ACL

class-map match-any VOICE-VIDEO

match ip dscp af41  ef

!

!

policy-map VGENERIC

class VOICE-VIDEO

  priority percent 40

class VCONTROL

  bandwidth percent 5

class InternalApps

  bandwidth percent 30

class class-default

  fair-queue

interface GigabitEthernet0/1

bandwidth 10000

no ip address

ip route-cache flow

duplex auto

speed auto

service-policy output VGENERIC

!        

interface GigabitEthernet0/1.1896

description MetroE

bandwidth 10000

encapsulation dot1Q 1896

ip address 10.10.10.3 255.255.255.0

6 REPLIES 6
pompeychimes
Enthusiast

Shouldn't your ACL on R2 be reversed. I believe you are listing your destination IP's as your source.

James

Sorry. They are. I grabbed the wrong list:

10 permit ip any host 172.16.1.46

    20 permit ip any host 172.16.20.51

    30 permit ip any host 172.16.20.52

    40 permit ip any host 172.16.20.53

    50 permit ip any host 172.16.20.54

    60 permit ip any host 172.16.20.55

    70 permit ip any host 172.16.20.56

    80 permit ip any host 172.16.20.57

    90 permit ip any host 172.16.20.58

    100 permit ip any host 172.16.20.59

    110 permit ip any host 172.16.1.123

    120 permit ip any host 172.16.1.124

Thanks, RG

Shouldn't the policy map be on your LAN interface?

Julio Tenorio
Beginner

Looks like you need a hierarquical Qos policy.

Please check http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a0080114326.shtml

Cheers

Cheers, Julio Sá
Joseph W. Doherty
Hall of Fame Expert

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Believe you'll want the policy applied on your subinterface.  For how, see Julio's reference.

Below are the outputs for the show policy-map interface g0/1. What's confusing me is that it seems to be working on R1 but not in R2 and it's been applied in the same place. When I try to apply on the sub interface, I get the following message:

CBWFQ : Not supported on subinterfaces

I'll take a look at Julio's link and I'll post the results back.

Thanks, RG

Router1

sh policy-map int g0/1 GigabitEthernet0/1

  Service-policy output: VGENERIC

    Class-map: VOICE-VIDEO (match-any)

      9077 packets, 8793813 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp af41  ef

        9077 packets, 8793813 bytes

        5 minute rate 0 bps

      Queueing

        Strict Priority

        Output Queue: Conversation 264

        Bandwidth 40 (%)

        Bandwidth 4000 (kbps) Burst 100000 (Bytes)

        (pkts matched/bytes matched) 110/92913

        (total drops/bytes drops) 0/0

    Class-map: VCONTROL (match-any)

      13636 packets, 6008897 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp cs3  af31

        13636 packets, 6008897 bytes

        5 minute rate 0 bps

      Queueing

        Output Queue: Conversation 265

        Bandwidth 5 (%)

        Bandwidth 500 (kbps) Max Threshold 64 (packets)

        (pkts matched/bytes matched) 299/47840

        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: InternalApps (match-any)

      92269127 packets, 94901895532 bytes

      5 minute offered rate 173000 bps, drop rate 0 bps

      Match: access-group name InternalApps-ACL

        92269123 packets, 94901890335 bytes

        5 minute rate 173000 bps

      Queueing

        Output Queue: Conversation 266

        Bandwidth 30 (%)

        Bandwidth 3000 (kbps) Max Threshold 64 (packets)

        (pkts matched/bytes matched) 3302419/4111735471

        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)

      532143302 packets, 401265872472 bytes

      5 minute offered rate 35000 bps, drop rate 0 bps

      Match: any

      Queueing

        Flow Based Fair Queueing

        Maximum Number of Hashed Queues 256

        (total queued/total drops/no-buffer drops) 0/0/0

--------------------------------

Router2

sh policy-map int g0/1    

GigabitEthernet0/1

  Service-policy output: VGENERIC

    Class-map: VOICE-VIDEO (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp af41 (34) ef (46)

        0 packets, 0 bytes

        5 minute rate 0 bps

      Queueing

        Strict Priority

        Output Queue: Conversation 264

        Bandwidth 40 (%)

        Bandwidth 4000 (kbps) Burst 100000 (Bytes)

        (pkts matched/bytes matched) 0/0

        (total drops/bytes drops) 0/0

    Class-map: VCONTROL (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: ip dscp cs3 (24) af31 (26)

        0 packets, 0 bytes

        5 minute rate 0 bps

      Queueing

        Output Queue: Conversation 265

        Bandwidth 5 (%)

        Bandwidth 500 (kbps)Max Threshold 64 (packets)

        (pkts matched/bytes matched) 0/0

        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: InternalApps (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: access-group name InternalApps-ACL

        0 packets, 0 bytes

        5 minute rate 0 bps

      Queueing

        Output Queue: Conversation 266

        Bandwidth 30 (%)

        Bandwidth 3000 (kbps)Max Threshold 64 (packets)

        (pkts matched/bytes matched) 0/0

        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)

      0 packets, 0 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

      Queueing

        Flow Based Fair Queueing

        Maximum Number of Hashed Queues 256

        (total queued/total drops/no-buffer drops) 0/0/0