cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4584
Views
0
Helpful
8
Replies

Redistribute 0.0.0.0 0.0.0.0 route only on Eigrp

Mero Cisco
Level 1
Level 1

Hi,

I have configured the eigrp routing protocol. At the main router I have many static routes and I want to redistribute only the default route (0.0.0.0 0.0.0.0). But now every static route is distributed on each router. How to distribute the default route only.

I have got the backup router of the main router and I want to redistribute the R1 default route only to other routers and in the failure of R2 I want to redistribue the R2 default route to other routers. The destination of default route of R1 and R2 is different. Is this possible or not.

Regards,

Mero

3 Accepted Solutions

Accepted Solutions

Hi, which autonomous system number are you using?

On R1 - whichever interface you want to advertise the default route out of:

interface gi0/1

ip summary-address eigrp # 0.0.0.0 0.0.0.0

Where the #(hash) is your autonomous system number.

If you want R2 to advertise a default route too but with R1 being prefered you can do this on R2:

interface gi0/1

ip summary-address eigrp # 0.0.0.0 0.0.0.0 200

This provides the higher AD of 200, so R1 will be prefered, if R1 was to go down, the R2's default route will be there as the backup.

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

View solution in original post

Hi,

if you want to redistribute the default route only:

ip prefix-list REDIST_STATIC permit 0.0.0.0/0

route-map REDIST_STATIC permit 10

match ip add prefix REDIST_STATIC

router eigrp 10

redistribute static route-map REDIST_STATIC

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Abzal
Level 7
Level 7

Hi,

You will just need to redistribute default routes on both R1/R2 routers but R1 will have better metric. And in case of failure R1 router other routers will accept R2's default route. First you will need to tune metric on both routers to make sure that R1 has better metric than R2.

Here is simple config:

R1:

router eigrp 1

redistribute static route-map test

no auto-summary

ip route 0.0.0.0 0.0.0.0 y.y.y.y

ip prefix-list Default description Default_Only

ip prefix-list Default seq 5 permit 0.0.0.0/0

!

route-map test permit 10

match ip address prefix-list Default

set metric 10000 1 255 1 1500

R2:

router eigrp 1

redistribute static route-map test

no auto-summary

ip route 0.0.0.0 0.0.0.0 x.x.x.x

ip prefix-list Default description Default_Only

ip prefix-list Default seq 5 permit 0.0.0.0/0

!

route-map test permit 10

match ip address prefix-list Default

set metric 10000 1000 255 1 1500

Verification on some other router:

sh ip eigrp top 0.0.0.0/0

There you should see two routes second route from R2 as backup.

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal

View solution in original post

8 Replies 8

Bilal Nawaz
VIP Alumni
VIP Alumni

Instead of redistributing statics you can summarise on your eigrp interfaces like this:

interface gi0/1

ip summary-address eigrp 10 0.0.0.0 0.0.0.0

This will advertise the default to connected eigrp neighbors (Where '10' is your autonomous system No.)

hope this helps

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Hi Nawaz,

I have already done that, but it doesn't shows the default route on the remote side. I added the ip summary-address eigrp 10 0.0.0.0 0.0.0.0 to an interface and check the route with sho ip route eigrp at remote side the scenario doesn't change, how to solve this one.

Regards

Hi, which autonomous system number are you using?

On R1 - whichever interface you want to advertise the default route out of:

interface gi0/1

ip summary-address eigrp # 0.0.0.0 0.0.0.0

Where the #(hash) is your autonomous system number.

If you want R2 to advertise a default route too but with R1 being prefered you can do this on R2:

interface gi0/1

ip summary-address eigrp # 0.0.0.0 0.0.0.0 200

This provides the higher AD of 200, so R1 will be prefered, if R1 was to go down, the R2's default route will be there as the backup.

Hope this helps.

Please rate useful posts and remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Hi,

if you want to redistribute the default route only:

ip prefix-list REDIST_STATIC permit 0.0.0.0/0

route-map REDIST_STATIC permit 10

match ip add prefix REDIST_STATIC

router eigrp 10

redistribute static route-map REDIST_STATIC

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Abzal
Level 7
Level 7

Hi,

You will just need to redistribute default routes on both R1/R2 routers but R1 will have better metric. And in case of failure R1 router other routers will accept R2's default route. First you will need to tune metric on both routers to make sure that R1 has better metric than R2.

Here is simple config:

R1:

router eigrp 1

redistribute static route-map test

no auto-summary

ip route 0.0.0.0 0.0.0.0 y.y.y.y

ip prefix-list Default description Default_Only

ip prefix-list Default seq 5 permit 0.0.0.0/0

!

route-map test permit 10

match ip address prefix-list Default

set metric 10000 1 255 1 1500

R2:

router eigrp 1

redistribute static route-map test

no auto-summary

ip route 0.0.0.0 0.0.0.0 x.x.x.x

ip prefix-list Default description Default_Only

ip prefix-list Default seq 5 permit 0.0.0.0/0

!

route-map test permit 10

match ip address prefix-list Default

set metric 10000 1000 255 1 1500

Verification on some other router:

sh ip eigrp top 0.0.0.0/0

There you should see two routes second route from R2 as backup.

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal

Hi Abzal,

Thanks for your reply. I need to shut down the eigrp routing table at the remote site on the high latency of ping response and on ping packet loss. Is this possible directly with eigrp. If not, how can I integrate this with IP SLA. Please explain with a simple example.

Thanks for your response in advance.

Regards,

Mero

Hi Mero,

More information will be useful in order to give you solution in your situation. I have in my head one solution but there might better solution. Info like interconnections of routers,topology.

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal

Dear Abzal,

At the branch end I have implemented two routing policy, one is dynamic (ospf or eigrp) and another is static. All of my trafic flows through the main router. On the failure of dynamic routing the routers works through static route. Some of the connection at the remote site is very poor. The packet loss and high latency is the main problem. Now, I am looking for the technique to automatically shut down the WAN interface according to the high latency and packet loss of more than 5% and vice versa. If the WAN interface gets shut down the static route becomes active. Is their any technique to do this through dynamic routing. Can I use IP SLA for this task, how ?

Thanks in advance for your kind cooperation.

Regards,

Mero

Review Cisco Networking for a $25 gift card